- Update to 0.47
PR: 146305 Submitted by: Ports Fury
This commit is contained in:
parent
829870f564
commit
1f82a7e4df
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=253996
@ -7,33 +7,40 @@
|
||||
#
|
||||
|
||||
PORTNAME= sam2p
|
||||
PORTVERSION= 0.45
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.47
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.inf.bme.hu/~pts/
|
||||
DISTNAME= ${PORTNAME}-latest
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Converts raster (bitmap) image formats into PS or PDF files
|
||||
|
||||
BUILD_DEPENDS= tif22pnm:${PORTSDIR}/graphics/tif22pnm \
|
||||
tifftopnm:${PORTSDIR}/graphics/netpbm \
|
||||
zip:${PORTSDIR}/archivers/zip \
|
||||
bash:${PORTSDIR}/shells/bash
|
||||
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
|
||||
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
|
||||
cjpeg:${PORTSDIR}/graphics/jpeg \
|
||||
tif22pnm:${PORTSDIR}/graphics/tif22pnm
|
||||
|
||||
USE_GHOSTSCRIPT_RUN= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
PLIST_FILES= bin/sam2p
|
||||
USE_PERL5_BUILD= yes
|
||||
USE_GHOSTSCRIPT_RUN= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= ac_cv_path_pts_bash="${SH}"
|
||||
MAKE_ARGS= CXXX="${CXX}" LDALL="${CXX}" CXXFLAGSB="${CXXFLAGS}"
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sam2p ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (sam2p-latest.tar.gz) = a4a02ab538485914327261ca4a7fb631
|
||||
SHA256 (sam2p-latest.tar.gz) = 2a26a9fedb40a20bb8ccfefd7fcd8552a259e8b333583a53ff70020d4364f292
|
||||
SIZE (sam2p-latest.tar.gz) = 548637
|
||||
MD5 (sam2p-0.47.tar.gz) = 2f1acc6bc1f24d51c2906ce080f20687
|
||||
SHA256 (sam2p-0.47.tar.gz) = 6e0cdab2b78124084a01cfb41fc5e42c0666c9103d7bf4f7c860f4406e051d23
|
||||
SIZE (sam2p-0.47.tar.gz) = 558936
|
||||
|
11
graphics/sam2p/files/patch-gensh.hpp
Normal file
11
graphics/sam2p/files/patch-gensh.hpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- gensi.hpp.orig 2008-05-27 03:58:43.000000000 +0900
|
||||
+++ gensi.hpp 2010-03-19 05:53:15.000000000 +0900
|
||||
@@ -252,7 +252,7 @@
|
||||
if (len!=0) block(beg,len,data);
|
||||
block(0,0,data);
|
||||
}
|
||||
- inline virtual void first_sub(Sub &sub) const { sub.beg=beg; sub.len=len; };
|
||||
+ inline virtual void first_sub(Sub &sub) const { sub.beg=beg; sub.len=len; }
|
||||
inline virtual void next_sub(Sub &sub) const { sub.len=0; }
|
||||
inline char const*getCString() const { return beg; }
|
||||
inline char const*operator()() const { return beg; }
|
13
graphics/sam2p/files/patch-ps_tiny.c
Normal file
13
graphics/sam2p/files/patch-ps_tiny.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- ps_tiny.c.orig 2005-02-22 08:22:22.000000000 +0900
|
||||
+++ ps_tiny.c 2010-03-19 05:54:19.000000000 +0900
|
||||
@@ -1,10 +1,3 @@
|
||||
-#define DUMMY \
|
||||
-set -ex; \
|
||||
-gcc -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused \
|
||||
- -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline \
|
||||
- -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes \
|
||||
- -Wmissing-declarations ps_tiny.c -o ps_tiny; \
|
||||
-exit
|
||||
/* ps_tiny.c -- read .pin files, write short PostScript code
|
||||
* by pts@fazekas.hu at Sat Aug 24 12:46:14 CEST 2002
|
||||
* -- Sat Aug 24 18:23:08 CEST 2002
|
13
graphics/sam2p/files/patch-pts_defl.c
Normal file
13
graphics/sam2p/files/patch-pts_defl.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- pts_defl.c.orig 2008-08-29 05:16:47.000000000 +0900
|
||||
+++ pts_defl.c 2010-03-19 05:54:55.000000000 +0900
|
||||
@@ -1,10 +1,3 @@
|
||||
-#define DUMMY \
|
||||
-set -ex; \
|
||||
-"${CC:-gcc}" -DNDEBUG=1 -DPTS_DEFL_MAIN -O3 -ansi \
|
||||
- -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline \
|
||||
- -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes \
|
||||
- -Wmissing-declarations pts_defl.c -o flateenc; \
|
||||
-exit
|
||||
/*
|
||||
* pts_defl.c -- C source file ZIP compression ripped from linux-2.6.8.1
|
||||
* by pts@fazekas.hu at Tue Jan 18 15:19:06 CET 2005
|
13
graphics/sam2p/files/patch-pts_lzw.c
Normal file
13
graphics/sam2p/files/patch-pts_lzw.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- pts_lzw.c.orig 2002-12-12 01:43:08.000000000 +0900
|
||||
+++ pts_lzw.c 2010-03-19 05:56:24.000000000 +0900
|
||||
@@ -1,10 +1,3 @@
|
||||
-#define DUMMY \
|
||||
-set -ex; \
|
||||
-g++ -DNDEBUG=1 -O3 -ansi -pedantic \
|
||||
- -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline \
|
||||
- -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes \
|
||||
- -Wmissing-declarations pts_lzw.c -c; \
|
||||
-exit
|
||||
/* pts_lzw.c -- a real, effective implementation of PostScript
|
||||
* LanguageLevel2 and PDF /LZWEncode and /LZWDecode filters (same as the LZW
|
||||
* compression used in TIFF raster image files)
|
@ -6,4 +6,4 @@ cases sam2p can compress an image 100 times smaller than the PostScript output
|
||||
of many other common image converters. sam2p provides ZIP, RLE and LZW
|
||||
(de)compression filters even on Level1 devices.
|
||||
|
||||
WWW: http://www.inf.bme.hu/~pts/sam2p/
|
||||
WWW: http://code.google.com/p/sam2p/
|
||||
|
Loading…
Reference in New Issue
Block a user