Add cadubi-1.1b1

CADUBI is an application written in Perl that allows you to
draw text-based images that are viewable on typical unix-based
consoles.  Usually the applications that emulate these
consoles support various text modes, such as background and
foreground colors, bold, and inverse.  This text art, commonly
called "ASCII art," is used in various places such as online
BBSes, email and login prompts.

Obtained from:	OpenBSD
This commit is contained in:
Kris Kennaway 2001-08-25 07:17:59 +00:00
parent 6d3a00d005
commit 1f7ae535a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46852
8 changed files with 86 additions and 0 deletions

View File

@ -16,6 +16,7 @@
SUBDIR += avifile
SUBDIR += backfract
SUBDIR += blender
SUBDIR += cadubi
SUBDIR += camediaplay
SUBDIR += camserv
SUBDIR += chbg

29
graphics/cadubi/Makefile Normal file
View File

@ -0,0 +1,29 @@
# Ports collection makefile for: cadubi
# Date created: 24 Aug 2001
# Whom: Kris Kennaway <kris@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= cadubi
PORTVERSION= 1.1b1
CATEGORIES= graphics editors
MASTER_SITES= ftp://logicallemon.com/pub/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cadubi ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/CADUBI.pl ${PREFIX}/libexec
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cadubi
${INSTALL_DATA} ${WRKSRC}/CADUBI.help ${PREFIX}/share/doc/cadubi
.endif
.include <bsd.port.mk>

1
graphics/cadubi/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (cadubi_1.1b1.tar.gz) = 1645579fa6db7cfbea5810fc32548622

View File

@ -0,0 +1,32 @@
--- CADUBI.pl.orig Thu Jan 27 03:54:45 2000
+++ CADUBI.pl Sun Jul 29 01:10:28 2001
@@ -59,6 +59,7 @@ $AUDIBLE = 1; # beep unless -m, --mute
$status_changed = 1; # used with &status so we don't constantly redraw.
$current_filename = undef; # name of file we're working with
$cadubi_done = 0; # main loop var
+$Helpfile = $Bin . "/../share/doc/cadubi";
# runtime statements
&initKeys(); # setup %controlkeys and %keymap
@@ -716,10 +717,10 @@ sub HandleKeystroke {
# help
if (ord($key) == $keymap{'^h'}) { #Help
- if (-e $Bin.'/CADUBI.help') {
+ if (-e $Helpfile.'/CADUBI.help') {
my @oldmap = @charmap;
my @oldpos = @pos;
- &readfile($Bin.'/CADUBI.help');
+ &readfile($Helpfile.'/CADUBI.help');
&status('Press a key to continue...', 1);
my $temp = ReadKey(0);
@charmap = @oldmap;
@@ -729,7 +730,7 @@ sub HandleKeystroke {
&status;
} else {
&beep;
- &status("'".$Bin."/CADUBI.help' not available");
+ &status("'".$Helpfile."/CADUBI.help' not available");
}
return 0;
}

View File

@ -0,0 +1,9 @@
--- cadubi.orig Thu Jan 27 03:54:51 2000
+++ cadubi Sun Jul 29 01:10:59 2001
@@ -32,5 +32,5 @@ use FindBin qw($Bin); use lib "$Bin/../l
my $CADUBI_Arguments = undef;
$CADUBI_Arguments .= ' --mute' unless $AUDIBLE;
$CADUBI_Arguments .= ' '.$ADD_OPS if $ADD_OPS;
-exec ('perl '.$Bin.'/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));
+exec ('perl '.$Bin.'/../libexec/CADUBI.pl'.$CADUBI_Arguments.' '.join(' ',@ARGV));

View File

@ -0,0 +1 @@
ASCII drawing utility

View File

@ -0,0 +1,9 @@
CADUBI is an application written in Perl that allows you to
draw text-based images that are viewable on typical unix-based
consoles. Usually the applications that emulate these
consoles support various text modes, such as background and
foreground colors, bold, and inverse. This text art, commonly
called "ASCII art," is used in various places such as online
BBSes, email and login prompts.
WWW: http://www.logicallemon.com/cadubi/

View File

@ -0,0 +1,4 @@
bin/cadubi
libexec/CADUBI.pl
%%PORTDOCS%%share/doc/cadubi/CADUBI.help
%%PORTDOCS%%@dirrm share/doc/cadubi