Add wmflame 0.60, a dockapp that shows the load average as a flame.

PR:		38135
Submitted by:	Alexey Dokuchaev <danfe@regency.nsu.ru>
This commit is contained in:
Pete Fritchman 2002-05-31 12:47:07 +00:00
parent 543139973f
commit 1f52337813
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60375
7 changed files with 70 additions and 0 deletions

View File

@ -209,6 +209,7 @@
SUBDIR += wmcube
SUBDIR += wmcube-gdk
SUBDIR += wmfire
SUBDIR += wmflame
SUBDIR += wmfsm
SUBDIR += wmhm
SUBDIR += wminet

23
sysutils/wmflame/Makefile Normal file
View File

@ -0,0 +1,23 @@
# New ports collection makefile for: wmflame
# Date created: 16 May 2002
# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
#
# $FreeBSD$
#
PORTNAME= wmflame
PORTVERSION= 0.60
CATEGORIES= sysutils
MASTER_SITES= http://web.novalis.org/programs/
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/wmflame.app/${PORTNAME}
USE_GMAKE= yes
USE_XPM= yes
USE_X_PREFIX= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmflame ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (wmflame-0.60.tar.gz) = a9de2b284d95cc9933ce9ba869a6fa67

View File

@ -0,0 +1,38 @@
$FreeBSD$
--- Makefile.orig Tue Jun 15 17:11:20 1999
+++ Makefile Thu May 16 11:38:12 2002
@@ -1,21 +1,20 @@
-INCDIR = -I/usr/X11R6/include
-LIBDIR = -L/usr/X11R6/lib
-LIBS = -lXpm -lXext -lX11
-OBJS = wmflame.o ../wmgeneral/wmgeneral.o
+CC ?= gcc
+CFLAGS += -c -Wall
+INCDIR = -I${X11BASE}/include
+LIBDIR = -L${X11BASE}/lib
+LIBS = -lXpm -lXext -lX11
+OBJS = wmflame.o ../wmgeneral/wmgeneral.o
.c.o:
- cc -c -g -O3 -Wall -D$(shell echo `uname -s`) $< -o $*.o $(INCDIR)
-
-all: wmflame
+ ${CC} ${CFLAGS} ${INCDIR} -D${shell echo `uname -s`} $< -o $*.o
wmflame: $(OBJS)
- cc -o wmflame $^ $(LIBDIR) $(LIBS)
+ ${CC} -o wmflame $^ ${LIBDIR} ${LIBS}
+
+all: wmflame
clean:
- for i in $(OBJS) ; do \
+ for i in ${OBJS}; do \
rm -f $$i; \
done
- rm -f wmflame
-
-install:
- mv wmflame /usr/local/bin
+ rm -f wmflame core

View File

@ -0,0 +1 @@
A dockapp that shows the load average as a flame

View File

@ -0,0 +1,5 @@
WindowMaker dockapp showing load average as a flame. Can also
be used in AfterStep. Allows user to change lots of the flame
characteristics.
WWW: http://web.novalis.org/

View File

@ -0,0 +1 @@
bin/wmflame