- Fix build with clang 4.0 by not defining __linux__
- Add LICENSE - Switch to options helpers - Regenerate patches PR: 216651 Submitted by: jbeich@FreeBSD.org
This commit is contained in:
parent
234accb6b6
commit
1f375c4cca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433038
@ -11,9 +11,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Fast paced multiplayer pac-man clone
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -D__linux__
|
||||
USES= gmake localbase
|
||||
USE_SDL= mixer image net sdl
|
||||
|
||||
PORTDOCS= *
|
||||
@ -34,9 +36,12 @@ post-extract:
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/var/lib/games|/var/games|' \
|
||||
${WRKSRC}/src/njam.cpp
|
||||
@${REINPLACE_CMD} -e 's,#ifdef __linux__,#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__),; \
|
||||
s,#ifndef __linux__,#if !defined(__linux__) \&\& !defined(__FreeBSD__) \&\& !defined(__DragonFly__),' \
|
||||
${WRKSRC}/src/*.cpp ${WRKSRC}/src/*.h
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/html/* ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/njamedit.cpp.orig 2008-06-26 22:38:47.000000000 +0000
|
||||
--- src/njamedit.cpp.orig 2008-06-26 22:38:47 UTC
|
||||
+++ src/njamedit.cpp
|
||||
@@ -114,7 +114,7 @@ void NjamEngine::LevelEditor()
|
||||
key = SDLK_a;
|
||||
|
Loading…
Reference in New Issue
Block a user