Update to 1.0.1

This commit is contained in:
Antoine Brodin 2017-04-30 10:45:06 +00:00
parent 209e817953
commit 1f2800dc44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439798
8 changed files with 15 additions and 24 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= unicorn
PORTVERSION= 1.0
PORTVERSION= 1.0.1
CATEGORIES= emulators python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1487917142
SHA256 (unicorn-engine-unicorn-1.0_GH0.tar.gz) = 27efa24e465f3eca9a1fa8f7f456f6fecd91beeba0b4be21b34308040047def9
SIZE (unicorn-engine-unicorn-1.0_GH0.tar.gz) = 3214697
TIMESTAMP = 1492722479
SHA256 (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3a6a4f2b8c405ab009040ca43af8e4aa10ebe44d9c8b336aa36dc35df955017c
SIZE (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3241225

View File

@ -1,6 +1,6 @@
# Do not bundle libunicorn.so
--- setup.py.orig 2017-02-23 12:57:14 UTC
--- setup.py.orig 2017-04-20 06:14:24 UTC
+++ setup.py
@@ -260,11 +260,4 @@ setup(
'Programming Language :: Python :: 3',

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= unicorn
PORTVERSION= 1.0
PORTVERSION= 1.0.1
CATEGORIES= emulators
MAINTAINER= antoine@FreeBSD.org
@ -19,7 +19,7 @@ USES= gmake python:2.7,build
USE_LDCONFIG= yes
MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
UNICORN_QEMU_FLAGS=--python=${PYTHON_CMD} \
MAKE_JOBS_NUMBER=${MAKE_JOBS_NUMBER} \
SMP_MFLAGS=-j${MAKE_JOBS_NUMBER} \
V=1
TEST_TARGET= test
TEST_WRKSRC= ${WRKSRC}/tests/unit

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1487917142
SHA256 (unicorn-engine-unicorn-1.0_GH0.tar.gz) = 27efa24e465f3eca9a1fa8f7f456f6fecd91beeba0b4be21b34308040047def9
SIZE (unicorn-engine-unicorn-1.0_GH0.tar.gz) = 3214697
TIMESTAMP = 1492722479
SHA256 (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3a6a4f2b8c405ab009040ca43af8e4aa10ebe44d9c8b336aa36dc35df955017c
SIZE (unicorn-engine-unicorn-1.0.1_GH0.tar.gz) = 3241225

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2017-02-23 12:57:14 UTC
--- Makefile.orig 2017-04-20 06:14:24 UTC
+++ Makefile
@@ -62,9 +62,9 @@ V ?= 0
@@ -72,9 +72,9 @@ V ?= 0
MACOS_UNIVERSAL ?= yes
ifeq ($(UNICORN_DEBUG),yes)
@ -12,7 +12,7 @@
UNICORN_QEMU_FLAGS += --disable-debug-info
endif
@@ -171,7 +171,7 @@ LIBDIRARCH ?= lib
@@ -181,7 +181,7 @@ LIBDIRARCH ?= lib
# Or better, pass 'LIBDIRARCH=lib64' to 'make install/uninstall' via 'make.sh'.
#LIBDIRARCH ?= lib64
@ -21,12 +21,3 @@
INCDIR ?= $(PREFIX)/include
BINDIR ?= $(PREFIX)/bin
@@ -204,7 +204,7 @@ qemu/config-host.h-timestamp:
cd qemu && \
./configure --cc="${CC}" --extra-cflags="$(UNICORN_CFLAGS)" --target-list="$(UNICORN_TARGETS)" ${UNICORN_QEMU_FLAGS}
printf "$(UNICORN_ARCHS)" > config.log
- $(MAKE) -C qemu -j 4
+ $(MAKE) -C qemu -j $(MAKE_JOBS_NUMBER)
$(eval UC_TARGET_OBJ += $$(wildcard qemu/util/*.o) $$(wildcard qemu/*.o) $$(wildcard qemu/qom/*.o) $$(wildcard qemu/hw/core/*.o) $$(wildcard qemu/qapi/*.o) $$(wildcard qemu/qobject/*.o))
unicorn: $(LIBRARY) $(ARCHIVE)

View File

@ -1,4 +1,4 @@
--- qemu/configure.orig 2017-02-23 12:57:14 UTC
--- qemu/configure.orig 2017-04-20 06:14:24 UTC
+++ qemu/configure
@@ -229,11 +229,11 @@ QEMU_CFLAGS="-Wstrict-prototypes -Wredun
QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"

View File

@ -1,4 +1,4 @@
--- tests/unit/Makefile.orig 2017-02-23 12:57:14 UTC
--- tests/unit/Makefile.orig 2017-04-20 06:14:24 UTC
+++ tests/unit/Makefile
@@ -1,6 +1,6 @@
CFLAGS += -Wall -Werror -Wno-unused-function -g