Fix bad C++ code, to unbreak on 5.X and -CURRENT.

Reported by:	kris
Approved by:	portmgr (marcus), fjoe (mentor, implicit)
This commit is contained in:
Alexey Dokuchaev 2004-09-20 19:34:58 +00:00
parent c515694159
commit 1f16f5e923
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118304
3 changed files with 28 additions and 7 deletions

View File

@ -20,14 +20,8 @@ RUN_DEPENDS= dotty:${PORTSDIR}/graphics/graphviz
USE_GMAKE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -8,3 +8,12 @@
#ifndef __make_dep__
#include <string>
@@ -91,7 +92,7 @@
{
list<T*> result=ld1;
- for(list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
+ for(typename list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
result.push_back(*i);
return result;

View File

@ -8,3 +8,21 @@
string indent(unsigned);
@@ -21,7 +22,7 @@
template <class T>
bool contains(list<T>& l, const T& t)
{
- for(list<T>::iterator li = l.begin(); li != l.end(); li++)
+ for(typename list<T>::iterator li = l.begin(); li != l.end(); li++)
if((*li) == t)
return true;
return false;
@@ -31,7 +32,7 @@
list<T> intersect(list<T>& l1, list<T>& l2)
{
list<T> result;
- for(list<T>::iterator li = l1.begin(); li != l1.end(); li++)
+ for(typename list<T>::iterator li = l1.begin(); li != l1.end(); li++)
if(contains(l2, *li))
result.push_back(*li);