Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
This commit is contained in:
parent
7cb0f3c9b4
commit
1ee4da6dd1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=423014
@ -10,7 +10,7 @@
|
||||
|
||||
.if !defined(_INCLUDE_USES_LIBARCHIVE_MK)
|
||||
_INCLUDE_USES_LIBARCHIVE_MK= yes
|
||||
.include "${USESDIR}/localbase.mk"
|
||||
_USES_POST+= localbase
|
||||
|
||||
LIB_DEPENDS+= libarchive.so.13:archivers/libarchive
|
||||
.endif
|
||||
|
@ -10,7 +10,7 @@
|
||||
|
||||
.if !defined(_INCLUDE_USES_LIBEDIT_MK)
|
||||
_INCLUDE_USES_LIBEDIT_MK= yes
|
||||
.include "${USESDIR}/localbase.mk"
|
||||
_USES_POST+= localbase
|
||||
|
||||
LIB_DEPENDS+= libedit.so.0:devel/libedit
|
||||
.endif
|
||||
|
@ -3,18 +3,27 @@
|
||||
# handle enforcing localbase in path
|
||||
#
|
||||
# Feature: localbase
|
||||
# Usage: USES=localbase
|
||||
# Valid ARGS: none
|
||||
# Usage: USES=localbase or USES=localbase:args
|
||||
# Valid ARGS: ldflags Set LDFLAGS instead of LIBS
|
||||
#
|
||||
# MAINTAINER: portmgr@FreeBSD.org
|
||||
|
||||
.if !defined(_INCLUDE_USES_LOCALBASE_MK)
|
||||
_INCLUDE_USES_LOCALBASE_MK= yes
|
||||
_USES_POST+= localbase
|
||||
.endif
|
||||
|
||||
.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_LOCALBASE_POST_MK)
|
||||
_INCLUDE_USES_LOCALBASE_POST_MK=yes
|
||||
|
||||
CPPFLAGS+= -isystem ${LOCALBASE}/include
|
||||
CFLAGS+= -isystem ${LOCALBASE}/include
|
||||
CXXFLAGS+= -isystem ${LOCALBASE}/include
|
||||
.if ${localbase_ARGS:Mldflags}
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
.else
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
.endif
|
||||
|
||||
# Use CONFIGURE_ENV instead of CMAKE_ARGS because devel/cmake itself also needs
|
||||
# this, and CMAKE_ARGS is not used when bootstrapping CMake.
|
||||
|
@ -15,7 +15,7 @@ LICENSE= ZLIB
|
||||
|
||||
LIB_DEPENDS= libzopfli.so:archivers/zopfli
|
||||
|
||||
USES= cpe gmake localbase
|
||||
USES= cpe gmake localbase:ldflags
|
||||
CPE_VENDOR= zlib
|
||||
ALL_TARGET= dev
|
||||
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Extract Makeself archives
|
||||
|
||||
USES= libarchive
|
||||
LDFLAGS+= -larchive
|
||||
LIBS+= -larchive
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
PLIST_FILES= bin/unmakeself
|
||||
@ -26,7 +26,7 @@ do-configure:
|
||||
|
||||
do-build:
|
||||
${CC} ${CFLAGS} ${CPPFLAGS} -I${WRKSRC} -o ${WRKSRC}/unmakeself \
|
||||
${FILESDIR}/unmakeself.c ${LDFLAGS}
|
||||
${FILESDIR}/unmakeself.c ${LDFLAGS} ${LIBS}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unmakeself ${STAGEDIR}/${PREFIX}/bin
|
||||
|
@ -22,6 +22,6 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= cmake localbase tar:xz
|
||||
USES= cmake localbase:ldflags tar:xz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -24,7 +24,7 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-g |$$(CPPFLAGS) | ; \
|
||||
s|-O2 || ; \
|
||||
s|-ldl |$$(LDFLAGS) |' ${WRKSRC}/Makefile
|
||||
s|-ldl |$$(LDFLAGS) $$(LIBS) |' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/listener ${WRKSRC}/setlistener \
|
||||
|
@ -13,7 +13,7 @@ LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= libpng.so:graphics/png
|
||||
|
||||
USES= jpeg localbase pkgconfig waf
|
||||
USES= jpeg localbase:ldflags pkgconfig waf
|
||||
USE_GL= egl gl glesv2
|
||||
CONFIGURE_ARGS= --with-flavors=x11-gl,x11-glesv2 --no-opt --no-debug
|
||||
WAF_CMD= ./waf -v
|
||||
|
@ -90,8 +90,7 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
|
||||
PKGINSTALL?= ${PKGDIR}/pkg-install-server
|
||||
.else
|
||||
# Client part stuff
|
||||
USES+= libedit
|
||||
LDFLAGS+= -L${LOCALBASE}/lib # to link in lncurses pulled in by libedit
|
||||
USES+= libedit
|
||||
|
||||
CONFIGURE_ARGS+= --with-system-editline
|
||||
CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
|
||||
|
@ -24,7 +24,7 @@ CPPFLAGS+= -DOS_FREEBSD
|
||||
MAKE_ENV= CXX=${CXX}
|
||||
USE_CXXSTD= c++11
|
||||
USE_LDCONFIG= yes
|
||||
USES= compiler:c++11-lib gmake localbase
|
||||
USES= compiler:c++11-lib gmake localbase:ldflags
|
||||
|
||||
PORTDATA= make_config.mk
|
||||
|
||||
|
@ -46,7 +46,7 @@ GTK2_USE= gnome=gtk20
|
||||
GTK2_MAKE_ENV= UI_TYPE=gtk
|
||||
|
||||
QT4_USE= qt4=gui,corelib,imageformats,network,moc_build
|
||||
QT4_LDFLAGS= -L${QT_LIBDIR}
|
||||
QT4_LIBS= -L${QT_LIBDIR}
|
||||
QT4_MAKE_ENV= UI_TYPE=qt4
|
||||
|
||||
post-patch:
|
||||
@ -58,7 +58,7 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e 's/-llinebreak/-lunibreak/g' ${WRKSRC}/makefiles/*.mk
|
||||
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/fbreader/desktop/Makefile
|
||||
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's,make ,gmake ,'
|
||||
-e 's,make ,$$(MAKE) ,' -e '/$$(LDFLAGS)/s/$$/ $$(LIBS)/'
|
||||
|
||||
pre-configure:
|
||||
# This cannot be done in post-patch because build dependencies are installed
|
||||
|
@ -14,8 +14,8 @@ LICENSE= GPLv2
|
||||
LIB_DEPENDS= libinotify.so:devel/libinotify \
|
||||
libqt5keychain.so:security/qtkeychain-qt5
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lib gmake iconv localbase \
|
||||
pkgconfig sqlite ssl
|
||||
USES= cmake:outsource compiler:c++11-lib gmake iconv \
|
||||
localbase:ldflags pkgconfig sqlite ssl
|
||||
USE_QT5= buildtools_build concurrent core dbus gui linguist_build network \
|
||||
qmake_build sql webkit widgets xml
|
||||
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=OFF \
|
||||
|
15
devel/efivar/files/patch-Make.rules
Normal file
15
devel/efivar/files/patch-Make.rules
Normal file
@ -0,0 +1,15 @@
|
||||
--- Make.rules.orig 2014-10-15 13:48:49 UTC
|
||||
+++ Make.rules
|
||||
@@ -2,10 +2,10 @@
|
||||
$(AR) -cvqs $@ $^
|
||||
|
||||
% : %.o
|
||||
- $(CCLD) $(ccldflags) -o $@ $^ $(foreach lib,$(LIBS),-l$(lib))
|
||||
+ $(CCLD) $(ccldflags) -o $@ $^ $(LIBS)
|
||||
|
||||
%.so.$(SONAME_VERSION) :
|
||||
- $(CCLD) $(cflags) -Wl,-soname,$(SONAME) $(ccldflags) $(LIBFLAGS) $^ -o $@ $(foreach lib,$(LIBS),-l$(lib))
|
||||
+ $(CCLD) $(cflags) -Wl,-soname,$(SONAME) $(ccldflags) $(LIBFLAGS) $^ -o $@ $(LIBS)
|
||||
|
||||
%.so : %.so.$(SONAME_VERSION)
|
||||
ln -sf $^ $@
|
@ -1,6 +1,6 @@
|
||||
--- src/Makefile.orig 2015-01-19 15:35:31.000000000 +0100
|
||||
+++ src/Makefile 2015-01-19 15:35:42.000000000 +0100
|
||||
@@ -15,7 +15,6 @@ all : $(LIBTARGETS) $(PCTARGETS) $(BINTA
|
||||
--- src/Makefile.orig 2014-10-15 13:48:49 UTC
|
||||
+++ src/Makefile
|
||||
@@ -15,14 +15,13 @@ all : $(LIBTARGETS) $(PCTARGETS) $(BINTA
|
||||
OBJECTS = lib.o vars.o efivarfs.o guid.o guidlist.o guid-symbols.o
|
||||
DEPS = .lib.c.P .efivar.c.P .efivar.h.P .vars.c.P .lib.h.P \
|
||||
.generics.h.P .guid.h.P .guid.c.P
|
||||
@ -8,3 +8,11 @@
|
||||
|
||||
libefivar.a :: $(OBJECTS)
|
||||
|
||||
libefivar.so.$(SONAME_VERSION) :: $(OBJECTS)
|
||||
|
||||
efivar : efivar.o libefivar.so
|
||||
- $(CCLD) $(ccldflags) -L. -lefivar -o $@ $^ -lpopt $(foreach lib,$(LIBS),-l$(lib))
|
||||
+ $(CCLD) $(ccldflags) -L. -lefivar -o $@ $^ -lpopt $(LIBS)
|
||||
|
||||
efivar.pc : efivar.pc.in
|
||||
sed -e "s,@@VERSION@@,$(VERSION),g" \
|
||||
|
11
devel/efivar/files/patch-src-test-Makefile
Normal file
11
devel/efivar/files/patch-src-test-Makefile
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/test/Makefile.orig 2014-10-15 13:48:49 UTC
|
||||
+++ src/test/Makefile
|
||||
@@ -4,7 +4,7 @@ TOPDIR = $(realpath $(SRCDIR)/../..)
|
||||
include $(TOPDIR)/Make.defaults
|
||||
|
||||
ccldflags += -L$(TOPDIR)/src/ -Wl,-rpath=$(TOPDIR)/src/
|
||||
-LIBS=efivar
|
||||
+LIBS = -lefivar
|
||||
|
||||
all : tester
|
||||
|
@ -13,7 +13,7 @@ LICENSE= ZLIB
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.txt
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake iconv libtool localbase pathfix pkgconfig
|
||||
USES= gmake iconv libtool localbase:ldflags pathfix pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CONFIGURE_ARGS+= --disable-video-opengles \
|
||||
|
@ -25,7 +25,7 @@ ETCDNSCRYPTWRAPPER= ${PREFIX}/etc/${PORTNAME}
|
||||
SUB_LIST+= ETCDNSCRYPTWRAPPER="${ETCDNSCRYPTWRAPPER}" USERS="${USERS}"
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
|
||||
USES= gmake localbase
|
||||
USES= gmake localbase:ldflags
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/*
|
||||
|
@ -64,7 +64,8 @@ SQLITE_CONFIGURE_ON= --with-sqlite3
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/SVNREV\//s|^|#| ; \
|
||||
s|/-liconv} -liconv|}| ; \
|
||||
s|LIBS="-liconv"|LIBS="-liconv $$LIBS"| ; \
|
||||
s|/-liconv}|}| ; \
|
||||
s|"-Wl,-rpath,"|""| ; \
|
||||
s|\[\[ |[ |g ; \
|
||||
s| \]\]| ]|g ; \
|
||||
|
@ -27,7 +27,7 @@ GH_TAGNAME?= cdf4a8d:lang 1ffab37:ext_armips
|
||||
|
||||
CONFLICTS_INSTALL= ${PORTNAME}-*
|
||||
|
||||
USES= compiler:c++11-lib localbase pkgconfig
|
||||
USES= compiler:c++11-lib localbase:ldflags pkgconfig
|
||||
EXCLUDE= glew snappy libzip zlib
|
||||
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
|
||||
USE_GL= glew glu
|
||||
|
@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/bg-installer:devel/bglibs
|
||||
LIB_DEPENDS= libcvm-v2client.so:security/cvm
|
||||
|
||||
USES= localbase
|
||||
USES= localbase:ldflags
|
||||
|
||||
BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
|
||||
BGLIBS_INCLUDE= ${LOCALBASE}/include/bglibs
|
||||
|
@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:devel/argp-standalone
|
||||
|
||||
USES= gmake localbase
|
||||
USES= gmake localbase:ldflags
|
||||
USE_GNOME= gtk12
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
|
@ -19,7 +19,7 @@ BROKEN_FreeBSD_9= does not build # revisit when ports gcc is switched to 4.9
|
||||
|
||||
USE_GITHUB= yes
|
||||
|
||||
USES= compiler:c++11-lib jpeg localbase openal scons
|
||||
USES= compiler:c++11-lib jpeg localbase:ldflags openal scons
|
||||
USE_SDL= sdl2
|
||||
USE_GL= gl glew
|
||||
INSTALLS_ICONS= yes
|
||||
|
@ -19,7 +19,7 @@ LICENSE_COMB= multi
|
||||
LICENSE_FILE_GPLv20= ${WRKSRC}/doc/gpl.txt
|
||||
LICENSE_FILE_CC-BY-SA-3.0= ${WRKSRC}/doc/cc-by-sa.txt
|
||||
|
||||
USES= localbase zip
|
||||
USES= localbase:ldflags zip
|
||||
USE_GL= gl
|
||||
BUILD_WRKSRC= ${WRKSRC}/src
|
||||
MAKEFILE= Makefile.lnx
|
||||
|
@ -12,7 +12,7 @@ COMMENT= X11 shoot-'em up which requires some lateral thinking
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USES= gmake localbase tar:bzip2
|
||||
USES= gmake localbase:ldflags tar:bzip2
|
||||
USE_GL= glut
|
||||
MAKE_ARGS= CC="${CC}" CPP="${CXX}" CC_FLAGS="${CXXFLAGS}" \
|
||||
LIB_FLAGS="${LDFLAGS}" GCC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
@ -20,7 +20,8 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
|
||||
libvorbis.so:audio/libvorbis \
|
||||
libogg.so:audio/libogg
|
||||
|
||||
USES= dos2unix gmake localbase openal:al pkgconfig python tar:bzip2
|
||||
USES= dos2unix gmake localbase:ldflags openal:al pkgconfig python \
|
||||
tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USE_SDL= sdl
|
||||
USE_GL= glut
|
||||
|
@ -24,7 +24,7 @@ CONFIGURE_ENV= ac_cv_header_sys_termios_h=no \
|
||||
ac_cv_header_db_h=no
|
||||
|
||||
ALL_TARGET= bmpp
|
||||
USES= gmake jpeg localbase
|
||||
USES= gmake jpeg localbase:ldflags
|
||||
|
||||
PLIST_FILES= bin/bmpp
|
||||
|
||||
|
@ -15,7 +15,7 @@ LICENSE= GPLv2
|
||||
LIB_DEPENDS= libexpat.so:textproc/expat2 \
|
||||
liblcms.so:graphics/lcms
|
||||
|
||||
USES= localbase scons tar:bzip2
|
||||
USES= localbase:ldflags scons tar:bzip2
|
||||
USE_GCC= any # segfaults on exit when built with Clang
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
@ -12,15 +12,16 @@ COMMENT= Decoder for RAW files from digital cameras
|
||||
LIB_DEPENDS= libjasper.so:graphics/jasper \
|
||||
liblcms2.so:graphics/lcms2
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include/jasper
|
||||
LDFLAGS+= -ljasper -ljpeg -llcms2 -lm
|
||||
CPPFLAGS+= -I${LOCALBASE}/include/jasper
|
||||
LIBS+= -ljasper -ljpeg -llcms2 -lm
|
||||
USES= jpeg localbase tar:xz
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
man/man1/${PORTNAME}.1.gz
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
|
||||
@cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CPPFLAGS} ${CFLAGS} \
|
||||
${PORTNAME}.c ${LDFLAGS} ${LIBS}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
|
@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
TEST_TARGET= check
|
||||
USE_LDCONFIG= yes
|
||||
USES= libtool localbase pathfix
|
||||
USES= libtool localbase:ldflags pathfix
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
|
@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
TEST_TARGET= check
|
||||
USE_LDCONFIG= yes
|
||||
USES= libtool localbase pathfix
|
||||
USES= libtool localbase:ldflags pathfix
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
|
@ -15,7 +15,7 @@ LICENSE= LGPL21+
|
||||
LIB_DEPENDS= libftgl.so:graphics/ftgl \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= cmake localbase
|
||||
USES= cmake localbase:ldflags
|
||||
CMAKE_ARGS= -DUSE_OPENMP=OFF # openmp breaks build on 11.x
|
||||
USE_GL= glew
|
||||
USE_LDCONFIG= yes
|
||||
|
@ -22,7 +22,9 @@ NO_WRKSUBDIR= yes
|
||||
PLIST_FILES= bin/pngrewrite
|
||||
|
||||
do-build:
|
||||
${CC} ${CFLAGS} ${LDFLAGS} -lm -lpng -lz -o ${WRKSRC}/pngrewrite ${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c
|
||||
${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} ${LIBS} -lm -lpng -lz \
|
||||
${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c \
|
||||
-o ${WRKSRC}/pngrewrite
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/pngrewrite ${STAGEDIR}${PREFIX}/bin/
|
||||
|
@ -1,13 +1,29 @@
|
||||
--- configure.orig 2012-08-08 11:59:15.000000000 +0200
|
||||
+++ configure 2012-08-08 11:59:45.000000000 +0200
|
||||
@@ -20271,8 +20271,8 @@
|
||||
--- configure.orig 2016-07-24 22:14:28 UTC
|
||||
+++ configure
|
||||
@@ -20556,7 +20556,7 @@ fi
|
||||
|
||||
ac_save_USER_INCLUDES="$USER_INCLUDES"
|
||||
ac_save_USER_LDFLAGS="$USER_LDFLAGS"
|
||||
- USER_INCLUDES="$USER_INCLUDES $LIBJPEG_CFLAGS"
|
||||
- USER_LDFLAGS="$USER_LDFLAGS $LIBJPEG_CFLAGS"
|
||||
+ USER_INCLUDES="$USER_INCLUDES $LIBJPEG_CFLAGS $CPPFLAGS"
|
||||
+ USER_LDFLAGS="$USER_LDFLAGS $LIBJPEG_LDFLAGS $LDFLAGS"
|
||||
ac_save_CPPFLAGS="$CPPFLAGS"
|
||||
ac_save_CXXFLAGS="$CXXFLAGS"
|
||||
-ac_save_LIBS="$LDFLAGS"
|
||||
+ac_save_LIBS="$LIBS"
|
||||
CPPFLAGS="$CPPFLAGS $LIBTIFF_CFLAGS"
|
||||
CXXFLAGS="$CXXFLAGS $LIBTIFF_CFLAGS"
|
||||
LIBS="$LIBS $LIBTIFF_LIBS"
|
||||
@@ -21387,7 +21387,7 @@ if ${ac_cv_lib_jpeg_6b+:} false; then :
|
||||
else
|
||||
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="$all_libraries $USER_LDFLAGS -ljpeg6b -lm"
|
||||
+LIBS="$LIBS $USER_LDFLAGS -ljpeg6b -lm"
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $all_includes $USER_INCLUDES"
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -21438,7 +21438,7 @@ if ${ac_cv_lib_jpeg_normal+:} false; the
|
||||
else
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libjpeg6b" >&5
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="$all_libraries $USER_LDFLAGS -ljpeg -lm"
|
||||
+LIBS="$LIBS $USER_LDFLAGS -ljpeg -lm"
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS $all_includes $USER_INCLUDES"
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
|
@ -27,7 +27,7 @@ CONFIGURE_ARGS= --enable-python
|
||||
CONFIGURE_ENV= PYTHON_LDFLAGS="-L${PYTHON_LIBDIR} -l${PYTHON_VERSION}${PYTHON_ABIVER}"
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
USES= autoreconf libtool localbase python
|
||||
USES= autoreconf libtool localbase:ldflags python
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/py_ext
|
||||
INSTALL_WRKSRC= ${WRKSRC}/py_ext
|
||||
|
18
mail/libetpan/files/patch-configure.ac
Normal file
18
mail/libetpan/files/patch-configure.ac
Normal file
@ -0,0 +1,18 @@
|
||||
--- configure.ac.orig 2016-05-26 05:27:47 UTC
|
||||
+++ configure.ac
|
||||
@@ -313,13 +313,13 @@ if test x$enable_iconv = xyes; then
|
||||
saved_LIBS="$LIBS"
|
||||
for lib in iconv ; do
|
||||
if test "x$ICONV_LINKED" = "x0" ; then
|
||||
- LIBS=-l$lib
|
||||
+ LIBS="-l$lib $saved_LIBS"
|
||||
AC_TRY_LINK([#include <stdlib.h>
|
||||
#include <iconv.h>],
|
||||
[iconv_t cd = iconv_open("","");
|
||||
iconv(cd,NULL,NULL,NULL,NULL);
|
||||
iconv_close(cd);],
|
||||
- [LIBICONV="$LIBS" ; ICONV_LINKED=1],
|
||||
+ [LIBICONV="-l$lib" ; ICONV_LINKED=1],
|
||||
[])
|
||||
fi
|
||||
done
|
@ -81,6 +81,7 @@ DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s/\`date/\`gdate/" ${WRKSRC}/Makefile.am ${WRKSRC}/doc/Makefile.am
|
||||
@${REINPLACE_CMD} '/LIBS=$$/d' ${WRKSRC}/configure.ac
|
||||
|
||||
post-install:
|
||||
${RM} -f ${STAGEDIR}${PREFIX}/etc/mime*
|
||||
|
@ -12,16 +12,14 @@ COMMENT= Incoming mail monitor dockapp with a similar look to wmcpuload
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= gmake localbase pkgconfig tar:bzip2
|
||||
USES= gmake localbase:ldflags pkgconfig ssl tar:bzip2
|
||||
USE_XORG= xpm
|
||||
USE_GNOME= gtk20
|
||||
USE_OPENSSL= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}
|
||||
MAKE_ENV= DEBUG_CFLAGS="-I${OPENSSLINC}" \
|
||||
DEBUG_LDFLAGS="-L${OPENSSLLIB}"
|
||||
|
||||
CFLAGS+= -D_GNU_SOURCE
|
||||
CPPFLAGS+= -I${OPENSSLINC} -D_GNU_SOURCE
|
||||
LDFLAGS+= -L${OPENSSLLIB}
|
||||
MAKE_ENV= DEBUG_CFLAGS="" DEBUG_LDFLAGS=""
|
||||
|
||||
PLIST_FILES= bin/wmmaiload bin/wmmaiload-config \
|
||||
man/man1/wmmaiload.1.gz man/man1/wmmaiload-config.1.gz
|
||||
|
@ -24,7 +24,7 @@ PORTDOCS= Changelog README
|
||||
NLS_MAKE_ARGS= WITHOUT_GETTEXT=0
|
||||
NLS_MAKE_ARGS_OFF= WITHOUT_GETTEXT=1
|
||||
NLS_LDFLAGS= -lintl
|
||||
NLS_USES= gettext localbase
|
||||
NLS_USES= gettext localbase:ldflags
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/gnu/*.o
|
||||
|
@ -58,8 +58,6 @@ USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --disable-ldvgrab
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CPPFLAGS+= -fPIC
|
||||
|
||||
DOC_FILES= AUTHORS BUGS ChangeLog FEATURES GETTING.STARTED README \
|
||||
OMC/lives-OMC.txt RFX/LiVES-Perl.odt RFX/rfxbuilder.odt \
|
||||
RFX/RFX.spec docs/clip_format.txt \
|
||||
@ -79,6 +77,8 @@ NLS_USES= gettext-tools
|
||||
NLS_CONFIGURE_OFF= --disable-nls
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
|
||||
's/^LIBS = $$/&@LIBS@/'
|
||||
@${REINPLACE_CMD} -e 's| install-docDATA||g; s|-$$(VERSION)||g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|: install-data-local |: |g; s|-ldl||' \
|
||||
|
@ -24,7 +24,8 @@ GH_TAGNAME= waf-1.9.3:waf
|
||||
|
||||
WAF_CMD= ${WRKSRC_waf}/waf-light
|
||||
|
||||
USES= compiler:c11 desktop-file-utils iconv jpeg localbase pkgconfig python:build waf
|
||||
USES= compiler:c11 desktop-file-utils iconv jpeg localbase:ldflags \
|
||||
pkgconfig python:build waf
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CONFIGURE_ARGS= --docdir=${EXAMPLESDIR} \
|
||||
|
@ -13,7 +13,7 @@ COMMENT= Simple encoder using OpenQuicktime (TM)
|
||||
|
||||
LIB_DEPENDS= libopenquicktime.so:multimedia/openquicktime
|
||||
|
||||
USES= localbase tar:tgz
|
||||
USES= localbase:ldflags tar:tgz
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
PLIST_FILES= bin/oqtencoder
|
||||
|
@ -32,7 +32,7 @@ CMAKE_ARGS= -DBUNDLED_LIBS=OFF \
|
||||
LDFLAGS+= ${ICONV_LIB} -lnet -lpcap
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= bison cmake:outsource cpe iconv localbase pkgconfig
|
||||
USES= bison cmake:outsource cpe iconv localbase:ldflags pkgconfig
|
||||
|
||||
DOCS= AUTHORS CHANGELOG README README.BINARIES README.BUGS \
|
||||
README.GIT README.PLATFORMS THANKS TODO TODO.TESTING \
|
||||
|
@ -11,7 +11,7 @@ COMMENT= GTK based Gnutella client
|
||||
|
||||
LICENSE= GPLv2+
|
||||
|
||||
USES= iconv localbase pkgconfig tar:bzip2
|
||||
USES= iconv localbase:ldflags pkgconfig tar:bzip2
|
||||
USE_GNOME= glib20 libxml2
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
|
20
net-p2p/transmission-cli/files/patch-configure
Normal file
20
net-p2p/transmission-cli/files/patch-configure
Normal file
@ -0,0 +1,20 @@
|
||||
--- configure.orig 2016-03-06 20:24:37 UTC
|
||||
+++ configure
|
||||
@@ -19348,7 +19348,7 @@ $as_echo_n "checking µTP... " >&6; }
|
||||
build_utp="no"
|
||||
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lutp"
|
||||
+LIBS="-lutp $LIBS"
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
#include <libutp/utp.h>
|
||||
@@ -19423,7 +19423,7 @@ $as_echo "$build_utp" >&6; }
|
||||
|
||||
|
||||
ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lminiupnpc"
|
||||
+LIBS="-lminiupnpc $LIBS"
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking system miniupnpc library" >&5
|
||||
$as_echo_n "checking system miniupnpc library... " >&6; }
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- daemon/Makefile.in.orig 2015-04-15 08:35:09 UTC
|
||||
+++ daemon/Makefile.in
|
||||
@@ -141,7 +141,7 @@ am__v_CC_1 =
|
||||
CCLD = $(CC)
|
||||
LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
|
||||
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
+ $(LDFLAGS) $(AM_LDFLAGS) -o $@
|
||||
AM_V_CCLD = $(am__v_CCLD_@AM_V@)
|
||||
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
|
||||
am__v_CCLD_0 = @echo " CCLD " $@;
|
@ -46,9 +46,9 @@ LDFLAGS+= -lm
|
||||
IGNORE= base OpenSSL in FreeBSD 9 is too old, specify a ports version of SSL by adding DEFAULT_VERSIONS+=ssl=... to /etc/make.conf and rebuild everything that needs SSL
|
||||
. else
|
||||
CONFIGURE_ENV+= libcrypto_CFLAGS="-I${OPENSSLINC}" \
|
||||
libcrypto_LIBS="-L${OPENSSLLIB} -lcrypto" \
|
||||
libcrypto_LIBS="${OPENSSLLIB}/libcrypto.so" \
|
||||
libssl_CFLAGS="-I${OPENSSLINC}" \
|
||||
libssl_LIBS="-L${OPENSSLLIB} -lssl"
|
||||
libssl_LIBS="${OPENSSLLIB}/libssl.so"
|
||||
. endif
|
||||
.endif
|
||||
|
||||
|
@ -16,7 +16,6 @@ USE_LDCONFIG= yes
|
||||
USES= tar:xz gmake libtool localbase pkgconfig
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --localstatedir=/var
|
||||
|
||||
INFO= dico
|
||||
|
||||
@ -54,7 +53,10 @@ post-patch:
|
||||
@${REINPLACE_CMD} 's/@bindir@/@sbindir@/' ${WRKSRC}/dicod/Makefile.in
|
||||
@${REINPLACE_CMD} 's/(bindir)..dir/&\/gdico/' ${WRKSRC}/dico/Makefile.in
|
||||
@${REINPLACE_CMD} '/INSTALL.*charset/d' ${WRKSRC}/gnu/Makefile.in
|
||||
@${REINPLACE_CMD} 's/python-config/$${PYTHON_CONFIG}/' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's/mu_check_lib_save_LIBS/LIBS/' \
|
||||
-e 's/python-config/$${PYTHON_CONFIG}/' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} 's/conf.5in dico/conf.5 dico/' ${WRKSRC}/doc/Makefile.in
|
||||
|
||||
post-install:
|
||||
|
@ -18,7 +18,7 @@ RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= bklang
|
||||
|
||||
USES= gmake localbase perl5 shebangfix
|
||||
USES= gmake localbase:ldflags perl5 shebangfix
|
||||
SHEBANG_FILES= scripts/*.pl
|
||||
USE_PERL5= run
|
||||
USE_OPENLDAP= yes
|
||||
|
@ -18,8 +18,8 @@ LIB_DEPENDS= libevent.so:devel/libevent2 \
|
||||
|
||||
CONFLICTS= ntp-[0-9].* ntp-rc-*
|
||||
|
||||
USES= cpe pathfix shebangfix libedit libtool pkgconfig ssl \
|
||||
gettext-runtime
|
||||
USES= cpe pathfix shebangfix libedit libtool localbase:ldflags \
|
||||
pkgconfig ssl gettext-runtime
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
|
@ -18,7 +18,8 @@ LIB_DEPENDS= libevent.so:devel/libevent2 \
|
||||
|
||||
CONFLICTS= ntp-rc-* ntp-devel-*
|
||||
|
||||
USES= cpe pathfix shebangfix libedit libtool pkgconfig ssl
|
||||
USES= cpe pathfix shebangfix libedit libtool localbase:ldflags \
|
||||
pkgconfig ssl
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= ocserv
|
||||
PORTVERSION= 0.11.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net security
|
||||
MASTER_SITES= ftp://ftp.infradead.org/pub/ocserv/
|
||||
|
||||
@ -23,7 +24,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
|
||||
libev.so:devel/libev \
|
||||
libnettle.so:security/nettle
|
||||
|
||||
USES= autoreconf cpe gettext gmake gperf libtool localbase ncurses \
|
||||
USES= autoreconf cpe gmake gperf libtool localbase ncurses \
|
||||
pathfix pkgconfig readline tar:xz
|
||||
CPE_VENDOR= infradead
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- configure.ac.orig 2015-09-04 19:27:22 UTC
|
||||
--- configure.ac.orig 2016-08-04 06:12:29 UTC
|
||||
+++ configure.ac
|
||||
@@ -19,7 +19,7 @@ if [ test "$GCC" = "yes" ];then
|
||||
fi
|
||||
@ -7,9 +7,9 @@
|
||||
-AC_CHECK_PROG([AUTOGEN], [autogen], [autogen], [:])
|
||||
+AC_CHECK_PROG([AUTOGEN], [autogen], [autogen], [autogen])
|
||||
|
||||
if test x"$AUTOGEN" = "x:"; then
|
||||
AC_MSG_WARN([[
|
||||
@@ -125,7 +125,7 @@ if test "$test_for_libnl" = yes;then
|
||||
AX_CODE_COVERAGE
|
||||
|
||||
@@ -133,7 +133,7 @@ if test "$test_for_libnl" = yes;then
|
||||
fi
|
||||
|
||||
have_readline=no
|
||||
@ -18,7 +18,15 @@
|
||||
#include <stdio.h>
|
||||
#include <readline/readline.h>], [rl_replace_line(0,0);])
|
||||
if test x$ac_cv_libreadline = xyes; then
|
||||
@@ -442,7 +442,7 @@ if test "$NEED_LIBOPTS_DIR" = "true";the
|
||||
@@ -183,6 +183,7 @@ AC_ARG_WITH(pam,
|
||||
|
||||
pam_enabled=no
|
||||
|
||||
+oldlibs=$LIBS
|
||||
if test "$test_for_pam" = yes;then
|
||||
LIBS="$oldlibs -lpam"
|
||||
AC_MSG_CHECKING([for pam library])
|
||||
@@ -496,7 +497,7 @@ if test "$NEED_LIBOPTS_DIR" = "true";the
|
||||
cp -f $i $nam
|
||||
fi
|
||||
done
|
||||
|
18
net/ocserv/files/patch-libopts_m4_libopts.m4
Normal file
18
net/ocserv/files/patch-libopts_m4_libopts.m4
Normal file
@ -0,0 +1,18 @@
|
||||
--- libopts/m4/libopts.m4.orig 2015-12-01 10:21:06 UTC
|
||||
+++ libopts/m4/libopts.m4
|
||||
@@ -55,6 +55,7 @@ AC_DEFUN([INVOKE_LIBOPTS_MACROS_FIRST],[
|
||||
AS_HELP_STRING([--disable-nls],[disable nls support in libopts]))
|
||||
AS_IF([test "x$enable_nls" != "xno" && \
|
||||
test "X${ac_cv_header_libintl_h}" = Xyes], [
|
||||
+ AC_CHECK_LIB(intl,gettext)
|
||||
AC_DEFINE([ENABLE_NLS],[1],[nls support in libopts])])
|
||||
|
||||
# --------------------------------------------
|
||||
@@ -106,7 +107,6 @@ AC_DEFUN([INVOKE_LIBOPTS_MACROS_FIRST],[
|
||||
# AC_CHECK_LIB
|
||||
# ------------
|
||||
AC_CHECK_LIB(gen, pathfind)
|
||||
- AC_CHECK_LIB(intl,gettext)
|
||||
AC_FUNC_VPRINTF
|
||||
AC_FUNC_FORK
|
||||
AC_CHECK_FUNCS([mmap canonicalize_file_name snprintf strdup strchr \
|
@ -14,7 +14,7 @@ COMMENT= Shrew Soft IKE daemon and client tools
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_RC_SUBR= iked
|
||||
USES= bison cmake libedit tar:tbz2
|
||||
USES= bison cmake libedit localbase:ldflags tar:tbz2
|
||||
USE_OPENSSL= yes
|
||||
USE_LDCONFIG= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
@ -16,7 +16,7 @@ USE_GITHUB= yes
|
||||
GH_ACCOUNT= whoozle
|
||||
GH_PROJECT= ${PORTNAME}-linux
|
||||
|
||||
USES= cmake compiler:c++11-lib localbase pkgconfig
|
||||
USES= cmake compiler:c++11-lib localbase:ldflags pkgconfig
|
||||
CMAKE_ARGS= -DUSB_BACKEND_LIBUSB=on -DBUILD_QT_UI=off
|
||||
|
||||
OPTIONS_DEFAULT=CLI FUSE
|
||||
|
@ -23,7 +23,7 @@ PLIST_FILES= bin/unionfs \
|
||||
bin/unionfsctl \
|
||||
man/man8/unionfs.8.gz
|
||||
|
||||
USES= fuse cmake localbase
|
||||
USES= fuse cmake localbase:ldflags
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} "s,share/man,man,g" ${WRKSRC}/man/CMakeLists.txt
|
||||
|
@ -21,7 +21,7 @@ ALL_TARGET= lspci lspci.8 setpci setpci.8
|
||||
CPPFLAGS+= -fPIC
|
||||
LDFLAGS+= -lpci
|
||||
MAKE_ENV= LANG=C
|
||||
USES= gmake localbase tar:xz
|
||||
USES= gmake localbase:ldflags tar:xz
|
||||
|
||||
PLIST_FILES= bin/lspci \
|
||||
bin/setpci \
|
||||
|
@ -28,8 +28,8 @@ OPTIONS_DEFINE= DOCS
|
||||
ONLY_FOR_ARCHS= amd64
|
||||
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64"
|
||||
|
||||
USES= cpe gmake libtool perl5 pkgconfig python shebangfix localbase \
|
||||
gettext
|
||||
USES= cpe gettext gmake libtool localbase:ldflags perl5 pkgconfig \
|
||||
python shebangfix
|
||||
USE_GNOME= glib20
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -13,7 +13,7 @@ LICENSE= GPLv2
|
||||
LIB_DEPENDS= libqtermwidget5.so:x11-toolkits/qtermwidget
|
||||
RUN_DEPENDS= liberation-fonts-ttf>=2.00:x11-fonts/liberation-fonts-ttf
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lang gettext localbase \
|
||||
USES= cmake:outsource compiler:c++11-lang gettext localbase:ldflags \
|
||||
pkgconfig
|
||||
USE_QT5+= buildtools_build core gui linguisttools_build qmake_build widgets
|
||||
USE_XORG+= x11
|
||||
|
Loading…
Reference in New Issue
Block a user