Respect CC, CFLAGS and install missed manpage.

PR:		19645
Submitted by:	Mikhail Teterin <mi@aldan.algebra.com>
This commit is contained in:
Maxim Sobolev 2000-07-03 08:25:56 +00:00
parent 2d8158ef4b
commit 1e5409c41b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30121
3 changed files with 25 additions and 1 deletions

View File

@ -16,7 +16,7 @@ MAINTAINER= jmz@FreeBSD.org
USE_X_PREFIX= yes
ALL_TARGET=
MAN1= xloadimage.1
MAN1= xloadimage.1 uufilter.1
do-configure:
cd ${WRKSRC} && ${MAKE} configure </dev/null
@ -26,5 +26,6 @@ do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} xloadimage uufilter ${PREFIX}/bin
cd ${WRKSRC} && ${INSTALL_DATA} xloadimagerc ${PREFIX}/lib/X11/app-defaults/Xloadimage
cd ${WRKSRC} && ${SED} -e s:/usr/lib/X11/Xloadimage:${PREFIX}/lib/X11/app-defaults/Xloadimage: < xloadimage.man >${PREFIX}/man/man1/xloadimage.1
${INSTALL_MAN} ${WRKSRC}/uufilter.man ${PREFIX}/man/man1/uufilter.1
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- Makefile Tue Nov 9 17:25:12 1993
+++ Makefile Sun Jul 2 10:56:48 2000
@@ -24,5 +24,7 @@
autoconfig: autoconfig.c
- $(CC) -g -o autoconfig autoconfig.c
+ $(CC) -o autoconfig autoconfig.c -DDEF_CC='"${CC}"' \
+ -DDEF_OPT_FLAGS='"${OPT_FLAGS}"' \
+ -DDEF_INSTALL_DIR='"${PREFIX}/bin"'
# manual configuration target

View File

@ -0,0 +1,12 @@
--- Make.conf Tue Nov 9 17:26:55 1993
+++ Make.conf Sun Jul 2 10:57:03 2000
@@ -12,5 +12,8 @@
# Optimization flags for C compiler.
-OPT_FLAGS=
+# A comment inside autoconfig.c recommends the two extra options:
+# -fstrength-reduce and -finline-functions
+# Unfortunately, strength-reduce triggers a bug in the gcc-2.95.2.
+OPT_FLAGS:=-fno-strength-reduce -finline-functions ${CFLAGS}
# Miscellaneous system libraries.