upgrade to 4.1.1

drop maintainership
This commit is contained in:
Ying-Chieh Liao 2001-09-09 12:09:32 +00:00
parent b76ce88bd9
commit 1dc254500d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47569
5 changed files with 28 additions and 18 deletions

View File

@ -7,23 +7,25 @@
#
PORTNAME= libdsp
PORTVERSION= 4.0.0
PORTVERSION= 4.1.1
CATEGORIES= devel audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= libdsp-src-${PORTVERSION}
MAINTAINER= ijliao@FreeBSD.org
MAINTAINER= ports@FreeBSD.org
# dont use "USE_LIBTOOL=yes" because there's no configure script
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
INLINE_VER= 1.2.2
MAKEFILE= Makefile.FreeBSD
INLINE_VER= 1.2.3
USE_GMAKE= yes
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e "s|%%INLINE_VER%%|${INLINE_VER}|g" ${WRKSRC}/${MAKEFILE}
@${PERL} -pi -e "s|%%INLINE_VER%%|${INLINE_VER}|g ; \
s|install -m 644|${INSTALL_DATA}|g" ${WRKSRC}/${MAKEFILE}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (libdsp-src-4.0.0.tar.gz) = 73845c912233675823a2a699cddf99ef
MD5 (libdsp-src-4.1.1.tar.gz) = 8c4dbba87b622319e652a8f42bbe4787

View File

@ -1,13 +0,0 @@
--- Makefile.orig Mon Jul 9 09:56:51 2001
+++ Makefile Mon Jul 9 09:57:37 2001
@@ -20,4 +20,4 @@
-CXX = g++
-CXXFLAGS = -mcpu=k6 -march=k6 -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror
-DEFS = -D_REENTRANT -D_THREAD_SAFE -D_ISOC9X_SOURCE -DX86 -DUSE_MEMMOVE
-INCS = -I.
+CXX ?= g++
+CXXFLAGS += -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror
+DEFS = -D_REENTRANT -D_THREAD_SAFE -DBSDSYS -DX86 -DUSE_MEMMOVE
+INCS = -I. -I../Inlines-%%INLINE_VER%%
@@ -26 +25,0 @@
-PREFIX = /usr/local

View File

@ -0,0 +1,19 @@
--- Makefile.FreeBSD.orig Sun Sep 9 19:52:53 2001
+++ Makefile.FreeBSD Sun Sep 9 19:54:01 2001
@@ -17,14 +17,12 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
-CXX = g++
-CXXFLAGS = -mcpu=pentium -march=pentium -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror #-g
+CXXFLAGS += -O6 -fomit-frame-pointer -ffast-math -funroll-loops -malign-loops=5 -malign-jumps=5 -malign-functions=5 -mpreferred-stack-boundary=5 -mfancy-math-387 -Wall -Werror #-g
DEFS = -D_REENTRANT -D_THREAD_SAFE -DBSDSYS -DX86 -DUSE_MEMMOVE
-INCS = -I. -I/usr/local/include
+INCS = -I. -I../Inlines-%%INLINE_VER%%
LDFLAGS = #-g
LIBS = -lm #-ldrfftw -ldfftw
LIBTOOL = libtool
-PREFIX = /usr/local
VERSION = 1:1:0

View File

@ -1,5 +1,6 @@
include/dsp/DSPConfig.hh
include/dsp/DSPOp.hh
include/dsp/DSPVector.hh
include/dsp/Decimator.hh
include/dsp/FFTDecimator.hh
include/dsp/Filter.hh
@ -8,6 +9,7 @@ include/dsp/FIRDecimator.hh
include/dsp/Hankel.hh
include/dsp/ReBuffer.hh
include/dsp/ReBuffer2.hh
include/dsp/ReBuffer3.hh
include/dsp/RecDecimator.hh
include/dsp/Transform4.hh
include/dsp/Transform8.hh