math/primme: 2.1.20181011 -> 2.2

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2018-10-28 04:32:44 +00:00
parent abc2314129
commit 1dbf74e111
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=483219
5 changed files with 28 additions and 20 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= primme
DISTVERSIONPREFIX= v
DISTVERSION= 2.1.20181011 # git describe doesn't identify the tag properly
DISTVERSION= 2.2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@ -15,7 +15,6 @@ TEST_DEPENDS= gfortran${GCC_DEFAULT}:lang/gcc${GCC_DEFAULT}
USES= gmake localbase:ldflags
USE_GITHUB= yes
GH_TAGNAME= 6a0fa27
MAKEFILE= makefile
ALL_TARGET= solib
USE_LDCONFIG= yes
@ -51,6 +50,6 @@ PLIST_FILES= include/primme.h \
include/primme_svds_f77.h \
lib/libprimme.so \
lib/libprimme.so.2 \
lib/libprimme.so.2.1
lib/libprimme.so.2.2
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1539306461
SHA256 (primme-primme-v2.1.20181011-6a0fa27_GH0.tar.gz) = 8f662a7c41d5bfb7910ccb9bbcb7f06f1191fc7c7a9d41fb695e9b13438bcb79
SIZE (primme-primme-v2.1.20181011-6a0fa27_GH0.tar.gz) = 5511173
TIMESTAMP = 1540697010
SHA256 (primme-primme-v2.2_GH0.tar.gz) = 5ed1b4476659cb0d0ef1de4f00bbd3fa9e1d879f067890a08236dcb48d8e6a52
SIZE (primme-primme-v2.2_GH0.tar.gz) = 6161380

View File

@ -0,0 +1,11 @@
--- examples/Makefile.orig 2018-10-28 03:29:33 UTC
+++ examples/Makefile
@@ -8,7 +8,7 @@ include ../Link_flags
override INCLUDE += -I../include
override FINCLUDE += -I../include
-LIBS := ../lib/libprimme.a $(LIBS)
+LIBS := ../lib/libprimme.so $(LIBS)
EXAMPLES_C = ex_eigs_dseq ex_eigs_zseq ex_svds_dseq ex_svds_zseq
EXAMPLES_CXX = ex_eigs_zseqxx ex_svds_zseqxx

View File

@ -1,11 +0,0 @@
--- tests/COMMON/num.h.orig 2018-10-08 17:28:33 UTC
+++ tests/COMMON/num.h
@@ -42,7 +42,7 @@
#endif
#define Sprimme CONCAT(SCALAR_PRE,primme)
#define Sprimme_svds CONCAT(SCALAR_PRE,primme_svds)
-#if !(defined (__APPLE__) && defined (__MACH__))
+#if !(defined (__APPLE__) && defined (__MACH__)) && !defined(__FreeBSD__)
# include <malloc.h> /* malloc */
#endif
#include <stdlib.h> /* malloc, free */

View File

@ -1,11 +1,20 @@
--- tests/Makefile.orig 2018-10-08 19:10:07 UTC
--- tests/Makefile.orig 2018-10-28 03:25:47 UTC
+++ tests/Makefile
@@ -9,7 +9,7 @@ include ../Link_flags
SOBJS= COMMON/shared_utils.o COMMON/ioandtest.o
COMMON_INCLUDE = -I./COMMON -I../include
override INCLUDE += $(COMMON_INCLUDE)
-LIBDIRS += -L../lib
+LIBDIRS += ../lib/libprimme.so
-LIBS := ../lib/libprimme.a $(LIBS)
+LIBS := ../lib/libprimme.so $(LIBS)
USE_NATIVE ?= yes
USE_PETSC ?= $(if $(findstring undefined,$(origin PETSC_DIR)),no,yes)
@@ -89,7 +89,7 @@ all: drivers
drivers: primme_double primme_doublecomplex primmesvds_double primmesvds_doublecomplex
-primme_double primme_doublecomplex primmesvds_double primmesvds_doublecomplex: ../lib/libprimme.a
+primme_double primme_doublecomplex primmesvds_double primmesvds_doublecomplex: ../lib/libprimme.so
ifeq ($(USE_MPI), yes)
MPIRUN ?= mpirun -np 4