Upgrade to 2.01
This commit is contained in:
parent
8766b27756
commit
1da1ba4634
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46032
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= WebMagick
|
||||
PORTVERSION= 2.0
|
||||
PORTVERSION= 2.01
|
||||
CATEGORIES= www graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= webmagick
|
||||
@ -36,7 +36,5 @@ post-install:
|
||||
${INSTALL_DATA} webmagickrc ${PREFIX}/etc; \
|
||||
fi; \
|
||||
${INSTALL_DATA} webmagickrc ${PREFIX}/etc/webmagickrc.dist
|
||||
cd ${WRKSRC}/icons; \
|
||||
${INSTALL_DATA} blue_help.gif ${PREFIX}/www/data/webmagick/blue_c.gif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (WebMagick-2.0.tar.gz) = fbbca7cdf9acf1a0d39de3c073f06944
|
||||
MD5 (WebMagick-2.01.tar.gz) = c4a2adaaed70994660be3c589fb11b64
|
||||
|
@ -1,41 +0,0 @@
|
||||
--- webmagick.in.bak Sat Jul 14 01:35:08 2001
|
||||
+++ webmagick.in Thu Aug 9 06:51:38 2001
|
||||
@@ -2109,9 +2109,17 @@
|
||||
}
|
||||
# --- prev link ---
|
||||
if( $pageNumber == 1 ) {
|
||||
- # Go to base index page if on first page
|
||||
- $indexbar .= "<A HREF=\"${opt_indexname}\" TARGET=\"$opt_frame_name_top\"><IMG
|
||||
- SRC=\"$iconImageUrls{'prev'}\" $iconImageSizes{'prev'} ALT=\"Prev\" BORDER=0></A>\n";
|
||||
+ my $indexname = get_rc_var('..', 'opt_indexname', $opt_indexname);
|
||||
+
|
||||
+ if ( !$haveReadme && $indexname ne 'NOLINK' ) {
|
||||
+ # Go to up index page if on first page
|
||||
+ $indexbar .= "<A HREF=\"../${indexname}\" TARGET=\"$opt_frame_name_top\"><IMG
|
||||
+ SRC=\"$iconImageUrls{'up'}\" $iconImageSizes{'up'} ALT=\"^\" BORDER=0></A>\n";
|
||||
+ } else {
|
||||
+ # Go to base index page if on first page
|
||||
+ $indexbar .= "<A HREF=\"${opt_indexname}\" TARGET=\"$opt_frame_name_top\"><IMG
|
||||
+ SRC=\"$iconImageUrls{'prev'}\" $iconImageSizes{'prev'} ALT=\"Prev\" BORDER=0></A>\n";
|
||||
+ }
|
||||
} else {
|
||||
# Go to preceding page
|
||||
$indexbar .= "<A HREF=\"$fileNames{'htmlPrevIndex'}\" TARGET=\"$frameTargets{'thumbview'}\"><IMG
|
||||
@@ -2700,7 +2708,7 @@
|
||||
# available in PerlMagick 1.12 and beyond. If the
|
||||
# feature is not supported then undefined values
|
||||
# should be returned.
|
||||
- ($base_columns, $base_rows) = $image->Get('base_columns', 'base_rows');
|
||||
+ ($base_columns, $base_rows) = $image->Get('base-columns', 'base-rows');
|
||||
if( defined($base_columns) && defined($base_rows) ) {
|
||||
$width = $base_columns;
|
||||
$height = $base_rows;
|
||||
@@ -2971,8 +2979,6 @@
|
||||
if( ! $opt_forcejpeg ) {
|
||||
print( STDERR "Writing $fileNames{'montageGIF'} ...\n" ) if $opt_debug;
|
||||
$status = $image->Write(
|
||||
- colors=>256,
|
||||
- colorspace=>'YUV',
|
||||
dither=>'True',
|
||||
filename=>"GIF:$fileNames{'montageGIF'}",
|
||||
interlace=>'Line'
|
Loading…
Reference in New Issue
Block a user