- New port: devel/xdgpaths

D library for retrieving XDG base directories as described by XDG Base
Directory Specification

WWW: https://github.com/FreeSlave/xdgpaths
This commit is contained in:
Jose Alonso Cardenas Marquez 2018-06-15 18:09:04 +00:00
parent 7e6bc27a2f
commit 1d98cee9f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472476
6 changed files with 55 additions and 0 deletions

View File

@ -6224,6 +6224,7 @@
SUBDIR += xc3sprog
SUBDIR += xdg-user-dirs
SUBDIR += xdg-utils
SUBDIR += xdgpaths
SUBDIR += xfce4-dev-tools
SUBDIR += xfce4-vala
SUBDIR += xmake

33
devel/xdgpaths/Makefile Normal file
View File

@ -0,0 +1,33 @@
# $FreeBSD$
PORTNAME= xdgpaths
PORTVERSION= 0.2.4
DISTVERSIONPREFIX= v
CATEGORIES= devel
MAINTAINER= acm@FreeBSD.org
COMMENT= XDG Base Directory Specification implementation in D lang
LICENSE= BSL
BUILD_DEPENDS= ldmd2:lang/ldc \
dub:devel/dub \
${LOCALBASE}/lib/d/libisfreedesktop.a:devel/isfreedesktop
USE_GITHUB= yes
GH_ACCOUNT= FreeSlave
DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
D_INCLUDE_DIR= ${PREFIX}/include/d
D_LIB_DIR= ${PREFIX}/lib/d
do-build:
@cd ${WRKSRC} && ${DUB_CMD}
do-install:
@${MKDIR} ${STAGEDIR}${D_INCLUDE_DIR}
@${MKDIR} ${STAGEDIR}${D_LIB_DIR}
${INSTALL_DATA} ${WRKSRC}/lib/libxdgpaths.a ${STAGEDIR}${D_LIB_DIR}
cd ${WRKSRC}/source && ${COPYTREE_SHARE} . ${STAGEDIR}${D_INCLUDE_DIR} "-name *\.d"
.include <bsd.port.mk>

3
devel/xdgpaths/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1513180834
SHA256 (FreeSlave-xdgpaths-v0.2.4_GH0.tar.gz) = 5eaa56100be022987baa62765474a2e243c00fc7e701895e5e719dee5836c44b
SIZE (FreeSlave-xdgpaths-v0.2.4_GH0.tar.gz) = 6345

View File

@ -0,0 +1,12 @@
--- dub.json.orig 2017-12-13 11:01:34.079914000 -0500
+++ dub.json 2017-12-13 11:01:47.615013000 -0500
@@ -6,9 +6,6 @@
"authors": ["Roman Chistokhodov"],
"targetPath" : "lib",
"targetType" : "library",
- "dependencies": {
- "isfreedesktop" : "~>0.1.0"
- },
"buildTypes" : {
"docs" : {
"buildOptions" : ["syntaxOnly"],

4
devel/xdgpaths/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
D library for retrieving XDG base directories as described by XDG Base
Directory Specification
WWW: https://github.com/FreeSlave/xdgpaths

2
devel/xdgpaths/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
include/d/xdgpaths.d
lib/d/libxdgpaths.a