FSF binutils for embedded ARM cross-development

This is used to generate code that is independent of any operating system.
This commit is contained in:
David E. O'Brien 2001-01-01 17:25:24 +00:00
parent 86c34c7330
commit 1d8f062168
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36574
7 changed files with 82 additions and 0 deletions

View File

@ -11,6 +11,7 @@
SUBDIR += a2dev
SUBDIR += adabroker
SUBDIR += amulet
SUBDIR += arm-aout-binutils
SUBDIR += asis
SUBDIR += asl
SUBDIR += astyle

View File

@ -0,0 +1,22 @@
# ex:ts=8
# New ports collection makefile for: armbinutils-2.9.1
# Date created: 2 june 2000
# Whom: Paul Becke <pbecke@javagear.com>
#
# $FreeBSD$
#
PORTNAME= arm-aout-binutils
PORTVERSION= 2.9.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= binutils
DISTNAME= binutils-2.9.1
MAINTAINER= pbecke@javagear.com
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=arm-aout
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (binutils-2.9.1.tar.gz) = 8f9ad1a6e96742fd3069479171a63c22

View File

@ -0,0 +1,19 @@
--- bfd/aout-arm.c.orig Mon Aug 21 10:22:41 2000
+++ bfd/aout-arm.c Mon Aug 21 10:23:42 2000
@@ -20,13 +20,13 @@
#define N_TXTADDR(x) \
- ((N_MAGIC(x) == NMAGIC) ? 0x8000 : \
+ ((N_MAGIC(x) == NMAGIC) ? 0x0000 : \
(N_MAGIC(x) != ZMAGIC) ? 0 : \
(N_SHARED_LIB(x)) ? ((x).a_entry & ~(TARGET_PAGE_SIZE - 1)) : \
TEXT_START_ADDR)
-#define TEXT_START_ADDR 0x8000
-#define TARGET_PAGE_SIZE 0x8000
+#define TEXT_START_ADDR 0x0000
+#define TARGET_PAGE_SIZE 0x1000
#define SEGMENT_SIZE TARGET_PAGE_SIZE
#define DEFAULT_ARCH bfd_arch_arm

View File

@ -0,0 +1 @@
FSF Binutils for embedded ARM cross-development

View File

@ -0,0 +1,10 @@
FSF binutils for embedded ARM cross-development
This is used to generate code that is independent of any operating system.
In particular, it is used to compile the kernel, since there is no operating
system that it can depend on.
devel/arm-aout-gcc295 uses this port as a dependency.
--------------------------------------------------------------------------
Paul Becke
pbecke@javagear.com

View File

@ -0,0 +1,28 @@
arm-aout/bin/ar
arm-aout/bin/as
arm-aout/bin/ld
arm-aout/bin/nm
arm-aout/bin/ranlib
arm-aout/bin/strip
arm-aout/lib/ldscripts/armaoutl.x
arm-aout/lib/ldscripts/armaoutl.xbn
arm-aout/lib/ldscripts/armaoutl.xn
arm-aout/lib/ldscripts/armaoutl.xr
arm-aout/lib/ldscripts/armaoutl.xu
bin/arm-aout-ld
bin/arm-aout-gasp
bin/arm-aout-as
bin/arm-aout-nm
bin/arm-aout-strip
bin/arm-aout-addr2line
bin/arm-aout-objcopy
bin/arm-aout-c++filt
bin/arm-aout-ranlib
bin/arm-aout-ar
bin/arm-aout-strings
bin/arm-aout-objdump
bin/arm-aout-size
@dirrm arm-aout/bin
@dirrm arm-aout/lib/ldscripts
@dirrm arm-aout/lib
@dirrm arm-aout