Add hs-port 1.2, a low-level GUI library for Haskell.
This commit is contained in:
parent
ae54af2ac9
commit
1d20f1abe3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103427
@ -86,6 +86,7 @@
|
||||
SUBDIR += hs-frantk
|
||||
SUBDIR += hs-gtk+hs
|
||||
SUBDIR += hs-gtk2hs
|
||||
SUBDIR += hs-port
|
||||
SUBDIR += icegradient
|
||||
SUBDIR += itk
|
||||
SUBDIR += iwidgets
|
||||
|
52
x11-toolkits/hs-port/Makefile
Normal file
52
x11-toolkits/hs-port/Makefile
Normal file
@ -0,0 +1,52 @@
|
||||
# New ports collection makefile for: port
|
||||
# Date created: 2004-03-09
|
||||
# Whom: obraun@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= port
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= x11-toolkits haskell
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= htoolkit
|
||||
PKGNAMEPREFIX= hs-
|
||||
|
||||
MAINTAINER= haskell@FreeBSD.org
|
||||
COMMENT= A low-level GUI library for Haskell
|
||||
|
||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
|
||||
|
||||
USE_GNOME= glib20 gtk20
|
||||
USE_BZIP2= yes
|
||||
USE_REINPLACE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= makefile
|
||||
MAKE_ENV+= DOCSDIR="${DOCSDIR}" INSTALL_DATA="${INSTALL_DATA}"
|
||||
ALL_TARGET= release
|
||||
|
||||
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
|
||||
PLIST_SUB+= GHC_VERSION="${GHC_VERSION}"
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock \
|
||||
${LOCALBASE}/share/doc/ghc6/index.html:${PORTSDIR}/lang/ghc6-doc
|
||||
CONFIGURE_ARGS+= -haddock-libs ${LOCALBASE}/share/doc/ghc6/libraries/base \
|
||||
-haddock-html ${LOCALBASE}/share/doc/ghc6/libraries/
|
||||
ALL_TARGET= release doc
|
||||
INSTALL_TARGET= install install-doc
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} 's|\"/usr/local/lib/glib-2.0/include\",|| ;\
|
||||
s|\"/usr/X11R6/lib/gnome-vfs-2.0/include\",|| ;\
|
||||
s|\"/usr/X11R6/lib/gtk-2.0/include\",||' \
|
||||
${WRKSRC}/config/port.pkg
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/config/port.pkg ${DATADIR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11-toolkits/hs-port/distinfo
Normal file
2
x11-toolkits/hs-port/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (port-1.2.tar.bz2) = 3d02a5edadd22c7c99a116ed0a416562
|
||||
SIZE (port-1.2.tar.bz2) = 190214
|
22
x11-toolkits/hs-port/files/patch-makefile
Normal file
22
x11-toolkits/hs-port/files/patch-makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- makefile.orig Mon Oct 20 23:21:59 2003
|
||||
+++ makefile Tue Mar 9 13:42:15 2004
|
||||
@@ -140,7 +140,6 @@
|
||||
install: $(MAINLIB) $(PKG)
|
||||
install -d $(LIBDIR)/imports/Graphics/UI/Port
|
||||
install -d $(LIBDIR)/include/port
|
||||
- install -d $(LIBDIR)/doc/html/port
|
||||
install -m 644 src/include/HsPort.h $(LIBDIR)/include/port
|
||||
install -m 644 $(HOUTDIR)/*.hi $(LIBDIR)/imports/Graphics/UI
|
||||
install -m 644 $(HOUTDIR)/Port/*.hi $(LIBDIR)/imports/Graphics/UI/Port
|
||||
@@ -150,7 +149,10 @@
|
||||
$(RM) $(LIBDIR)/include/port/HsPort.h
|
||||
$(RM) $(LIBDIR)/$(MAINOBJ)
|
||||
$(HCPKG) -u -g -i $(PKG)
|
||||
- install -m 644 doc/*.html doc/*.css doc/*.gif doc/*.haddock $(LIBDIR)/doc/html/port
|
||||
+
|
||||
+install-doc:
|
||||
+ install -d ${DOCSDIR}
|
||||
+ ${INSTALL_DATA} doc/*.html doc/*.css doc/*.gif doc/*.haddock ${DOCSDIR}
|
||||
|
||||
$(MAINLIB): $(HOBJS) $(COBJS) $(STUBSTUBOBJS)
|
||||
$(RM) $(MAINLIB)
|
20
x11-toolkits/hs-port/files/patch-src::Port::Types.hs
Normal file
20
x11-toolkits/hs-port/files/patch-src::Port::Types.hs
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/Port/Types.hs.orig Fri Aug 29 21:39:21 2003
|
||||
+++ src/Port/Types.hs Tue Mar 9 11:58:33 2004
|
||||
@@ -848,7 +848,7 @@
|
||||
|
||||
fromCBitmap :: BitmapHandle -> IO Bitmap
|
||||
fromCBitmap bh
|
||||
- = do bm <- newForeignPtr bh osDeleteBitmap
|
||||
+ = do bm <- newForeignPtr osDeleteBitmap bh
|
||||
return (Bitmap bm)
|
||||
foreign import ccall "&osDeleteBitmap" osDeleteBitmap :: FinalizerPtr BH
|
||||
|
||||
@@ -934,7 +934,7 @@
|
||||
|
||||
fromCFont :: FontDef -> FontHandle -> IO Font
|
||||
fromCFont fontdef handle
|
||||
- = do fhandle <- newForeignPtr handle osDeleteFont
|
||||
+ = do fhandle <- newForeignPtr osDeleteFont handle
|
||||
return (Font fhandle fontdef)
|
||||
foreign import ccall "&osDeleteFont" osDeleteFont :: FinalizerPtr FH
|
||||
|
12
x11-toolkits/hs-port/pkg-descr
Normal file
12
x11-toolkits/hs-port/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
Port is part of the HToolkit. The goal of the HToolkit project is to implement
|
||||
a portable Haskell library for writing graphical user interfaces (GUI's).
|
||||
|
||||
To tackle the problem of portability, the library will be built upon a
|
||||
low-level interface that will be implemented for each different target
|
||||
platform. The low-level library is called Port and is currently implemented for
|
||||
GTK and Windows.
|
||||
|
||||
WWW: http://htoolkit.sourceforge.net/
|
||||
|
||||
-- Oliver Braun
|
||||
obraun@FreeBSD.org
|
153
x11-toolkits/hs-port/pkg-plist
Normal file
153
x11-toolkits/hs-port/pkg-plist
Normal file
@ -0,0 +1,153 @@
|
||||
lib/ghc-%%GHC_VERSION%%/HSport.o
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Bitmap.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Canvas.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Colors.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/CommonDialogs.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/ConfigKey.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Controls.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Document.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Font.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Handlers.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/IntMap.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Menu.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Message.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Process.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/PtrMap.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Timer.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/ToolBar.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Types.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port/Window.hi
|
||||
lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port.hi
|
||||
lib/ghc-%%GHC_VERSION%%/include/HsPort.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Bitmap.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Button.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Canvas.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/CheckBox.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/CommonDialogs.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/ConfigKey.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/EditBox.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Font.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/GroupBox.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Label.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/ListBox.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Menu.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Message.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Notebook.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/PopUp.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/ProgressBar.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/RadioBox.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Slider.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Timer.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/ToolBar.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Types.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/Window.h
|
||||
lib/ghc-%%GHC_VERSION%%/include/port/config.h
|
||||
lib/ghc-%%GHC_VERSION%%/libHSport.a
|
||||
share/port/port.pkg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Bitmap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Canvas.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Colors.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.CommonDialogs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.ConfigKey.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Controls.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Document.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Font.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Handlers.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Menu.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Message.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Process.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Timer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.ToolBar.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.Window.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Graphics.UI.Port.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/colors.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-A.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-B.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-C.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-D.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-F.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-G.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-H.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-I.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-J.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-K.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-L.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-M.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-N.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-O.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-P.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-Q.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-R.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-S.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-T.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-U.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-V.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-W.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-Y.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tA.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tB.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tC.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tD.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tE.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tF.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tG.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tH.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tI.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tJ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tK.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tL.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tM.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tN.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tO.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tP.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tQ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tR.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tS.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tT.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tU.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tV.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tW.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tX.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tY.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-tZ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vA.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vB.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vC.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vD.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vE.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vF.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vG.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vH.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vI.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vJ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vK.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vL.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vM.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vN.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vO.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vP.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vQ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vR.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vS.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vT.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vU.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vV.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vW.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vX.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vY.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index-vZ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/doc-index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/haddock.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/haskell_icon.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/port.haddock
|
||||
@dirrm share/port
|
||||
@dirrm lib/ghc-%%GHC_VERSION%%/include/port
|
||||
@dirrm lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI/Port
|
||||
@dirrm lib/ghc-%%GHC_VERSION%%/imports/Graphics/UI
|
||||
@dirrm lib/ghc-%%GHC_VERSION%%/imports/Graphics
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@exec %D/bin/ghc-pkg -u -g -i %D/share/port/port.pkg
|
||||
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
|
||||
@unexec %D/bin/ghc-pkg -r port
|
||||
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
|
Loading…
Reference in New Issue
Block a user