- Update to 0.6

- Switch to USES=autoreconf
- Strip libraries

- While here, add LICENSE_FILE

PR:		195127
Submitted by:	liangtai.s16@gmail.com (maintainer)
This commit is contained in:
Dmitry Marakasov 2014-11-20 16:21:07 +00:00
parent a8c511cafa
commit 1d10ed5f78
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372949
4 changed files with 18 additions and 14 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= opusfile
PORTVERSION= 0.5
PORTREVISION= 4
PORTVERSION= 0.6
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
${MASTER_SITE_MOZILLA_EXTENDED}
@ -12,14 +11,14 @@ MAINTAINER= liangtai.s16@gmail.com
COMMENT= Opus playback library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
libopus.so:${PORTSDIR}/audio/opus
USES= gmake libtool pkgconfig pathfix
USES= autoreconf gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal autoconf autoheader automake
MAKE_JOBS_UNSAFE= yes
PATHFIX_MAKEFILEIN= Makefile.am
@ -31,12 +30,15 @@ OPTIONS_DEFAULT= # empty
DOXYGEN_CONFIGURE_ENABLE= doc
DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's| @openssl@||' \
${WRKSRC}/opusfile.pc.in ${WRKSRC}/opusurl.pc.in
@${REINPLACE_CMD} -e '/libopusurl_la_SOURCES/s/http.c/& src\/ftime.c/' \
-e '/dist_doc_DATA/s/COPYING//' \
${WRKSRC}/Makefile.am
@${CP} ${FILESDIR}/ftime.c ${WRKSRC}/src/
@ -46,9 +48,6 @@ post-install:
${FIND} ${STAGEDIR}${DOCSDIR}/html -type f | \
${SED} 's|${STAGEDIR}${PREFIX}/||' \
>> ${WRKDIR}/PLIST.doc ; \
${FIND} ${STAGEDIR}${DOCSDIR}/html -type d | \
${SED} 's|${STAGEDIR}${PREFIX}/|@dirrm |' \
| ${SORT} -r >> ${WRKDIR}/PLIST.doc ; \
(cd ${WRKDIR} ; ${SED} -i -e '/PLIST.doc/ r PLIST.doc' ${TMPPLIST})
.endif

View File

@ -1,2 +1,2 @@
SHA256 (opusfile-0.5.tar.gz) = 2ce52d006aeeec9f10260dbe3073c4636954a1ab19c82b8baafefe0180aa4a39
SIZE (opusfile-0.5.tar.gz) = 437671
SHA256 (opusfile-0.6.tar.gz) = 2428717b356e139f18ed2fdb5ad990b5654a238907a0058200b39c46a7d03ea6
SIZE (opusfile-0.6.tar.gz) = 437980

View File

@ -1,6 +1,11 @@
--- ./configure.ac.orig 2014-01-09 22:35:34.000000000 +0000
+++ ./configure.ac 2014-01-17 17:25:40.113916574 +0000
@@ -90,10 +90,12 @@
--- configure.ac.orig 2014-06-10 07:40:26.000000000 +0900
+++ configure.ac 2014-06-13 07:24:14.000000000 +0900
@@ -86,15 +86,16 @@
)
)
)
-AC_SEARCH_LIBS(ftime, [compat], , [enable_http=no])
AS_IF([test "$enable_http" != "no"], [
openssl="openssl"
AC_DEFINE([OP_ENABLE_HTTP], [1], [Enable HTTP support])

View File

@ -2,11 +2,11 @@ include/opus/opusfile.h
lib/libopusfile.a
lib/libopusfile.so
lib/libopusfile.so.0
lib/libopusfile.so.0.3.0
lib/libopusfile.so.0.3.1
lib/libopusurl.a
lib/libopusurl.so
lib/libopusurl.so.0
lib/libopusurl.so.0.3.0
lib/libopusurl.so.0.3.1
libdata/pkgconfig/opusfile.pc
libdata/pkgconfig/opusurl.pc
@comment Insert PLIST.doc here