Build a new scanner to avoid compilation errors in crufty old AT&T
scanner skeleton.
This commit is contained in:
parent
46e3f1b0da
commit
1d04b67168
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60555
@ -19,7 +19,8 @@ WRKSRC= ${WRKDIR}/mpegdir
|
||||
MAN1= mpeg.1
|
||||
|
||||
pre-build:
|
||||
@${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
|
||||
@-${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
|
||||
cd ${WRKSRC} && lex -lt lexer.l >lexer.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mpeg ${PREFIX}/bin
|
||||
|
15
graphics/mpeg/files/patch-lexer.l
Normal file
15
graphics/mpeg/files/patch-lexer.l
Normal file
@ -0,0 +1,15 @@
|
||||
--- lexer.l.orig Mon Jun 3 18:16:25 2002
|
||||
+++ lexer.l Mon Jun 3 18:16:32 2002
|
||||
@@ -1,3 +1,4 @@
|
||||
+%{
|
||||
/*************************************************************
|
||||
Copyright (C) 1990, 1991, 1993 Andy C. Hung, all rights reserved.
|
||||
PUBLIC DOMAIN LICENSE: Stanford University Portable Video Research
|
||||
@@ -15,7 +16,6 @@
|
||||
Video Research Group (PVRG) code, and not by any author(s) (or
|
||||
Stanford University) name.
|
||||
*************************************************************/
|
||||
-%{
|
||||
|
||||
/*LABEL lexer.c */
|
||||
|
@ -19,7 +19,8 @@ WRKSRC= ${WRKDIR}/mpegdir
|
||||
MAN1= mpeg.1
|
||||
|
||||
pre-build:
|
||||
@${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
|
||||
@-${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
|
||||
cd ${WRKSRC} && lex -lt lexer.l >lexer.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mpeg ${PREFIX}/bin
|
||||
|
15
multimedia/mpeg/files/patch-lexer.l
Normal file
15
multimedia/mpeg/files/patch-lexer.l
Normal file
@ -0,0 +1,15 @@
|
||||
--- lexer.l.orig Mon Jun 3 18:16:25 2002
|
||||
+++ lexer.l Mon Jun 3 18:16:32 2002
|
||||
@@ -1,3 +1,4 @@
|
||||
+%{
|
||||
/*************************************************************
|
||||
Copyright (C) 1990, 1991, 1993 Andy C. Hung, all rights reserved.
|
||||
PUBLIC DOMAIN LICENSE: Stanford University Portable Video Research
|
||||
@@ -15,7 +16,6 @@
|
||||
Video Research Group (PVRG) code, and not by any author(s) (or
|
||||
Stanford University) name.
|
||||
*************************************************************/
|
||||
-%{
|
||||
|
||||
/*LABEL lexer.c */
|
||||
|
Loading…
Reference in New Issue
Block a user