back-out the last commit since it was done with mangled CVS/Root files and that
resulted in checking n the stuff into the wrong directory... Bump PORTEPOCH (because of PORTVERSION wents backward)
This commit is contained in:
parent
bc1d229cfd
commit
1cf81f5a9e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126227
@ -6,13 +6,17 @@
|
||||
#
|
||||
|
||||
PORTNAME= gqmpeg
|
||||
PORTVERSION= 0.91.1
|
||||
CATEGORIES= audio
|
||||
PORTVERSION= 0.20.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES+= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= oliver@FreeBSD.org
|
||||
COMMENT= Another gtk-based MP3 frontend
|
||||
MAINTAINER?= lyngbol@wheel.dk
|
||||
COMMENT?= Another gtk-based MP3 frontend
|
||||
|
||||
RUN_DEPENDS= ogg123:${PORTSDIR}/audio/vorbis-tools \
|
||||
xmp:${PORTSDIR}/audio/xmp
|
||||
|
||||
.if defined(WITH_MPG321)
|
||||
RUN_DEPENDS+= mpg321:${PORTSDIR}/audio/mpg321
|
||||
@ -20,29 +24,30 @@ RUN_DEPENDS+= mpg321:${PORTSDIR}/audio/mpg321
|
||||
RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_MOD)
|
||||
RUN_DEPENDS+= xmp:${PORTSDIR}/audio/xmp
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_OGG)
|
||||
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
|
||||
.endif
|
||||
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gtk20
|
||||
USE_LIBTOOL_VER=15
|
||||
USE_GNOME= gdkpixbuf
|
||||
WANT_GNOME= yes
|
||||
USE_LIBTOOL_VER= 13
|
||||
USE_AUTOCONF_VER= 213
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib" \
|
||||
|
||||
CONFLICTS= gqmpeg-0.2*
|
||||
|
||||
MAN1= gqmpeg.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomelibs}!=""
|
||||
USE_GNOME+= gnomeprefix gnomelibs
|
||||
PKGNAMESUFFIX= -gnome
|
||||
CONFIGURE_ENV+= USE_GNOME="yes"
|
||||
PLIST_SUB+= DATADIR="share/gnome"
|
||||
.else
|
||||
CONFIGURE_ENV+= USE_GNOME=""
|
||||
PLIST_SUB+= DATADIR="share"
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_MPG321)
|
||||
pre-everything::
|
||||
@${ECHO_MSG}
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (gqmpeg-0.91.1.tar.gz) = e22eda86fc3e59108c8d04abc37b3e56
|
||||
SIZE(gqmpeg-0.91.1.tar.gz) = 1078478
|
||||
MD5 (gqmpeg-0.20.0.tar.gz) = 18cc9e61969552fd6dabfded53907227
|
||||
SIZE (gqmpeg-0.20.0.tar.gz) = 966991
|
||||
|
46
audio/gqmpeg/files/patch-aclocal.m4
Normal file
46
audio/gqmpeg/files/patch-aclocal.m4
Normal file
@ -0,0 +1,46 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- aclocal.m4.orig Wed Jul 17 20:48:30 2002
|
||||
+++ aclocal.m4 Thu Jul 18 16:38:49 2002
|
||||
@@ -545,7 +545,7 @@
|
||||
rm -f conf.gdk_pixbuftest
|
||||
])
|
||||
|
||||
-# gettext.m4 serial 13 (gettext-0.11.1)
|
||||
+# gettext.m4 serial 14 (gettext-0.11.2)
|
||||
dnl Copyright (C) 1995-2002 Free Software Foundation, Inc.
|
||||
dnl This file is free software, distributed under the terms of the GNU
|
||||
dnl General Public License. As a special exception to the GNU General
|
||||
@@ -689,14 +689,13 @@
|
||||
dnl Now see whether libintl exists and does not depend on libiconv.
|
||||
AC_TRY_LINK([#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
extern
|
||||
#ifdef __cplusplus
|
||||
"C"
|
||||
#endif
|
||||
const char *_nl_expand_alias ();],
|
||||
[bindtextdomain ("", "");
|
||||
-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
|
||||
+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
|
||||
gt_cv_func_gnugettext_libintl=yes,
|
||||
gt_cv_func_gnugettext_libintl=no)
|
||||
dnl Now see whether libintl exists and depends on libiconv.
|
||||
@@ -704,14 +703,13 @@
|
||||
LIBS="$LIBS $LIBICONV"
|
||||
AC_TRY_LINK([#include <libintl.h>
|
||||
extern int _nl_msg_cat_cntr;
|
||||
-extern int *_nl_domain_bindings;
|
||||
extern
|
||||
#ifdef __cplusplus
|
||||
"C"
|
||||
#endif
|
||||
const char *_nl_expand_alias ();],
|
||||
[bindtextdomain ("", "");
|
||||
-return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_domain_bindings + *_nl_expand_alias (0)],
|
||||
+return (int) gettext ("")]ifelse([$2], [need-ngettext], [ + (int) ngettext ("", "", 0)], [])[ + _nl_msg_cat_cntr + *_nl_expand_alias (0)],
|
||||
[LIBINTL="$LIBINTL $LIBICONV"
|
||||
LTLIBINTL="$LTLIBINTL $LTLIBICONV"
|
||||
gt_cv_func_gnugettext_libintl=yes
|
11
audio/gqmpeg/files/patch-ad
Normal file
11
audio/gqmpeg/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.in.orig Sun Jan 20 09:20:14 2002
|
||||
+++ Makefile.in Sun Jan 20 09:20:32 2002
|
||||
@@ -118,7 +118,7 @@
|
||||
skindir = $(prefix)/share/gqmpeg/skins
|
||||
skin_DATA = SKIN-SPECS README
|
||||
|
||||
-@HAVE_GNOME_TRUE@desktopdir = @HAVE_GNOME_TRUE@$(GNOME_DATADIR)/gnome/apps/Multimedia
|
||||
+@HAVE_GNOME_TRUE@desktopdir = @HAVE_GNOME_TRUE@$(GNOME_DATADIR)/apps/Multimedia
|
||||
@HAVE_GNOME_TRUE@desktop_DATA = @HAVE_GNOME_TRUE@gqmpeg.desktop
|
||||
|
||||
@HAVE_GNOME_TRUE@icondir = @HAVE_GNOME_TRUE@$(GNOME_DATADIR)/pixmaps
|
11
audio/gqmpeg/files/patch-configure.in
Normal file
11
audio/gqmpeg/files/patch-configure.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.in.orig Fri Nov 9 14:42:36 2001
|
||||
+++ configure.in Sun Nov 11 22:13:39 2001
|
||||
@@ -83,7 +83,7 @@
|
||||
dnl CHECK_GNOME
|
||||
AC_PATH_PROG(GNOME_CONFIG,gnome-config,no)
|
||||
AM_CONDITIONAL(HAVE_GNOME, test $GNOME_CONFIG != no)
|
||||
- if test "$GNOME_CONFIG" = no; then
|
||||
+ if test "$GNOME_CONFIG" = no -o "$USE_GNOME" != yes; then
|
||||
AC_MSG_RESULT(GNOME icon and menu entry will NOT be installed)
|
||||
else
|
||||
AC_MSG_RESULT(will install a GNOME icon and menu entry)
|
14
audio/gqmpeg/files/patch-po_Makefile.in.in
Normal file
14
audio/gqmpeg/files/patch-po_Makefile.in.in
Normal file
@ -0,0 +1,14 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- po/Makefile.in.in.orig Wed Jul 24 16:24:35 2002
|
||||
+++ po/Makefile.in.in Wed Jul 24 16:25:07 2002
|
||||
@@ -21,7 +21,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
datadir = @datadir@
|
||||
-localedir = $(datadir)/locale
|
||||
+localedir = $(prefix)/share/locale
|
||||
gettextsrcdir = $(datadir)/gettext/po
|
||||
|
||||
INSTALL = @INSTALL@
|
@ -1,7 +1,7 @@
|
||||
bin/gqmpeg
|
||||
bin/gqmpeg-shoutcast-plugin.sh
|
||||
%%DATADIR%%/applications/gqmpeg.desktop
|
||||
%%DATADIR%%/pixmaps/gqmpeg.png
|
||||
%%GNOME:%%%%DATADIR%%/apps/Multimedia/gqmpeg.desktop
|
||||
%%GNOME:%%%%DATADIR%%/pixmaps/gqmpeg.png
|
||||
share/gqmpeg/skins/README
|
||||
share/gqmpeg/skins/SKIN-SPECS
|
||||
share/gqmpeg/skins/mrclean/blue-handle-24.png
|
||||
|
Loading…
Reference in New Issue
Block a user