Add Sauerbraten, a first person shooter based on Cube.

PR:		ports/92712
Submitted by:	Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
This commit is contained in:
Sam Lawrance 2006-04-30 10:25:12 +00:00
parent 19c3d66216
commit 1ccc7e7daf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160894
25 changed files with 4483 additions and 0 deletions

View File

@ -544,6 +544,7 @@
SUBDIR += rubix
SUBDIR += ruby-exmars
SUBDIR += sarien
SUBDIR += sauerbraten
SUBDIR += scare
SUBDIR += scid
SUBDIR += scorched3d

View File

@ -0,0 +1,63 @@
# New ports collection makefile for: sauerbraten
# Date created: 2006-02-01
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= sauerbraten
PORTVERSION= 20060320
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sauerbraten
DISTNAME= ${PORTNAME}_2006_03_20_shader_edition_linux
MAINTAINER= acardenas@bsd.org.pe
COMMENT= First person shooter based on Cube
USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= sdl image mixer
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259 aclocal:19 automake:19
GNU_CONFIGURE= yes
AUTOMAKE_ARGS= -a -c --foreign --add-missing
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
SAUDATDIR= packages data
SUB_FILES= sauer_client sauer_server pkg-message
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not build on 4.x
.endif
post-extract:
@${FIND} ${WRKSRC} -type d -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
post-patch:
@${REINPLACE_CMD} -e 's|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Makefile
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/sauer_client ${WRKDIR}/sauer_server ${PREFIX}/bin
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/sauer_client ${BUILD_WRKSRC}/sauer_server ${PREFIX}/libexec
@${MKDIR} ${DATADIR}
@cd ${WRKSRC} && \
${FIND} -E ${SAUDATDIR} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${SAUDATDIR} -type f -iregex ".*\.(png|cfg|jpg|ogg|ogz|txt|md2|ms3d|qc|wav)" \
-exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/docs && \
${FIND} -E * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(html|css|jpg)" -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 0eb564fc664145c3744780a070c8bfec
SHA256 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = e3cb43409e883cbfc21dabf62d7e5d033c82dfc8c6672d21ed11899278aefd8a
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 51374842

View File

@ -0,0 +1,30 @@
--- src/Makefile Mon Mar 20 03:09:19 2006
+++ src/Makefile Mon Mar 27 11:48:36 2006
@@ -1,9 +1,8 @@
-CXX=g++
-CXXOPTFLAGS=-Wall -fsigned-char -O3 -fomit-frame-pointer
-CXXFLAGS=$(CXXOPTFLAGS) -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl-config --cflags`
+CXX=%%CXX%%
+CXXFLAGS=%%CXXFLAGS%% -I%%X11BASE%%/include -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl11-config --cflags` -DHAS_SOCKLEN_T
-PLATFORM_PREFIX=linux
-CLIENT_LIBS=-Lenet -lenet `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
+PLATFORM_PREFIX=FreeBSD
+CLIENT_LIBS=-L%%X11BASE%%/lib -Lenet -lenet `sdl11-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
CLIENT_OBJS= \
shared/tools.o \
engine/bsp.o \
@@ -42,11 +41,11 @@
all: libenet client server
libenet:
- -make -C enet/ all
+ -gmake -C enet/ all
clean:
-rm -f $(SERVER_OBJS) $(CLIENT_OBJS) sauer_server sauer_client
- -make -C enet/ clean
+ -gmake -C enet/ clean
engine/server-standalone.o:
$(CXX) $(CXXFLAGS) -DSTANDALONE -c -o engine/server-standalone.o engine/server.cpp

View File

@ -0,0 +1,9 @@
###############################################################################
1) First time, sauerbraten create ~/.sauerbraten directory and symlinks
2) Config files are into ~/.sauerbraten directory.
3) See %%DATADIR%%/data/keymap.cfg, if you want add new bind into
~/.sauerbraten/config.cfg
4) Enjoy it ;)
###############################################################################

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
fi

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
fi

View File

@ -0,0 +1,8 @@
Sauerbraten is multiplayer/singleplayer FPS game freeware game project, and
soon an RPG game project. Sauerbraten is an experimental engine based on
Cube, can be seen as "Next-Gen Cube", or "Cube 2". Much like cube, the aim
of this engine is not to produce the most eyecandy possible, but rather allow
map/geometry editing to be done dynamically in-game, and make map editing a
lot of fun.
WWW: http://sauerbraten.org/

File diff suppressed because it is too large Load Diff

63
games/redeclipse/Makefile Normal file
View File

@ -0,0 +1,63 @@
# New ports collection makefile for: sauerbraten
# Date created: 2006-02-01
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= sauerbraten
PORTVERSION= 20060320
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sauerbraten
DISTNAME= ${PORTNAME}_2006_03_20_shader_edition_linux
MAINTAINER= acardenas@bsd.org.pe
COMMENT= First person shooter based on Cube
USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= sdl image mixer
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259 aclocal:19 automake:19
GNU_CONFIGURE= yes
AUTOMAKE_ARGS= -a -c --foreign --add-missing
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
SAUDATDIR= packages data
SUB_FILES= sauer_client sauer_server pkg-message
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not build on 4.x
.endif
post-extract:
@${FIND} ${WRKSRC} -type d -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
post-patch:
@${REINPLACE_CMD} -e 's|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Makefile
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/sauer_client ${WRKDIR}/sauer_server ${PREFIX}/bin
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/sauer_client ${BUILD_WRKSRC}/sauer_server ${PREFIX}/libexec
@${MKDIR} ${DATADIR}
@cd ${WRKSRC} && \
${FIND} -E ${SAUDATDIR} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${SAUDATDIR} -type f -iregex ".*\.(png|cfg|jpg|ogg|ogz|txt|md2|ms3d|qc|wav)" \
-exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/docs && \
${FIND} -E * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(html|css|jpg)" -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 0eb564fc664145c3744780a070c8bfec
SHA256 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = e3cb43409e883cbfc21dabf62d7e5d033c82dfc8c6672d21ed11899278aefd8a
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 51374842

View File

@ -0,0 +1,30 @@
--- src/Makefile Mon Mar 20 03:09:19 2006
+++ src/Makefile Mon Mar 27 11:48:36 2006
@@ -1,9 +1,8 @@
-CXX=g++
-CXXOPTFLAGS=-Wall -fsigned-char -O3 -fomit-frame-pointer
-CXXFLAGS=$(CXXOPTFLAGS) -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl-config --cflags`
+CXX=%%CXX%%
+CXXFLAGS=%%CXXFLAGS%% -I%%X11BASE%%/include -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl11-config --cflags` -DHAS_SOCKLEN_T
-PLATFORM_PREFIX=linux
-CLIENT_LIBS=-Lenet -lenet `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
+PLATFORM_PREFIX=FreeBSD
+CLIENT_LIBS=-L%%X11BASE%%/lib -Lenet -lenet `sdl11-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
CLIENT_OBJS= \
shared/tools.o \
engine/bsp.o \
@@ -42,11 +41,11 @@
all: libenet client server
libenet:
- -make -C enet/ all
+ -gmake -C enet/ all
clean:
-rm -f $(SERVER_OBJS) $(CLIENT_OBJS) sauer_server sauer_client
- -make -C enet/ clean
+ -gmake -C enet/ clean
engine/server-standalone.o:
$(CXX) $(CXXFLAGS) -DSTANDALONE -c -o engine/server-standalone.o engine/server.cpp

View File

@ -0,0 +1,9 @@
###############################################################################
1) First time, sauerbraten create ~/.sauerbraten directory and symlinks
2) Config files are into ~/.sauerbraten directory.
3) See %%DATADIR%%/data/keymap.cfg, if you want add new bind into
~/.sauerbraten/config.cfg
4) Enjoy it ;)
###############################################################################

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
fi

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
fi

View File

@ -0,0 +1,8 @@
Sauerbraten is multiplayer/singleplayer FPS game freeware game project, and
soon an RPG game project. Sauerbraten is an experimental engine based on
Cube, can be seen as "Next-Gen Cube", or "Cube 2". Much like cube, the aim
of this engine is not to produce the most eyecandy possible, but rather allow
map/geometry editing to be done dynamically in-game, and make map editing a
lot of fun.
WWW: http://sauerbraten.org/

1349
games/redeclipse/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,63 @@
# New ports collection makefile for: sauerbraten
# Date created: 2006-02-01
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= sauerbraten
PORTVERSION= 20060320
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sauerbraten
DISTNAME= ${PORTNAME}_2006_03_20_shader_edition_linux
MAINTAINER= acardenas@bsd.org.pe
COMMENT= First person shooter based on Cube
USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= sdl image mixer
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:259 aclocal:19 automake:19
GNU_CONFIGURE= yes
AUTOMAKE_ARGS= -a -c --foreign --add-missing
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
SAUDATDIR= packages data
SUB_FILES= sauer_client sauer_server pkg-message
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not build on 4.x
.endif
post-extract:
@${FIND} ${WRKSRC} -type d -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
post-patch:
@${REINPLACE_CMD} -e 's|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Makefile
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/sauer_client ${WRKDIR}/sauer_server ${PREFIX}/bin
@${INSTALL_PROGRAM} ${BUILD_WRKSRC}/sauer_client ${BUILD_WRKSRC}/sauer_server ${PREFIX}/libexec
@${MKDIR} ${DATADIR}
@cd ${WRKSRC} && \
${FIND} -E ${SAUDATDIR} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${SAUDATDIR} -type f -iregex ".*\.(png|cfg|jpg|ogg|ogz|txt|md2|ms3d|qc|wav)" \
-exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/docs && \
${FIND} -E * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(html|css|jpg)" -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 0eb564fc664145c3744780a070c8bfec
SHA256 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = e3cb43409e883cbfc21dabf62d7e5d033c82dfc8c6672d21ed11899278aefd8a
MD5 (sauerbraten_2006_03_20_shader_edition_linux.tar.gz) = 51374842

View File

@ -0,0 +1,30 @@
--- src/Makefile Mon Mar 20 03:09:19 2006
+++ src/Makefile Mon Mar 27 11:48:36 2006
@@ -1,9 +1,8 @@
-CXX=g++
-CXXOPTFLAGS=-Wall -fsigned-char -O3 -fomit-frame-pointer
-CXXFLAGS=$(CXXOPTFLAGS) -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl-config --cflags`
+CXX=%%CXX%%
+CXXFLAGS=%%CXXFLAGS%% -I%%X11BASE%%/include -Ienet/include -I. -Ishared -Iengine -Ifpsgame `sdl11-config --cflags` -DHAS_SOCKLEN_T
-PLATFORM_PREFIX=linux
-CLIENT_LIBS=-Lenet -lenet `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
+PLATFORM_PREFIX=FreeBSD
+CLIENT_LIBS=-L%%X11BASE%%/lib -Lenet -lenet `sdl11-config --libs` -lSDL_image -lSDL_mixer -lz -lGL -lGLU
CLIENT_OBJS= \
shared/tools.o \
engine/bsp.o \
@@ -42,11 +41,11 @@
all: libenet client server
libenet:
- -make -C enet/ all
+ -gmake -C enet/ all
clean:
-rm -f $(SERVER_OBJS) $(CLIENT_OBJS) sauer_server sauer_client
- -make -C enet/ clean
+ -gmake -C enet/ clean
engine/server-standalone.o:
$(CXX) $(CXXFLAGS) -DSTANDALONE -c -o engine/server-standalone.o engine/server.cpp

View File

@ -0,0 +1,9 @@
###############################################################################
1) First time, sauerbraten create ~/.sauerbraten directory and symlinks
2) Config files are into ~/.sauerbraten directory.
3) See %%DATADIR%%/data/keymap.cfg, if you want add new bind into
~/.sauerbraten/config.cfg
4) Enjoy it ;)
###############################################################################

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_client
fi

View File

@ -0,0 +1,16 @@
#!/bin/sh
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
# ~/.sauerbraten, and create symlinks to the data files.
if [ -d "~/.sauerbraten" ]; then
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
else
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sauerbraten/{} \; || exit 1
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sauerbraten/{} \; 2>/dev/null || exit 1
cd ~/.sauerbraten || exit 1
exec %%PREFIX%%/libexec/sauer_server
fi

View File

@ -0,0 +1,8 @@
Sauerbraten is multiplayer/singleplayer FPS game freeware game project, and
soon an RPG game project. Sauerbraten is an experimental engine based on
Cube, can be seen as "Next-Gen Cube", or "Cube 2". Much like cube, the aim
of this engine is not to produce the most eyecandy possible, but rather allow
map/geometry editing to be done dynamically in-game, and make map editing a
lot of fun.
WWW: http://sauerbraten.org/

1349
games/sauerbraten/pkg-plist Normal file

File diff suppressed because it is too large Load Diff