- Pet portlint, switch to options helpers

PR:		202532
Submitted by:	cyberbotx@cyberbotx.com (maintainer)
This commit is contained in:
Dmitry Marakasov 2015-08-27 09:09:19 +00:00
parent 4cced8479f
commit 1cb88c91e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=395407
7 changed files with 36 additions and 38 deletions

View File

@ -16,7 +16,6 @@ USES= compiler:c++11-lib gmake pkgconfig tar:xz
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
#MAKE_ENV+= c="${CC} -std=gnu99" cpp="${CXX} -std=gnu++0x"
MAKE_ENV+= compiler="${CXX}" cflags="-x c -std=c99 ${CFLAGS}" \
cppflags="-x c++ -std=c++11 ${CXXFLAGS}"
@ -118,19 +117,18 @@ post-patch:
${WRKSRC}/target-ethos/Makefile
${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|' \
${WRKSRC}/nall/string/platform.hpp
.if ${PORT_OPTIONS:MDEBUG}
post-patch-DEBUG-on:
${REINPLACE_CMD} -e 's|-O3|-g|g' \
${WRKSRC}/ananke/Makefile \
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|:= -s|:= #|g' \
${WRKSRC}/Makefile
.endif
# ${RM} ${WRKSRC}/shaders/Sepia.Direct3D.shader
pre-build-QT4-on:
(cd ${WRKSRC}/phoenix/qt && ${MOC} -i -o platform.moc platform.moc.hpp)
do-build:
.if ${PORT_OPTIONS:MQT4}
(cd ${WRKSRC}/phoenix/qt && ${MOC} -i -o platform.moc platform.moc.hpp)
.endif
.for d in . ananke
(cd ${WRKSRC}/${d} && ${MAKE_CMD} ${MAKE_ENV})
.endfor

View File

@ -1,6 +1,6 @@
--- ./nall/platform.hpp.orig 2014-03-16 21:33:25.000000000 -0400
+++ ./nall/platform.hpp 2014-03-16 21:45:07.000000000 -0400
@@ -41,7 +41,7 @@
--- nall/platform.hpp.orig 2014-01-20 06:37:12 UTC
+++ nall/platform.hpp
@@ -41,7 +41,7 @@ namespace Math {
#undef interface
#define dllexport __declspec(dllexport)
#else

View File

@ -1,6 +1,6 @@
--- ./ruby/video/glx.cpp.orig 2014-01-20 01:37:14.000000000 -0500
+++ ./ruby/video/glx.cpp 2014-06-02 23:32:39.000000000 -0400
@@ -128,6 +128,28 @@
--- ruby/video/glx.cpp.orig 2014-01-20 06:37:14 UTC
+++ ruby/video/glx.cpp
@@ -128,6 +128,28 @@ struct pVideoGLX : OpenGL {
//require GLX 1.2+ API
if(glx.version_major < 1 || (glx.version_major == 1 && glx.version_minor < 2)) return false;

View File

@ -1,22 +0,0 @@
--- ./target-ethos/general/presentation.cpp.orig 2013-12-06 15:19:40.000000000 -0500
+++ ./target-ethos/general/presentation.cpp 2014-03-16 22:40:31.000000000 -0400
@@ -235,7 +235,7 @@
void Presentation::loadShaders() {
//only the OpenGL driver has video shader support
if(config->video.driver == "OpenGL") {
- string pathname = program->path("Video Shaders/");
+ string pathname = program->path("shaders/");
lstring shaders = directory::folders(pathname, "*.shader");
for(auto& name : shaders) {
auto shader = new RadioItem;
--- ./target-ethos/utility/utility.cpp.orig 2013-12-21 02:00:03.000000000 -0500
+++ ./target-ethos/utility/utility.cpp 2014-03-16 22:41:03.000000000 -0400
@@ -203,7 +203,7 @@
video.set(Video::Filter, Video::FilterLinear);
} else if(config->video.shader == "Display Emulation") {
if(program->active) {
- string pathname = program->path("Video Shaders/");
+ string pathname = program->path("shaders/");
pathname.append("Display Emulation/");
pathname.append(presentation->systemName, ".shader/");
if(directory::exists(pathname)) {

View File

@ -1,6 +1,6 @@
--- ./target-ethos/Makefile.orig 2014-01-13 00:26:29.000000000 -0500
+++ ./target-ethos/Makefile 2014-03-16 21:57:02.000000000 -0400
@@ -27,9 +27,9 @@
--- target-ethos/Makefile.orig 2014-01-13 05:26:29 UTC
+++ target-ethos/Makefile
@@ -27,9 +27,9 @@ else ifeq ($(platform),linux)
ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.pulseaudiosimple audio.ao
ruby += input.udev input.sdl input.x
else ifeq ($(platform),bsd)

View File

@ -0,0 +1,11 @@
--- target-ethos/general/presentation.cpp.orig 2013-12-06 20:19:40 UTC
+++ target-ethos/general/presentation.cpp
@@ -235,7 +235,7 @@ void Presentation::bootstrap() {
void Presentation::loadShaders() {
//only the OpenGL driver has video shader support
if(config->video.driver == "OpenGL") {
- string pathname = program->path("Video Shaders/");
+ string pathname = program->path("shaders/");
lstring shaders = directory::folders(pathname, "*.shader");
for(auto& name : shaders) {
auto shader = new RadioItem;

View File

@ -0,0 +1,11 @@
--- target-ethos/utility/utility.cpp.orig 2013-12-21 07:00:03 UTC
+++ target-ethos/utility/utility.cpp
@@ -203,7 +203,7 @@ void Utility::updateShader() {
video.set(Video::Filter, Video::FilterLinear);
} else if(config->video.shader == "Display Emulation") {
if(program->active) {
- string pathname = program->path("Video Shaders/");
+ string pathname = program->path("shaders/");
pathname.append("Display Emulation/");
pathname.append(presentation->systemName, ".shader/");
if(directory::exists(pathname)) {