Hard code the path to nmap w/in nmapfe. Thus it will work in the face of a

limited path.

Bug reported by:	Andre Albsmeier <andre.albsmeier@mchp.siemens.de>
This commit is contained in:
David E. O'Brien 1999-07-23 18:21:54 +00:00
parent 50fbbf4c4d
commit 1cb3956451
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20329
6 changed files with 138 additions and 0 deletions

View File

@ -0,0 +1,25 @@
--- nmapfe/Makefile.in.orig Fri May 7 04:51:52 1999
+++ nmapfe/Makefile.in Fri Jul 23 10:46:08 1999
@@ -71,7 +71,7 @@
PROGRAMS = $(bin_PROGRAMS)
-DEFS = @DEFS@ -I. -I$(srcdir)
+DEFS = @DEFS@ -DNMAP_PATH=\"$(bindir)/\" -I. -I$(srcdir)
CPPFLAGS = @CPPFLAGS@
STATIC =
LDFLAGS = @LDFLAGS@ $(STATIC)
@@ -231,11 +231,11 @@
maintainer-clean-depend:
-rm -rf .deps
-%.o: %.c
+.c.o:
@echo '$(COMPILE) -c $<'; \
$(COMPILE) -c $<
-%.lo: %.c
+.c.lo:
@echo '$(LTCOMPILE) -c $<'; \
$(LTCOMPILE) -c $<
@-sed -e 's/^\([^:]*\)\.o:/\1.lo \1.o:/' \

View File

@ -0,0 +1,21 @@
--- nmapfe/nmapfe_sig.c.orig Fri May 7 04:51:52 1999
+++ nmapfe/nmapfe_sig.c Fri Jul 23 11:09:45 1999
@@ -171,7 +171,7 @@
on_Get_Nmap_Version_activate (GtkMenuItem *menuitem,
gpointer user_data)
{
- execute("nmap -V");
+ execute( NMAP_PATH "nmap -V");
}
@@ -296,7 +296,8 @@
if (size > command_size)
command = realloc(command, size);
- strcpy(command, "nmap ");
+ strcpy(command, NMAP_PATH);
+ strcat(command, "nmap ");
/*Uhm... yeah.. Spit out which scan to perform based
on the which_scan variable */

View File

@ -0,0 +1,25 @@
--- nmapfe/Makefile.in.orig Fri May 7 04:51:52 1999
+++ nmapfe/Makefile.in Fri Jul 23 10:46:08 1999
@@ -71,7 +71,7 @@
PROGRAMS = $(bin_PROGRAMS)
-DEFS = @DEFS@ -I. -I$(srcdir)
+DEFS = @DEFS@ -DNMAP_PATH=\"$(bindir)/\" -I. -I$(srcdir)
CPPFLAGS = @CPPFLAGS@
STATIC =
LDFLAGS = @LDFLAGS@ $(STATIC)
@@ -231,11 +231,11 @@
maintainer-clean-depend:
-rm -rf .deps
-%.o: %.c
+.c.o:
@echo '$(COMPILE) -c $<'; \
$(COMPILE) -c $<
-%.lo: %.c
+.c.lo:
@echo '$(LTCOMPILE) -c $<'; \
$(LTCOMPILE) -c $<
@-sed -e 's/^\([^:]*\)\.o:/\1.lo \1.o:/' \

View File

@ -0,0 +1,21 @@
--- nmapfe/nmapfe_sig.c.orig Fri May 7 04:51:52 1999
+++ nmapfe/nmapfe_sig.c Fri Jul 23 11:09:45 1999
@@ -171,7 +171,7 @@
on_Get_Nmap_Version_activate (GtkMenuItem *menuitem,
gpointer user_data)
{
- execute("nmap -V");
+ execute( NMAP_PATH "nmap -V");
}
@@ -296,7 +296,8 @@
if (size > command_size)
command = realloc(command, size);
- strcpy(command, "nmap ");
+ strcpy(command, NMAP_PATH);
+ strcat(command, "nmap ");
/*Uhm... yeah.. Spit out which scan to perform based
on the which_scan variable */

View File

@ -0,0 +1,25 @@
--- nmapfe/Makefile.in.orig Fri May 7 04:51:52 1999
+++ nmapfe/Makefile.in Fri Jul 23 10:46:08 1999
@@ -71,7 +71,7 @@
PROGRAMS = $(bin_PROGRAMS)
-DEFS = @DEFS@ -I. -I$(srcdir)
+DEFS = @DEFS@ -DNMAP_PATH=\"$(bindir)/\" -I. -I$(srcdir)
CPPFLAGS = @CPPFLAGS@
STATIC =
LDFLAGS = @LDFLAGS@ $(STATIC)
@@ -231,11 +231,11 @@
maintainer-clean-depend:
-rm -rf .deps
-%.o: %.c
+.c.o:
@echo '$(COMPILE) -c $<'; \
$(COMPILE) -c $<
-%.lo: %.c
+.c.lo:
@echo '$(LTCOMPILE) -c $<'; \
$(LTCOMPILE) -c $<
@-sed -e 's/^\([^:]*\)\.o:/\1.lo \1.o:/' \

View File

@ -0,0 +1,21 @@
--- nmapfe/nmapfe_sig.c.orig Fri May 7 04:51:52 1999
+++ nmapfe/nmapfe_sig.c Fri Jul 23 11:09:45 1999
@@ -171,7 +171,7 @@
on_Get_Nmap_Version_activate (GtkMenuItem *menuitem,
gpointer user_data)
{
- execute("nmap -V");
+ execute( NMAP_PATH "nmap -V");
}
@@ -296,7 +296,8 @@
if (size > command_size)
command = realloc(command, size);
- strcpy(command, "nmap ");
+ strcpy(command, NMAP_PATH);
+ strcat(command, "nmap ");
/*Uhm... yeah.. Spit out which scan to perform based
on the which_scan variable */