parent
1e96f2755d
commit
1c5eff158b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=398661
@ -2,8 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= variety
|
||||
PORTVERSION= 0.5.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.5.4
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://launchpad.net/variety/trunk/${PORTVERSION}/+download/ \
|
||||
http://nivit.altervista.org/FreeBSD/ports/distfiles/
|
||||
@ -46,6 +46,7 @@ WRKSRC= ${WRKDIR}/variety
|
||||
|
||||
post-patch:
|
||||
@(cd ${WRKSRC} && ${REINPLACE_CMD} \
|
||||
-i '' \
|
||||
-E -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
|
||||
-e 's,%%PREFIX%%,${PREFIX},1' \
|
||||
-e 's,/usr(/share/backgrounds),${LOCALBASE}\1,1' \
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (variety_0.5.3.tar.gz) = 48bd7f9a1f857bb00ffac4548f201d83e05eecef2e5cf04539a088198c177965
|
||||
SIZE (variety_0.5.3.tar.gz) = 3471248
|
||||
SHA256 (variety_0.5.4.tar.gz) = 56e1de00cff34d18dcca7dbfbbb5a03cd58cb7ffb8c34f63a167f8b45ae7ba2d
|
||||
SIZE (variety_0.5.4.tar.gz) = 825088
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- setup.py.orig 2015-02-08 18:03:27 UTC
|
||||
+++ setup.py
|
||||
@@ -60,7 +60,10 @@ def update_desktop_file(datadir):
|
||||
|
||||
for line in fin:
|
||||
if 'Icon=' in line:
|
||||
- line = "Icon=%s\n" % (datadir + 'media/variety.svg')
|
||||
+ line = "Icon=%s\n" % (datadir + '/share/variety/media/variety.svg')
|
||||
+ if 'Exec=/opt' in line:
|
||||
+ cmd, arg = line.split()
|
||||
+ line = "Exec=%s %s\n" % (datadir + '/bin/variety', arg)
|
||||
fout.write(line)
|
||||
fout.flush()
|
||||
fout.close()
|
||||
@@ -76,7 +79,7 @@ class InstallAndUpdateDataDirectory(Dist
|
||||
values = {'__variety_data_directory__': "'%s'" % (self.prefix + '/share/variety/'),
|
||||
'__version__': "'%s'" % self.distribution.get_version()}
|
||||
previous_values = update_config(values)
|
||||
- update_desktop_file(self.prefix + '/share/variety/')
|
||||
+ update_desktop_file(self.prefix)
|
||||
DistUtilsExtra.auto.install_auto.run(self)
|
||||
update_config(previous_values)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- variety/VarietyWindow.py.orig 2015-03-07 10:46:27 UTC
|
||||
--- variety/VarietyWindow.py.orig 2015-09-06 14:49:07 UTC
|
||||
+++ variety/VarietyWindow.py
|
||||
@@ -2333,7 +2333,7 @@ To set a specific wallpaper: %prog /some
|
||||
@@ -2339,7 +2339,7 @@ To set a specific wallpaper: %prog /some
|
||||
("auto" if refresh_level == VarietyWindow.RefreshLevel.ALL else "refresh")
|
||||
logger.debug(lambda: "Running set_wallpaper script with parameters: %s, %s, %s" % (wallpaper, auto, original_file))
|
||||
try:
|
||||
@ -9,12 +9,3 @@
|
||||
except subprocess.CalledProcessError, e:
|
||||
if e.returncode == 124:
|
||||
logger.error(lambda: "Timeout while running set_wallpaper script, killed")
|
||||
@@ -2695,7 +2695,7 @@ To set a specific wallpaper: %prog /some
|
||||
"Name=Variety\n"
|
||||
"Comment=Variety Wallpaper Changer\n"
|
||||
"Icon=%s\n"
|
||||
- 'Exec=sh -c "/opt/extras.ubuntu.com/variety/bin/variety || /usr/bin/variety || /opt/variety/bin/variety"\n'
|
||||
+ 'Exec=sh -c "%%PREFIX%%/bin/variety"\n'
|
||||
"Terminal=false\n"
|
||||
"Type=Application\n"
|
||||
"X-GNOME-Autostart-Delay=20\n"
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- variety/__init__.py.orig 2015-03-07 13:09:20 UTC
|
||||
+++ variety/__init__.py
|
||||
@@ -155,6 +155,12 @@ def main():
|
||||
signal.signal(signal.SIGTERM, sigint_handler)
|
||||
signal.signal(signal.SIGQUIT, sigint_handler)
|
||||
|
||||
+ if 34015728 <= sys.hexversion:
|
||||
+ from setuptools import ssl_support as ssl_support
|
||||
+ ssl_cert_file = ssl_support.find_ca_bundle()
|
||||
+ if not ssl_cert_file and not 'SSL_CERT_FILE' in os.environ:
|
||||
+ os.environ['SSL_CERT_FILE'] = '%%LOCALBASE%%/share/certs/ca-root-nss.crt'
|
||||
+
|
||||
Util.makedirs(os.path.expanduser(u"~/.config/variety/"))
|
||||
|
||||
arguments = map(_u, sys.argv[1:])
|
@ -44,6 +44,9 @@ bin/variety
|
||||
%%PYTHON_SITELIBDIR%%/variety/AvgColor.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/AvgColor.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/AvgColor.pyo
|
||||
%%PYTHON_SITELIBDIR%%/variety/BingDownloader.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/BingDownloader.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/BingDownloader.pyo
|
||||
%%PYTHON_SITELIBDIR%%/variety/CalibrateDominantColors.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/CalibrateDominantColors.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/CalibrateDominantColors.pyo
|
||||
@ -125,6 +128,9 @@ bin/variety
|
||||
%%PYTHON_SITELIBDIR%%/variety/ThumbsWindow.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/ThumbsWindow.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/ThumbsWindow.pyo
|
||||
%%PYTHON_SITELIBDIR%%/variety/UnsplashDownloader.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/UnsplashDownloader.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/UnsplashDownloader.pyo
|
||||
%%PYTHON_SITELIBDIR%%/variety/Util.py
|
||||
%%PYTHON_SITELIBDIR%%/variety/Util.pyc
|
||||
%%PYTHON_SITELIBDIR%%/variety/Util.pyo
|
||||
@ -187,6 +193,9 @@ share/help/C/variety/figures/icon.png
|
||||
share/help/C/variety/index.page
|
||||
share/help/C/variety/preferences.page
|
||||
share/help/C/variety/topic1.page
|
||||
share/icons/hicolor/22x22/apps/variety-indicator-dark.png
|
||||
share/icons/hicolor/22x22/apps/variety-indicator.png
|
||||
share/icons/hicolor/scalable/apps/variety.svg
|
||||
share/locale/bg/LC_MESSAGES/variety.mo
|
||||
share/locale/de/LC_MESSAGES/variety.mo
|
||||
share/locale/es/LC_MESSAGES/variety.mo
|
||||
|
Loading…
Reference in New Issue
Block a user