graphics/drawpile: Update 2.1.0 -> 2.1.1

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2019-02-18 10:29:55 +00:00
parent c026fee6b9
commit 1c5e23607e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493256
5 changed files with 19 additions and 64 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= Drawpile
DISTVERSION= 2.1.0
DISTVERSION= 2.1.1
CATEGORIES= graphics python
MAINTAINER= yuri@FreeBSD.org
@ -20,25 +20,13 @@ USES= cmake desktop-file-utils kde:5 pkgconfig qt:5 shared-mime-info
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME:tl}
USE_QT= core gui multimedia network sql svg widgets buildtools_build linguisttools_build qmake_build
USE_KDE= archive
USE_KDE= archive dnssd
OPTIONS_DEFINE= DOCS
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
PLIST_SUB= PORTVERSION=${PORTVERSION}
post-install:
.for SZ in 16 32 64 128 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/mimetypes
${INSTALL_DATA} ${WRKSRC}/desktop/drawpile-${SZ}x${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/drawpile.png
${INSTALL_DATA} ${WRKSRC}/desktop/drawpile-${SZ}x${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/mimetypes/application-x-drawpile-recording.png
${INSTALL_DATA} ${WRKSRC}/desktop/drawpile-${SZ}x${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/mimetypes/gnome-mime-application-x-drawpile-recording.png
.endfor
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/mimetypes
${GZIP_CMD} ${GZIP} < ${WRKSRC}/desktop/drawpile.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/mimetypes/drawpile.svgz
@${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/desktop/x-drawpile.xml ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/desktop/net.drawpile.drawpile.desktop ${STAGEDIR}${PREFIX}/share/applications
@${RM} ${STAGEDIR}${DOCSDIR}/COPYING
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1550369609
SHA256 (drawpile-Drawpile-2.1.0_GH0.tar.gz) = df003da4b808f336405b697f135135c8b660a21de81d3be2dd9acfcd8966408b
SIZE (drawpile-Drawpile-2.1.0_GH0.tar.gz) = 2332950
TIMESTAMP = 1550484552
SHA256 (drawpile-Drawpile-2.1.1_GH0.tar.gz) = 69768c72f834904af7d39d662aba9953710327bcabaf1422551ef636b60d83b6
SIZE (drawpile-Drawpile-2.1.1_GH0.tar.gz) = 2380321

View File

@ -1,31 +0,0 @@
--- desktop/CMakeLists.txt.orig 2019-02-13 17:11:53 UTC
+++ desktop/CMakeLists.txt
@@ -1,8 +1,8 @@
-find_program(XDGICON xdg-icon-resource)
-find_program(XDGMENU xdg-desktop-menu)
-find_program(XDGMIME xdg-mime)
+#find_program(XDGICON xdg-icon-resource)
+#find_program(XDGMENU xdg-desktop-menu)
+#find_program(XDGMIME xdg-mime)
-if( XDGICON )
+if( FALSE )
install(CODE "
execute_process(COMMAND ${XDGICON} install --novendor ${CMAKE_CURRENT_SOURCE_DIR}/drawpile-16x16.png --size 16 drawpile)
execute_process(COMMAND ${XDGICON} install --novendor ${CMAKE_CURRENT_SOURCE_DIR}/drawpile-32x32.png --size 32 drawpile)
@@ -18,13 +18,13 @@ if( XDGICON )
")
endif()
-if( XDGMENU )
+if( FALSE )
install(CODE "
execute_process(COMMAND ${XDGMENU} install --novendor ${CMAKE_CURRENT_SOURCE_DIR}/net.drawpile.drawpile.desktop)
")
endif()
-if( XDGMIME )
+if( FALSE )
install(CODE "
execute_process(COMMAND ${XDGMIME} install ${CMAKE_CURRENT_SOURCE_DIR}/x-drawpile.xml)
")

View File

@ -1,5 +1,12 @@
--- doc/CMakeLists.txt.orig 2017-06-26 15:54:00 UTC
--- doc/CMakeLists.txt.orig 2019-02-18 10:23:08 UTC
+++ doc/CMakeLists.txt
@@ -1,6 +1,5 @@
SET(base_files
../ChangeLog
- ../COPYING
../README.md
openraster.txt
textloader.md
@@ -20,6 +20,6 @@ if (UNIX AND NOT APPLE)
)
INSTALL (

View File

@ -3,13 +3,6 @@ bin/drawpile-%%PORTVERSION%%
bin/drawpile-srv
man/man1/drawpile-srv.1.gz
share/applications/net.drawpile.drawpile.desktop
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/logins.md
%%PORTDOCS%%%%DOCSDIR%%/messages.md
%%PORTDOCS%%%%DOCSDIR%%/openraster.txt
%%PORTDOCS%%%%DOCSDIR%%/protocol.md
%%PORTDOCS%%%%DOCSDIR%%/textloader.md
share/drawpile/drawpile/i18n/drawpile_cs.qm
share/drawpile/drawpile/i18n/drawpile_de.qm
share/drawpile/drawpile/i18n/drawpile_fi.qm
@ -168,19 +161,17 @@ share/drawpile/drawpile/theme/light/zoom-out.svg
share/drawpile/drawpile/theme/light/zoom-select.svg
share/icons/hicolor/128x128/apps/drawpile.png
share/icons/hicolor/128x128/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/128x128/mimetypes/gnome-mime-application-x-drawpile-recording.png
share/icons/hicolor/16x16/apps/drawpile.png
share/icons/hicolor/16x16/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/16x16/mimetypes/gnome-mime-application-x-drawpile-recording.png
share/icons/hicolor/256x256/apps/drawpile.png
share/icons/hicolor/256x256/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/256x256/mimetypes/gnome-mime-application-x-drawpile-recording.png
share/icons/hicolor/32x32/apps/drawpile.png
share/icons/hicolor/32x32/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/32x32/mimetypes/gnome-mime-application-x-drawpile-recording.png
share/icons/hicolor/48x48/apps/drawpile.png
share/icons/hicolor/48x48/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/64x64/apps/drawpile.png
share/icons/hicolor/64x64/mimetypes/application-x-drawpile-recording.png
share/icons/hicolor/64x64/mimetypes/gnome-mime-application-x-drawpile-recording.png
share/icons/hicolor/scalable/mimetypes/drawpile.svgz
share/icons/hicolor/scalable/apps/drawpile.svgz
share/icons/hicolor/scalable/mimetypes/application-x-drawpile-recording.svgz
share/metainfo/net.drawpile.drawpile.appdata.xml
share/mime/packages/x-drawpile.xml