update ntop to 2.2

PR:		51077
Submitted by:	Ying-Chieh Liao <ijliao@terry.dorm11.nctu.edu.tw>
This commit is contained in:
Oliver Lehmann 2003-06-15 18:50:37 +00:00
parent 3a18feadf1
commit 1c5bee2711
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83032
6 changed files with 490 additions and 430 deletions

View File

@ -6,77 +6,71 @@
#
PORTNAME= ntop
PORTVERSION= 2.0.99.r2
PORTREVISION= 2
PORTVERSION= 2.2
PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= http://luca.ntop.org/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S|.r|-rc|}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
# Besides the required dependencies listed here, this port can optionally
# make use of sysutils/lsof and security/nmap if installed.
BUILD_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
RUN_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
.endif
# ntop will store its runtime database files in ${DBDIR}/ntop/
DBDIR?= /var/db
# The default startup script in ${LOCALBASE}/etc/rc.d will invoke
# with a flag to force it to log to ${LOGDIR}
LOGDIR?= /var/log
WRKSRC= ${WRKDIR}/RC2/${PORTNAME}
USE_AUTOMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
USE_GMAKE= yes
USE_REINPLACE= yes
USE_OPENSSL= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
PLIST_SUB+= DBDIR=${DBDIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= LIBS="-lcrypto -L${LOCALBASE}/lib -lgnugetopt"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-gdbm-root=${LOCALBASE} \
--with-ossl-root=${OPENSSLBASE} \
--with-gdchart-root=${LOCALBASE}
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}" \
CAT="${CAT}" \
OPTIONS="${OPTIONS}" \
REALCURDIR="${.CURDIR}"
.if !defined(WITHOUT_TCPWRAP)
CONFIGURE_ARGS+= --enable-tcpwrap
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400014
LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
CONFIGURE_ARGS+= --with-ossl-root=${LOCALBASE}
.endif
MAN1= intop.1
MAN8= ntop.8
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
.include <bsd.port.pre.mk>
# Remove included dependencies as a precaution against polluting the
# configuration. Not strictly necessary.
pre-configure:
@ ${RM} -rf ${WRKDIR}/RC2/gdchart*
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.sh
post-configure:
@ ${SED} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
pkg-message > ${PKGMESSAGE}
post-patch:
@${REINPLACE_CMD} -e "s,-lgdchart,-lgdc,g" \
-e "s,-lglib,-lglib12,g" ${WRKSRC}/configure
post-install:
@ ${MKDIR} ${DBDIR}/ntop
@ ${MKDIR} ${PREFIX}/etc/rc.d
@ ${SED} -e "s#%%PREFIX%%#${PREFIX}#g" \
-e "s#%%LOGDIR%%#${LOGDIR}#g" ${FILESDIR}/ntop.sh > \
${WRKDIR}/ntop.sh
@ ${INSTALL_DATA} ${WRKDIR}/ntop.sh ${PREFIX}/etc/rc.d
@${MKDIR} ${DBDIR}/ntop
@${MKDIR} ${PREFIX}/etc/rc.d
@${SED} -e "s#%%PREFIX%%#${PREFIX}#g" \
-e "s#%%LOGDIR%%#${LOGDIR}#g" ${FILESDIR}/ntop.sh > \
${WRKDIR}/ntop.sh
@${INSTALL_DATA} ${WRKDIR}/ntop.sh ${PREFIX}/etc/rc.d
.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}
@${SED} "s,%%LOCALBASE%%,${LOCALBASE},g" < ${PKGMESSAGE}
.endif
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (ntop-2.0.99-rc2.tgz) = d2eebe53b21c954abd44f8b96483bf8c
MD5 (ntop-2.2.tgz) = 4586e4173fcab64d2394502603fc73aa

View File

@ -1,14 +0,0 @@
--- Makefile.am.orig Tue May 14 20:12:55 2002
+++ Makefile.am Mon Jun 24 14:42:42 2002
@@ -218,10 +218,10 @@
/bin/rm -f privkey.pem cert.pem
install-data-local:
- @cp -p ntop-cert.pem $(DESTDIR)$(bindir)/ntop-cert.pem
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(libdir)/plugins;
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop;
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop/html;
+ @cp -p ntop-cert.pem $(DESTDIR)/$(datadir)/ntop/ntop-cert.pem
@for file in $(NTOPHTML); do \
if test -d $$file; then \
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop/$$file; \

View File

@ -1,55 +0,0 @@
--- configure.in.orig Fri May 31 19:09:35 2002
+++ configure.in Sun Sep 15 20:29:44 2002
@@ -826,12 +826,10 @@
if test ".${GDBM_ROOT}" != .; then
AC_MSG_CHECKING([for the GNU Database Manager Library gdbm (required package)])
- if test -d $GDBM_ROOT &&
- test -r $GDBM_ROOT/libgdbm.a &&
- test -r $GDBM_ROOT/gdbm.h; then
+ if test 1; then
GDBM_ROOT=`cd ${GDBM_ROOT} && pwd`
- CORELIBS="${CORELIBS} -L$GDBM_ROOT -lgdbm"
- INCS="${INCS} -I$GDBM_ROOT"
+ CORELIBS="${CORELIBS} -L${GDBM_ROOT}/lib -lgdbm"
+ INCS="${INCS} -I${GDBM_ROOT}/include"
AC_DEFINE(HAVE_GDBM_H)
AC_MSG_RESULT([found in $GDBM_ROOT])
else
@@ -907,16 +905,11 @@
dnl>
dnl> user defined directory passed as option at configuration time
dnl>
- if test ".${GDCHART_ROOT}" != .; then
- if test -d $GDCHART_ROOT &&
- test -r $GDCHART_ROOT/libgdchart.a &&
- test -r $GDCHART_ROOT/gdc.h &&
- test -r $GDCHART_ROOT/gd-1.8.3/libgd.a &&
- test -r $GDCHART_ROOT/gd-1.8.3/gd.h &&
- test -r $GDCHART_ROOT/zlib-1.1.4/libz.a; then
+ if test 1; then
+ if test -d $GDCHART_ROOT; then
GDCHART_ROOT=`cd ${GDCHART_ROOT} && pwd`
- MORELIBS="${MORELIBS} -L$GDCHART_ROOT -lgdchart -L$GDCHART_ROOT/gd-1.8.3 -lgd -L$GDCHART_ROOT/gd-1.8.3/libpng-1.2.1 -lpng -L$GDCHART_ROOT/zlib-1.1.4 -lz"
- INCS="${INCS} -I$GDCHART_ROOT -I$GDCHART_ROOT/zlib-1.1.4"
+ MORELIBS="${MORELIBS} -L${prefix}/lib -lgdc -lgd -lpng -lz"
+ INCS="${INCS} -I${prefix}/include/gd"
AC_DEFINE(HAVE_GDCHART)
AC_DEFINE(HAVE_ZLIB)
AC_MSG_RESULT([found in $GDCHART_ROOT])
@@ -971,12 +964,10 @@
if test ".$ac_disable_openssl" = ".no"; then
AC_MSG_CHECKING([for OpenSSL Library by Open SLL Project (optional package)])
if test ".${OSSL_ROOT}" != .; then
- if test -d $OSSL_ROOT &&
- test -r $OSSL_ROOT/libssl.a &&
- test -r $OSSL_ROOT/openssl/ssl.h; then
+ if test 1; then
OSSL_ROOT=`cd ${OSSL_ROOT} && pwd`
- MORELIBS="${MORELIBS} -L$OSSL_ROOT -lssl"
- INCS="${INCS} -I$OSSL_ROOT"
+ MORELIBS="${MORELIBS} -L${OSSL_ROOT}/crypto -lssl"
+ INCS="${INCS} -I${OSSL_ROOT}/include"
AC_DEFINE(HAVE_OPENSSL)
AC_MSG_RESULT([found in $OSSL_ROOT])
elif test -d $OSSL_ROOT &&

View File

@ -1,341 +1,366 @@
@exec mkdir -p %%DBDIR%%/ntop
bin/intop
bin/ntop
bin/ntop-config
etc/rc.d/ntop.sh
lib/libicmpPlugin-2.2.so
lib/libicmpPlugin.a
lib/libicmpPlugin.so
lib/libicmpPlugin.so.99
lib/liblastSeenPlugin-2.2.so
lib/liblastSeenPlugin.a
lib/liblastSeenPlugin.so
lib/liblastSeenPlugin.so.99
lib/libnetflowPlugin-2.2.so
lib/libnetflowPlugin.a
lib/libnetflowPlugin.so
lib/libnetflowPlugin.so.99
lib/libnfsPlugin-2.2.so
lib/libnfsPlugin.a
lib/libnfsPlugin.so
lib/libnfsPlugin.so.99
lib/libntop-2.0.so.99
lib/libntop-2.2.so
lib/libntop.a
lib/libntop.so
lib/libntopreport-2.0.so.99
lib/libntopreport-2.2.so
lib/libntopreport.a
lib/libntopreport.so
lib/libpdaPlugin-2.2.so
lib/libpdaPlugin.a
lib/libpdaPlugin.so
lib/libpdaPlugin.so.99
lib/librrdPlugin-2.2.so
lib/librrdPlugin.a
lib/librrdPlugin.so
lib/libsflowPlugin-2.2.so
lib/libsflowPlugin.a
lib/libsflowPlugin.so
lib/libsflowPlugin.so.99
lib/ntop/plugins/icmpPlugin.so
lib/ntop/plugins/lastSeenPlugin.so
lib/ntop/plugins/netflowPlugin.so
lib/ntop/plugins/nfsPlugin.so
lib/ntop/plugins/pdaPlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
share/ntop/html/About.html
share/ntop/html/Admin.html
share/ntop/html/Copyright.html
share/ntop/html/Corner.gif
share/ntop/html/DataRcvd.html
share/ntop/html/DataSent.html
share/ntop/html/IPProtocols.html
share/ntop/html/IPTraffic.html
share/ntop/html/Risk_high.gif
share/ntop/html/Risk_low.gif
share/ntop/html/Risk_medium.gif
share/ntop/html/Risk_unknown.gif
share/ntop/html/Stats.html
share/ntop/html/antenna.gif
share/ntop/html/arrow_down.gif
share/ntop/html/arrow_up.gif
share/ntop/html/back.gif
share/ntop/html/bar.gif
share/ntop/html/bg_line.gif
share/ntop/html/black.gif
share/ntop/html/bottom_corner.gif
share/ntop/html/bulb.gif
share/ntop/html/card.gif
share/ntop/html/child.gif
share/ntop/html/clear.gif
share/ntop/html/collapsed.gif
share/ntop/html/copyright.gif
share/ntop/html/corner.gif
share/ntop/html/deleteURL.gif
share/ntop/html/deleteUser.gif
share/ntop/html/dns.gif
share/ntop/html/error.gif
share/ntop/html/expanded.gif
share/ntop/html/favicon.ico
share/ntop/html/fback.gif
share/ntop/html/fforward.gif
share/ntop/html/forward.gif
share/ntop/html/gauge.jpg
share/ntop/html/gray_bg.gif
share/ntop/html/help.html
share/ntop/html/index.html
share/ntop/html/index_inner.html
share/ntop/html/index_inner_w3c.html
share/ntop/html/index_left.html
share/ntop/html/index_left_w3c.html
share/ntop/html/index_top.html
share/ntop/html/index_top_w3c.html
share/ntop/html/index_w3c.html
share/ntop/html/info.gif
share/ntop/html/j_DataRcvd.html
share/ntop/html/j_DataSent.html
share/ntop/html/j_Stats.html
share/ntop/html/j_home.html
share/ntop/html/j_index_top.html
share/ntop/html/mail.gif
share/ntop/html/major.gif
share/ntop/html/menubar.png
share/ntop/html/menubar_j.png
share/ntop/html/menuline.png
share/ntop/html/minor.gif
share/ntop/html/modifyUser.gif
share/ntop/html/multihomed.gif
share/ntop/html/ntop.gif
share/ntop/html/ntop.html
share/ntop/html/printer.gif
share/ntop/html/question.gif
share/ntop/html/router.gif
share/ntop/html/statsicons/flags/ad.gif
share/ntop/html/statsicons/flags/ae.gif
share/ntop/html/statsicons/flags/af.gif
share/ntop/html/statsicons/flags/ag.gif
share/ntop/html/statsicons/flags/ai.gif
share/ntop/html/statsicons/flags/al.gif
share/ntop/html/statsicons/flags/am.gif
share/ntop/html/statsicons/flags/an.gif
share/ntop/html/statsicons/flags/ao.gif
share/ntop/html/statsicons/flags/aq.gif
share/ntop/html/statsicons/flags/ar.gif
share/ntop/html/statsicons/flags/as.gif
share/ntop/html/statsicons/flags/at.gif
share/ntop/html/statsicons/flags/au.gif
share/ntop/html/statsicons/flags/aw.gif
share/ntop/html/statsicons/flags/az.gif
share/ntop/html/statsicons/flags/ba.gif
share/ntop/html/statsicons/flags/bb.gif
share/ntop/html/statsicons/flags/bd.gif
share/ntop/html/statsicons/flags/be.gif
share/ntop/html/statsicons/flags/bf.gif
share/ntop/html/statsicons/flags/bg.gif
share/ntop/html/statsicons/flags/bh.gif
share/ntop/html/statsicons/flags/bi.gif
share/ntop/html/statsicons/flags/bj.gif
share/ntop/html/statsicons/flags/bm.gif
share/ntop/html/statsicons/flags/bn.gif
share/ntop/html/statsicons/flags/bo.gif
share/ntop/html/statsicons/flags/br.gif
share/ntop/html/statsicons/flags/bs.gif
share/ntop/html/statsicons/flags/bt.gif
share/ntop/html/statsicons/flags/bv.gif
share/ntop/html/statsicons/flags/bw.gif
share/ntop/html/statsicons/flags/by.gif
share/ntop/html/statsicons/flags/bz.gif
share/ntop/html/statsicons/flags/ca.gif
share/ntop/html/statsicons/flags/cc.gif
share/ntop/html/statsicons/flags/cd.gif
share/ntop/html/statsicons/flags/cf.gif
share/ntop/html/statsicons/flags/cg.gif
share/ntop/html/statsicons/flags/ch.gif
share/ntop/html/statsicons/flags/ci.gif
share/ntop/html/statsicons/flags/ck.gif
share/ntop/html/statsicons/flags/cl.gif
share/ntop/html/statsicons/flags/cm.gif
share/ntop/html/statsicons/flags/cn.gif
share/ntop/html/statsicons/flags/co.gif
share/ntop/html/statsicons/flags/com.gif
share/ntop/html/statsicons/flags/cr.gif
share/ntop/html/statsicons/flags/cu.gif
share/ntop/html/statsicons/flags/cv.gif
share/ntop/html/statsicons/flags/cx.gif
share/ntop/html/statsicons/flags/cy.gif
share/ntop/html/statsicons/flags/cz.gif
share/ntop/html/statsicons/flags/de.gif
share/ntop/html/statsicons/flags/dj.gif
share/ntop/html/statsicons/flags/dk.gif
share/ntop/html/statsicons/flags/dm.gif
share/ntop/html/statsicons/flags/do.gif
share/ntop/html/statsicons/flags/dz.gif
share/ntop/html/statsicons/flags/ec.gif
share/ntop/html/statsicons/flags/edu.gif
share/ntop/html/statsicons/flags/ee.gif
share/ntop/html/statsicons/flags/eg.gif
share/ntop/html/statsicons/flags/eh.gif
share/ntop/html/statsicons/flags/es.gif
share/ntop/html/statsicons/flags/et.gif
share/ntop/html/statsicons/flags/fi.gif
share/ntop/html/statsicons/flags/fj.gif
share/ntop/html/statsicons/flags/fk.gif
share/ntop/html/statsicons/flags/fm.gif
share/ntop/html/statsicons/flags/fo.gif
share/ntop/html/statsicons/flags/fr.gif
share/ntop/html/statsicons/flags/fx.gif
share/ntop/html/statsicons/flags/ga.gif
share/ntop/html/statsicons/flags/gb.gif
share/ntop/html/statsicons/flags/gd.gif
share/ntop/html/statsicons/flags/ge.gif
share/ntop/html/statsicons/flags/gf.gif
share/ntop/html/statsicons/flags/gh.gif
share/ntop/html/statsicons/flags/gi.gif
share/ntop/html/statsicons/flags/gl.gif
share/ntop/html/statsicons/flags/gm.gif
share/ntop/html/statsicons/flags/gn.gif
share/ntop/html/statsicons/flags/gov.gif
share/ntop/html/statsicons/flags/gp.gif
share/ntop/html/statsicons/flags/gq.gif
share/ntop/html/statsicons/flags/gr.gif
share/ntop/html/statsicons/flags/gt.gif
share/ntop/html/statsicons/flags/gu.gif
share/ntop/html/statsicons/flags/gw.gif
share/ntop/html/statsicons/flags/gy.gif
share/ntop/html/statsicons/flags/hk.gif
share/ntop/html/statsicons/flags/hm.gif
share/ntop/html/statsicons/flags/hn.gif
share/ntop/html/statsicons/flags/hr.gif
share/ntop/html/statsicons/flags/ht.gif
share/ntop/html/statsicons/flags/hu.gif
share/ntop/html/statsicons/flags/id.gif
share/ntop/html/statsicons/flags/ie.gif
share/ntop/html/statsicons/flags/il.gif
share/ntop/html/statsicons/flags/in.gif
share/ntop/html/statsicons/flags/int.gif
share/ntop/html/statsicons/flags/io.gif
share/ntop/html/statsicons/flags/iq.gif
share/ntop/html/statsicons/flags/ir.gif
share/ntop/html/statsicons/flags/is.gif
share/ntop/html/statsicons/flags/it.gif
share/ntop/html/statsicons/flags/jm.gif
share/ntop/html/statsicons/flags/jo.gif
share/ntop/html/statsicons/flags/jp.gif
share/ntop/html/statsicons/flags/ke.gif
share/ntop/html/statsicons/flags/kg.gif
share/ntop/html/statsicons/flags/kh.gif
share/ntop/html/statsicons/flags/ki.gif
share/ntop/html/statsicons/flags/km.gif
share/ntop/html/statsicons/flags/kn.gif
share/ntop/html/statsicons/flags/kp.gif
share/ntop/html/statsicons/flags/kr.gif
share/ntop/html/statsicons/flags/kw.gif
share/ntop/html/statsicons/flags/ky.gif
share/ntop/html/statsicons/flags/kz.gif
share/ntop/html/statsicons/flags/la.gif
share/ntop/html/statsicons/flags/lb.gif
share/ntop/html/statsicons/flags/lc.gif
share/ntop/html/statsicons/flags/li.gif
share/ntop/html/statsicons/flags/lk.gif
share/ntop/html/statsicons/flags/localhost.gif
share/ntop/html/statsicons/flags/lr.gif
share/ntop/html/statsicons/flags/ls.gif
share/ntop/html/statsicons/flags/lt.gif
share/ntop/html/statsicons/flags/lu.gif
share/ntop/html/statsicons/flags/lv.gif
share/ntop/html/statsicons/flags/ly.gif
share/ntop/html/statsicons/flags/ma.gif
share/ntop/html/statsicons/flags/mc.gif
share/ntop/html/statsicons/flags/md.gif
share/ntop/html/statsicons/flags/mil.gif
share/ntop/html/statsicons/flags/mk.gif
share/ntop/html/statsicons/flags/mq.gif
share/ntop/html/statsicons/flags/mr.gif
share/ntop/html/statsicons/flags/mt.gif
share/ntop/html/statsicons/flags/mu.gif
share/ntop/html/statsicons/flags/mx.gif
share/ntop/html/statsicons/flags/my.gif
share/ntop/html/statsicons/flags/na.gif
share/ntop/html/statsicons/flags/ne.gif
share/ntop/html/statsicons/flags/net.gif
share/ntop/html/statsicons/flags/ng.gif
share/ntop/html/statsicons/flags/ni.gif
share/ntop/html/statsicons/flags/nl.gif
share/ntop/html/statsicons/flags/no.gif
share/ntop/html/statsicons/flags/np.gif
share/ntop/html/statsicons/flags/nu.gif
share/ntop/html/statsicons/flags/nz.gif
share/ntop/html/statsicons/flags/om.gif
share/ntop/html/statsicons/flags/org.gif
share/ntop/html/statsicons/flags/pa.gif
share/ntop/html/statsicons/flags/pe.gif
share/ntop/html/statsicons/flags/pf.gif
share/ntop/html/statsicons/flags/ph.gif
share/ntop/html/statsicons/flags/pk.gif
share/ntop/html/statsicons/flags/pl.gif
share/ntop/html/statsicons/flags/pr.gif
share/ntop/html/statsicons/flags/pt.gif
share/ntop/html/statsicons/flags/py.gif
share/ntop/html/statsicons/flags/qa.gif
share/ntop/html/statsicons/flags/ro.gif
share/ntop/html/statsicons/flags/ru.gif
share/ntop/html/statsicons/flags/rw.gif
share/ntop/html/statsicons/flags/sa.gif
share/ntop/html/statsicons/flags/sb.gif
share/ntop/html/statsicons/flags/se.gif
share/ntop/html/statsicons/flags/sg.gif
share/ntop/html/statsicons/flags/si.gif
share/ntop/html/statsicons/flags/sk.gif
share/ntop/html/statsicons/flags/su.gif
share/ntop/html/statsicons/flags/sy.gif
share/ntop/html/statsicons/flags/sz.gif
share/ntop/html/statsicons/flags/tc.gif
share/ntop/html/statsicons/flags/td.gif
share/ntop/html/statsicons/flags/tf.gif
share/ntop/html/statsicons/flags/tg.gif
share/ntop/html/statsicons/flags/th.gif
share/ntop/html/statsicons/flags/tk.gif
share/ntop/html/statsicons/flags/tm.gif
share/ntop/html/statsicons/flags/tn.gif
share/ntop/html/statsicons/flags/to.gif
share/ntop/html/statsicons/flags/tr.gif
share/ntop/html/statsicons/flags/tt.gif
share/ntop/html/statsicons/flags/tw.gif
share/ntop/html/statsicons/flags/tz.gif
share/ntop/html/statsicons/flags/ua.gif
share/ntop/html/statsicons/flags/uk.gif
share/ntop/html/statsicons/flags/us.gif
share/ntop/html/statsicons/flags/uy.gif
share/ntop/html/statsicons/flags/uz.gif
share/ntop/html/statsicons/flags/va.gif
share/ntop/html/statsicons/flags/vc.gif
share/ntop/html/statsicons/flags/ve.gif
share/ntop/html/statsicons/flags/vg.gif
share/ntop/html/statsicons/flags/vi.gif
share/ntop/html/statsicons/flags/vn.gif
share/ntop/html/statsicons/flags/wf.gif
share/ntop/html/statsicons/flags/ws.gif
share/ntop/html/statsicons/flags/ye.gif
share/ntop/html/statsicons/flags/yu.gif
share/ntop/html/statsicons/flags/za.gif
share/ntop/html/statsicons/flags/ze.gif
share/ntop/html/statsicons/flags/zm.gif
share/ntop/html/statsicons/flags/zw.gif
share/ntop/html/statsicons/os/aix.gif
share/ntop/html/statsicons/os/amiga.gif
share/ntop/html/statsicons/os/be.gif
share/ntop/html/statsicons/os/bsd.gif
share/ntop/html/statsicons/os/hp.gif
share/ntop/html/statsicons/os/irix.gif
share/ntop/html/statsicons/os/linux.gif
share/ntop/html/statsicons/os/mac.gif
share/ntop/html/statsicons/os/novell.gif
share/ntop/html/statsicons/os/os2.gif
share/ntop/html/statsicons/os/sun.gif
share/ntop/html/statsicons/os/windows.gif
share/ntop/html/style.css
share/ntop/html/top.html
share/ntop/html/url.gif
share/ntop/html/user.gif
share/ntop/html/vgauge.jpg
share/ntop/html/warning.gif
share/ntop/html/wheel.gif
share/ntop/html/white_bg.gif
share/ntop/ntop-cert.pem
@dirrm share/ntop/html/statsicons/os
@dirrm share/ntop/html/statsicons/flags
@dirrm share/ntop/html/statsicons
@dirrm share/ntop/html
@dirrm share/ntop
@dirrm lib/ntop/plugins
@dirrm lib/ntop
%%DATADIR%%/html/About.html
%%DATADIR%%/html/Admin.html
%%DATADIR%%/html/Copyright.html
%%DATADIR%%/html/DataRcvd.html
%%DATADIR%%/html/DataSent.html
%%DATADIR%%/html/IPProtocols.html
%%DATADIR%%/html/IPTraffic.html
%%DATADIR%%/html/Risk_high.gif
%%DATADIR%%/html/Risk_low.gif
%%DATADIR%%/html/Risk_medium.gif
%%DATADIR%%/html/Risk_unknown.gif
%%DATADIR%%/html/Stats.html
%%DATADIR%%/html/TotalData.html
%%DATADIR%%/html/antenna.gif
%%DATADIR%%/html/arrow_down.gif
%%DATADIR%%/html/arrow_up.gif
%%DATADIR%%/html/back.gif
%%DATADIR%%/html/bar.gif
%%DATADIR%%/html/bg_line.gif
%%DATADIR%%/html/black.gif
%%DATADIR%%/html/bottom_corner.gif
%%DATADIR%%/html/bug.png
%%DATADIR%%/html/bulb.gif
%%DATADIR%%/html/card.gif
%%DATADIR%%/html/child.gif
%%DATADIR%%/html/clear.gif
%%DATADIR%%/html/collapsed.gif
%%DATADIR%%/html/copyright.png
%%DATADIR%%/html/corner.gif
%%DATADIR%%/html/deleteURL.gif
%%DATADIR%%/html/deleteUser.gif
%%DATADIR%%/html/dns.gif
%%DATADIR%%/html/download.gif
%%DATADIR%%/html/dump.html
%%DATADIR%%/html/dumpxml.html
%%DATADIR%%/html/error.gif
%%DATADIR%%/html/expanded.gif
%%DATADIR%%/html/favicon.ico
%%DATADIR%%/html/fback.gif
%%DATADIR%%/html/fforward.gif
%%DATADIR%%/html/forward.gif
%%DATADIR%%/html/functions.js
%%DATADIR%%/html/gauge.jpg
%%DATADIR%%/html/graph.gif
%%DATADIR%%/html/gray_bg.gif
%%DATADIR%%/html/help.html
%%DATADIR%%/html/help.png
%%DATADIR%%/html/index.html
%%DATADIR%%/html/index_inner.html
%%DATADIR%%/html/index_inner_w3c.html
%%DATADIR%%/html/index_left.html
%%DATADIR%%/html/index_left_w3c.html
%%DATADIR%%/html/index_top.html
%%DATADIR%%/html/index_top_w3c.html
%%DATADIR%%/html/index_w3c.html
%%DATADIR%%/html/info.gif
%%DATADIR%%/html/lock.png
%%DATADIR%%/html/mail.gif
%%DATADIR%%/html/major.gif
%%DATADIR%%/html/marchio_unipi_pant541_144.gif
%%DATADIR%%/html/menubar.png
%%DATADIR%%/html/menubar_j.png
%%DATADIR%%/html/menuline.png
%%DATADIR%%/html/minor.gif
%%DATADIR%%/html/modifyUser.gif
%%DATADIR%%/html/multihomed.gif
%%DATADIR%%/html/nboxLogo.gif
%%DATADIR%%/html/ntop.gif
%%DATADIR%%/html/ntop.html
%%DATADIR%%/html/ntopdump.dtd
%%DATADIR%%/html/ntophelp.html
%%DATADIR%%/html/p2p.gif
%%DATADIR%%/html/pie-error.png
%%DATADIR%%/html/printer.gif
%%DATADIR%%/html/question.gif
%%DATADIR%%/html/router.gif
%%DATADIR%%/html/statsicons/flags/ad.gif
%%DATADIR%%/html/statsicons/flags/ae.gif
%%DATADIR%%/html/statsicons/flags/af.gif
%%DATADIR%%/html/statsicons/flags/ag.gif
%%DATADIR%%/html/statsicons/flags/ai.gif
%%DATADIR%%/html/statsicons/flags/al.gif
%%DATADIR%%/html/statsicons/flags/am.gif
%%DATADIR%%/html/statsicons/flags/an.gif
%%DATADIR%%/html/statsicons/flags/ao.gif
%%DATADIR%%/html/statsicons/flags/aq.gif
%%DATADIR%%/html/statsicons/flags/ar.gif
%%DATADIR%%/html/statsicons/flags/as.gif
%%DATADIR%%/html/statsicons/flags/at.gif
%%DATADIR%%/html/statsicons/flags/au.gif
%%DATADIR%%/html/statsicons/flags/aw.gif
%%DATADIR%%/html/statsicons/flags/az.gif
%%DATADIR%%/html/statsicons/flags/ba.gif
%%DATADIR%%/html/statsicons/flags/bb.gif
%%DATADIR%%/html/statsicons/flags/bd.gif
%%DATADIR%%/html/statsicons/flags/be.gif
%%DATADIR%%/html/statsicons/flags/bf.gif
%%DATADIR%%/html/statsicons/flags/bg.gif
%%DATADIR%%/html/statsicons/flags/bh.gif
%%DATADIR%%/html/statsicons/flags/bi.gif
%%DATADIR%%/html/statsicons/flags/bj.gif
%%DATADIR%%/html/statsicons/flags/bm.gif
%%DATADIR%%/html/statsicons/flags/bn.gif
%%DATADIR%%/html/statsicons/flags/bo.gif
%%DATADIR%%/html/statsicons/flags/br.gif
%%DATADIR%%/html/statsicons/flags/bs.gif
%%DATADIR%%/html/statsicons/flags/bt.gif
%%DATADIR%%/html/statsicons/flags/bv.gif
%%DATADIR%%/html/statsicons/flags/bw.gif
%%DATADIR%%/html/statsicons/flags/by.gif
%%DATADIR%%/html/statsicons/flags/bz.gif
%%DATADIR%%/html/statsicons/flags/ca.gif
%%DATADIR%%/html/statsicons/flags/cc.gif
%%DATADIR%%/html/statsicons/flags/cd.gif
%%DATADIR%%/html/statsicons/flags/cf.gif
%%DATADIR%%/html/statsicons/flags/cg.gif
%%DATADIR%%/html/statsicons/flags/ch.gif
%%DATADIR%%/html/statsicons/flags/ci.gif
%%DATADIR%%/html/statsicons/flags/ck.gif
%%DATADIR%%/html/statsicons/flags/cl.gif
%%DATADIR%%/html/statsicons/flags/cm.gif
%%DATADIR%%/html/statsicons/flags/cn.gif
%%DATADIR%%/html/statsicons/flags/co.gif
%%DATADIR%%/html/statsicons/flags/com.gif
%%DATADIR%%/html/statsicons/flags/cr.gif
%%DATADIR%%/html/statsicons/flags/cu.gif
%%DATADIR%%/html/statsicons/flags/cv.gif
%%DATADIR%%/html/statsicons/flags/cx.gif
%%DATADIR%%/html/statsicons/flags/cy.gif
%%DATADIR%%/html/statsicons/flags/cz.gif
%%DATADIR%%/html/statsicons/flags/de.gif
%%DATADIR%%/html/statsicons/flags/dj.gif
%%DATADIR%%/html/statsicons/flags/dk.gif
%%DATADIR%%/html/statsicons/flags/dm.gif
%%DATADIR%%/html/statsicons/flags/do.gif
%%DATADIR%%/html/statsicons/flags/dz.gif
%%DATADIR%%/html/statsicons/flags/ec.gif
%%DATADIR%%/html/statsicons/flags/edu.gif
%%DATADIR%%/html/statsicons/flags/ee.gif
%%DATADIR%%/html/statsicons/flags/eg.gif
%%DATADIR%%/html/statsicons/flags/eh.gif
%%DATADIR%%/html/statsicons/flags/es.gif
%%DATADIR%%/html/statsicons/flags/et.gif
%%DATADIR%%/html/statsicons/flags/eu.gif
%%DATADIR%%/html/statsicons/flags/fi.gif
%%DATADIR%%/html/statsicons/flags/fj.gif
%%DATADIR%%/html/statsicons/flags/fk.gif
%%DATADIR%%/html/statsicons/flags/fm.gif
%%DATADIR%%/html/statsicons/flags/fo.gif
%%DATADIR%%/html/statsicons/flags/fr.gif
%%DATADIR%%/html/statsicons/flags/fx.gif
%%DATADIR%%/html/statsicons/flags/ga.gif
%%DATADIR%%/html/statsicons/flags/gb.gif
%%DATADIR%%/html/statsicons/flags/gd.gif
%%DATADIR%%/html/statsicons/flags/ge.gif
%%DATADIR%%/html/statsicons/flags/gf.gif
%%DATADIR%%/html/statsicons/flags/gh.gif
%%DATADIR%%/html/statsicons/flags/gi.gif
%%DATADIR%%/html/statsicons/flags/gl.gif
%%DATADIR%%/html/statsicons/flags/gm.gif
%%DATADIR%%/html/statsicons/flags/gn.gif
%%DATADIR%%/html/statsicons/flags/gov.gif
%%DATADIR%%/html/statsicons/flags/gp.gif
%%DATADIR%%/html/statsicons/flags/gq.gif
%%DATADIR%%/html/statsicons/flags/gr.gif
%%DATADIR%%/html/statsicons/flags/gt.gif
%%DATADIR%%/html/statsicons/flags/gu.gif
%%DATADIR%%/html/statsicons/flags/gw.gif
%%DATADIR%%/html/statsicons/flags/gy.gif
%%DATADIR%%/html/statsicons/flags/hk.gif
%%DATADIR%%/html/statsicons/flags/hm.gif
%%DATADIR%%/html/statsicons/flags/hn.gif
%%DATADIR%%/html/statsicons/flags/hr.gif
%%DATADIR%%/html/statsicons/flags/ht.gif
%%DATADIR%%/html/statsicons/flags/hu.gif
%%DATADIR%%/html/statsicons/flags/id.gif
%%DATADIR%%/html/statsicons/flags/ie.gif
%%DATADIR%%/html/statsicons/flags/il.gif
%%DATADIR%%/html/statsicons/flags/in.gif
%%DATADIR%%/html/statsicons/flags/int.gif
%%DATADIR%%/html/statsicons/flags/io.gif
%%DATADIR%%/html/statsicons/flags/iq.gif
%%DATADIR%%/html/statsicons/flags/ir.gif
%%DATADIR%%/html/statsicons/flags/is.gif
%%DATADIR%%/html/statsicons/flags/it.gif
%%DATADIR%%/html/statsicons/flags/jm.gif
%%DATADIR%%/html/statsicons/flags/jo.gif
%%DATADIR%%/html/statsicons/flags/jp.gif
%%DATADIR%%/html/statsicons/flags/ke.gif
%%DATADIR%%/html/statsicons/flags/kg.gif
%%DATADIR%%/html/statsicons/flags/kh.gif
%%DATADIR%%/html/statsicons/flags/ki.gif
%%DATADIR%%/html/statsicons/flags/km.gif
%%DATADIR%%/html/statsicons/flags/kn.gif
%%DATADIR%%/html/statsicons/flags/kp.gif
%%DATADIR%%/html/statsicons/flags/kr.gif
%%DATADIR%%/html/statsicons/flags/kw.gif
%%DATADIR%%/html/statsicons/flags/ky.gif
%%DATADIR%%/html/statsicons/flags/kz.gif
%%DATADIR%%/html/statsicons/flags/la.gif
%%DATADIR%%/html/statsicons/flags/lb.gif
%%DATADIR%%/html/statsicons/flags/lc.gif
%%DATADIR%%/html/statsicons/flags/li.gif
%%DATADIR%%/html/statsicons/flags/lk.gif
%%DATADIR%%/html/statsicons/flags/localhost.gif
%%DATADIR%%/html/statsicons/flags/lr.gif
%%DATADIR%%/html/statsicons/flags/ls.gif
%%DATADIR%%/html/statsicons/flags/lt.gif
%%DATADIR%%/html/statsicons/flags/lu.gif
%%DATADIR%%/html/statsicons/flags/lv.gif
%%DATADIR%%/html/statsicons/flags/ly.gif
%%DATADIR%%/html/statsicons/flags/ma.gif
%%DATADIR%%/html/statsicons/flags/mc.gif
%%DATADIR%%/html/statsicons/flags/md.gif
%%DATADIR%%/html/statsicons/flags/mil.gif
%%DATADIR%%/html/statsicons/flags/mk.gif
%%DATADIR%%/html/statsicons/flags/ml.gif
%%DATADIR%%/html/statsicons/flags/mn.gif
%%DATADIR%%/html/statsicons/flags/mo.gif
%%DATADIR%%/html/statsicons/flags/mq.gif
%%DATADIR%%/html/statsicons/flags/mr.gif
%%DATADIR%%/html/statsicons/flags/mt.gif
%%DATADIR%%/html/statsicons/flags/mu.gif
%%DATADIR%%/html/statsicons/flags/mx.gif
%%DATADIR%%/html/statsicons/flags/my.gif
%%DATADIR%%/html/statsicons/flags/mz.gif
%%DATADIR%%/html/statsicons/flags/na.gif
%%DATADIR%%/html/statsicons/flags/ne.gif
%%DATADIR%%/html/statsicons/flags/net.gif
%%DATADIR%%/html/statsicons/flags/ng.gif
%%DATADIR%%/html/statsicons/flags/ni.gif
%%DATADIR%%/html/statsicons/flags/nl.gif
%%DATADIR%%/html/statsicons/flags/no.gif
%%DATADIR%%/html/statsicons/flags/np.gif
%%DATADIR%%/html/statsicons/flags/nu.gif
%%DATADIR%%/html/statsicons/flags/nz.gif
%%DATADIR%%/html/statsicons/flags/om.gif
%%DATADIR%%/html/statsicons/flags/org.gif
%%DATADIR%%/html/statsicons/flags/pa.gif
%%DATADIR%%/html/statsicons/flags/pe.gif
%%DATADIR%%/html/statsicons/flags/pf.gif
%%DATADIR%%/html/statsicons/flags/pg.gif
%%DATADIR%%/html/statsicons/flags/ph.gif
%%DATADIR%%/html/statsicons/flags/pk.gif
%%DATADIR%%/html/statsicons/flags/pl.gif
%%DATADIR%%/html/statsicons/flags/pr.gif
%%DATADIR%%/html/statsicons/flags/ps.gif
%%DATADIR%%/html/statsicons/flags/pt.gif
%%DATADIR%%/html/statsicons/flags/py.gif
%%DATADIR%%/html/statsicons/flags/qa.gif
%%DATADIR%%/html/statsicons/flags/ro.gif
%%DATADIR%%/html/statsicons/flags/ru.gif
%%DATADIR%%/html/statsicons/flags/rw.gif
%%DATADIR%%/html/statsicons/flags/sa.gif
%%DATADIR%%/html/statsicons/flags/sb.gif
%%DATADIR%%/html/statsicons/flags/sd.gif
%%DATADIR%%/html/statsicons/flags/se.gif
%%DATADIR%%/html/statsicons/flags/sg.gif
%%DATADIR%%/html/statsicons/flags/si.gif
%%DATADIR%%/html/statsicons/flags/sk.gif
%%DATADIR%%/html/statsicons/flags/sm.gif
%%DATADIR%%/html/statsicons/flags/sn.gif
%%DATADIR%%/html/statsicons/flags/su.gif
%%DATADIR%%/html/statsicons/flags/sv.gif
%%DATADIR%%/html/statsicons/flags/sy.gif
%%DATADIR%%/html/statsicons/flags/sz.gif
%%DATADIR%%/html/statsicons/flags/tc.gif
%%DATADIR%%/html/statsicons/flags/td.gif
%%DATADIR%%/html/statsicons/flags/tf.gif
%%DATADIR%%/html/statsicons/flags/tg.gif
%%DATADIR%%/html/statsicons/flags/th.gif
%%DATADIR%%/html/statsicons/flags/tj.gif
%%DATADIR%%/html/statsicons/flags/tk.gif
%%DATADIR%%/html/statsicons/flags/tm.gif
%%DATADIR%%/html/statsicons/flags/tn.gif
%%DATADIR%%/html/statsicons/flags/to.gif
%%DATADIR%%/html/statsicons/flags/tr.gif
%%DATADIR%%/html/statsicons/flags/tt.gif
%%DATADIR%%/html/statsicons/flags/tw.gif
%%DATADIR%%/html/statsicons/flags/tz.gif
%%DATADIR%%/html/statsicons/flags/ua.gif
%%DATADIR%%/html/statsicons/flags/uk.gif
%%DATADIR%%/html/statsicons/flags/us.gif
%%DATADIR%%/html/statsicons/flags/uy.gif
%%DATADIR%%/html/statsicons/flags/uz.gif
%%DATADIR%%/html/statsicons/flags/va.gif
%%DATADIR%%/html/statsicons/flags/vc.gif
%%DATADIR%%/html/statsicons/flags/ve.gif
%%DATADIR%%/html/statsicons/flags/vg.gif
%%DATADIR%%/html/statsicons/flags/vi.gif
%%DATADIR%%/html/statsicons/flags/vn.gif
%%DATADIR%%/html/statsicons/flags/wf.gif
%%DATADIR%%/html/statsicons/flags/ws.gif
%%DATADIR%%/html/statsicons/flags/ye.gif
%%DATADIR%%/html/statsicons/flags/yu.gif
%%DATADIR%%/html/statsicons/flags/za.gif
%%DATADIR%%/html/statsicons/flags/ze.gif
%%DATADIR%%/html/statsicons/flags/zm.gif
%%DATADIR%%/html/statsicons/flags/zw.gif
%%DATADIR%%/html/statsicons/os/aix.gif
%%DATADIR%%/html/statsicons/os/amiga.gif
%%DATADIR%%/html/statsicons/os/be.gif
%%DATADIR%%/html/statsicons/os/bsd.gif
%%DATADIR%%/html/statsicons/os/hp.gif
%%DATADIR%%/html/statsicons/os/irix.gif
%%DATADIR%%/html/statsicons/os/linux.gif
%%DATADIR%%/html/statsicons/os/mac.gif
%%DATADIR%%/html/statsicons/os/novell.gif
%%DATADIR%%/html/statsicons/os/os2.gif
%%DATADIR%%/html/statsicons/os/sun.gif
%%DATADIR%%/html/statsicons/os/windows.gif
%%DATADIR%%/html/style.css
%%DATADIR%%/html/top.html
%%DATADIR%%/html/upload.gif
%%DATADIR%%/html/url.gif
%%DATADIR%%/html/user.gif
%%DATADIR%%/html/users.gif
%%DATADIR%%/html/vgauge.jpg
%%DATADIR%%/html/warning.gif
%%DATADIR%%/html/web.gif
%%DATADIR%%/html/wheel.gif
%%DATADIR%%/html/white_bg.gif
@dirrm %%DATADIR%%/html/statsicons/flags
@dirrm %%DATADIR%%/html/statsicons/os
@dirrm %%DATADIR%%/html/statsicons
@dirrm %%DATADIR%%/html
@dirrm %%DATADIR%%

View File

@ -0,0 +1,110 @@
# ex:ts=4
# $FreeBSD$
if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
tempfile=`/usr/bin/mktemp -t checklist`
if [ "${BATCH}" ]; then
if [ "${OPTIONS}" ]; then
set ${OPTIONS}
else
set \"tcpwrap\" \"pcap\" \"zlib\"
fi
else
/usr/bin/dialog --title "configuration options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 16 \
tcpwrap "TCP Wrapper support" ON \
pcap "libpcap support" ON \
gdbm "GNU gdbm support" OFF \
zlib "zlib support" ON \
gd "GD 1 support" OFF \
rrd "rrdtool support" OFF \
locale "locale (i18n) support" OFF \
xmldump "XML Dump support" OFF \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
set `cat $tempfile`
fi
rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
echo "Nothing selected"
fi
;;
1) echo "Cancel pressed."
exit 1
;;
esac
fi
${MKDIR} ${WRKDIRPREFIX}${REALCURDIR}
exec > ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tcpwrap\")
echo "CONFIGURE_ARGS+=--with-tcpwrap"
;;
\"pcap\")
echo "CONFIGURE_ARGS+=--with-pcap-root=/usr"
;;
\"gdbm\")
echo "LIB_DEPENDS+= gdbm.3:\${PORTSDIR}/databases/gdbm"
echo "CONFIGURE_ARGS+=--with-gdbm-root=\${LOCALBASE}"
;;
\"zlib\")
echo "CONFIGURE_ARGS+=--with-zlib-root=/usr"
;;
\"gd\")
echo "LIB_DEPENDS+= gd.2:\${PORTSDIR}/graphics/gd"
echo "LIB_DEPENDS+= png.5:\${PORTSDIR}/graphics/png"
echo "CONFIGURE_ARGS+=--with-gd-root=\${LOCALBASE}"
echo "CONFIGURE_ARGS+=--with-libpng-root=\${LOCALBASE}"
;;
\"rrd\")
echo "LIB_DEPENDS+= rrd.0:\${PORTSDIR}/net/rrdtool"
echo "CONFIGURE_ARGS+=--with-rrd-root=\${LOCALBASE}"
;;
\"locale\")
echo "LIB_DEPENDS+= intl.4:\${PORTSDIR}/devel/gettext"
echo "CONFIGURE_ARGS+=--with-localedir=\${LOCALBASE}/share/locale"
echo "CONFIGURE_ARGS+=--enable-i18n"
;;
\"xmldump\")
echo "USE_GNOME= glib12"
echo "GLIB_PREFIX?= `\${LOCALBASE}/bin/glib-config --prefix`"
echo "XML2_PREFIX?= `\${LOCALBASE}/bin/xml2-config --prefix`"
echo "LIB_DEPENDS+= xml2.5:\${PORTSDIR}/textproc/libxml2"
echo "LIB_DEPENDS+= gdome.7:\${PORTSDIR}/textproc/gdome2"
echo "CONFIGURE_ARGS+=--enable-xmldump"
echo "CONFIGURE_ARGS+=--with-xml2-lib=\${XML2_PREFIX}/lib"
echo "CONFIGURE_ARGS+=--with-xml2-include=\${XML2_PREFIX}/include/libxml2/libxml"
echo "CONFIGURE_ARGS+=--with-gdome-lib=\${LOCALBASE}/lib"
echo "CONFIGURE_ARGS+=--with-gdome-include=\${LOCALBASE}/include/libgdome"
echo "CONFIGURE_ARGS+=--with-glib-lib=\${GLIB_PREFIX}/lib"
echo "CONFIGURE_ARGS+=--with-glib-include=\${GLIB_PREFIX}/include/glib12"
;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
exit 1
;;
esac
shift
done