The @stake Sleuth Kit (TASK) is the only open source forensic toolkit

for a complete analysis of Microsoft and UNIX file systems.  TASK
enables investigators to identify and recover evidence from images
acquired during incident response or from live systems.

Obtained from:	openbsd
This commit is contained in:
Kris Kennaway 2002-10-07 07:07:26 +00:00
parent 9ff7092bd9
commit 1c2935fc4b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67534
13 changed files with 154 additions and 0 deletions

View File

@ -204,6 +204,7 @@
SUBDIR += su2
SUBDIR += symlinks
SUBDIR += syslog-ng
SUBDIR += task
SUBDIR += tcplist
SUBDIR += tdir
SUBDIR += thefish

31
sysutils/task/Makefile Normal file
View File

@ -0,0 +1,31 @@
# New ports collection makefile for: task
# Date created: Sun Oct 6 23:52:10 PDT 2002
# Whom: Kris Kennaway <kris@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= task
PORTVERSION= 1.50
CATEGORIES= sysutils security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=sleuthkit
MAINTAINER= ports@FreeBSD.org
DOCS= README docs/* tct.docs/*
MAN1= blockcalc.1 dcalc.1 dcat.1 dls.1 dstat.1 ffind.1 \
find_file.1 find_inode.1 fls.1 fsstat.1 icat.1 ifind.1 \
ils.1 istat.1 mactime.1 unrm.1
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/task
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/task
.endif
${INSTALL_SCRIPT} ${WRKSRC}/bin/mactime ${PREFIX}/bin
cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} dcalc dcat dls dstat ffind \
icat fls fsstat icat ifind ils istat ${PREFIX}/bin
cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
.include <bsd.port.mk>

1
sysutils/task/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (task-1.50.tar.gz) = f21e123e9dc5b3634d0e974cff61fc93

View File

@ -0,0 +1,11 @@
--- ./src/makedefs.orig Sun Oct 6 23:53:33 2002
+++ ./src/makedefs Sun Oct 6 23:53:45 2002
@@ -8,6 +8,8 @@
;;
FreeBSD.4*) DEFS="-DFREEBSD4"
;;
+ FreeBSD.5*) DEFS="-DFREEBSD5"
+ ;;
OpenBSD.[23]*) DEFS="-DOPENBSD2"
;;
OpenBSD.3*) DEFS="-DOPENBSD3"

View File

@ -0,0 +1,11 @@
--- ./src/fstools/fs_tools.h.orig Sun Oct 6 23:54:26 2002
+++ ./src/fstools/fs_tools.h Sun Oct 6 23:56:05 2002
@@ -91,7 +91,7 @@
/*
* FreeBSD can handle filesystems > 2GB.
*/
-#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4)
+#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) || defined(FREEBSD5)
#define SUPPORTED
#define LSEEK lseek
#define OFF_T off_t

View File

@ -0,0 +1,15 @@
--- ./src/file/Makefile.orig Mon Oct 7 00:01:09 2002
+++ ./src/file/Makefile Mon Oct 7 00:01:51 2002
@@ -22,10 +22,9 @@
# 4. This notice may not be removed or altered.
SHELL = /bin/sh
-CC = gcc
-OPT = -O
+CC ?= gcc
DEBUG = -g
-CFLAGS = $(OPT) $(DEBUG) $(DEFS) $(DEFS_LCL)
+CFLAGS += $(DEBUG) $(DEFS) $(DEFS_LCL)
# If TASK is used with Autopsy on a CD that can be used for live
# analysis, uncomment the line below and set the TASK directory

View File

@ -0,0 +1,15 @@
--- ./src/fstools/Makefile.orig Mon Oct 7 00:01:58 2002
+++ ./src/fstools/Makefile Mon Oct 7 00:02:12 2002
@@ -1,9 +1,9 @@
SHELL = /bin/sh
-CC = gcc
-OPT = -O -Wall
+CC ?= gcc
+OPT = -Wall
DEBUG = -ggdb
INCL = -I../misc
-CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
+CFLAGS += $(DEFS) $(INCL) $(OPT) $(DEBUG)
LIBOBJ = fs_buf.o fs_inode.o fs_io.o fs_open.o \
fs_dent.o fs_types.o fs_data.o mylseek.o get.o \
ffs.o ffs_dent.o ext2fs.o ext2fs_dent.o \

View File

@ -0,0 +1,17 @@
--- ./src/hash/Makefile.orig Mon Oct 7 00:02:28 2002
+++ ./src/hash/Makefile Mon Oct 7 00:02:41 2002
@@ -1,12 +1,11 @@
SHELL = /bin/sh
-CC = gcc
-OPT = -O
+CC ?= gcc
DEBUG = -g
BIN = ../../bin
MAN = ../../man
PROGS = $(BIN)/md5 $(BIN)/sha1
MANPAGES= $(MAN)/man1/md5.1
-CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. $(XFLAGS)
+CFLAGS += $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. $(XFLAGS)
defs:
@sh ../makedefs

View File

@ -0,0 +1,13 @@
--- ./src/misc/Makefile.orig Mon Oct 7 00:02:50 2002
+++ ./src/misc/Makefile Mon Oct 7 00:03:00 2002
@@ -1,8 +1,7 @@
SHELL = /bin/sh
-CC = gcc
-OPT = -O
+CC ?= gcc
DEBUG = -g
-CFLAGS = $(DEFS) $(OPT) $(DEBUG)
+CFLAGS += $(DEFS) $(OPT) $(DEBUG)
LIBOBJ = mymalloc.o error.o strerror.o split_at.o
LIB = aux_lib.a
BIN_DIR =

View File

@ -0,0 +1,9 @@
--- Makefile.orig Mon Oct 7 00:05:18 2002
+++ Makefile Mon Oct 7 00:05:22 2002
@@ -1,5 +1,5 @@
SHELL = /bin/sh
-CC = gcc
+CC ?= gcc
DIRS = bin etc
all: $(DIRS) compile

View File

@ -0,0 +1 @@
Forensic toolkit based on TCT

6
sysutils/task/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
The @stake Sleuth Kit (TASK) is the only open source forensic toolkit
for a complete analysis of Microsoft and UNIX file systems. TASK
enables investigators to identify and recover evidence from images
acquired during incident response or from live systems.
WWW: http://www.atstake.com/research/tools/task/

23
sysutils/task/pkg-plist Normal file
View File

@ -0,0 +1,23 @@
bin/mactime
bin/dcalc
bin/dcat
bin/dls
bin/dstat
bin/ffind
bin/icat
bin/fls
bin/fsstat
bin/ifind
bin/ils
bin/istat
%%PORTDOCS%%share/doc/task/README
%%PORTDOCS%%share/doc/task/fat.README
%%PORTDOCS%%share/doc/task/filesystem.README
%%PORTDOCS%%share/doc/task/ntfs.README
%%PORTDOCS%%share/doc/task/timeline.README
%%PORTDOCS%%share/doc/task/README.FIRST
%%PORTDOCS%%share/doc/task/additional-resources
%%PORTDOCS%%share/doc/task/bibliography
%%PORTDOCS%%share/doc/task/help-recovering-file
%%PORTDOCS%%share/doc/task/help-when-broken-into
%%PORTDOCS%%@dirrm share/doc/task