- Add patch to support using PACKAGEROOT instead of PACKAGESITE

PR:		ports/156629
Submitted by:	"Douglas K. Rand" <rand@meridian-enviro.com>
Feature safe:	yes
This commit is contained in:
Steve Wills 2011-12-05 03:23:43 +00:00
parent fd83281f5c
commit 1c17beb762
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286896
2 changed files with 21 additions and 1 deletions

View File

@ -50,7 +50,8 @@ MAN8= filebucket.8 pi.8 puppet.8 puppetca.8 puppetd.8 \
puppet-secret_agent.8 puppet-status.8
OPTIONS= MONGREL "Run puppet server as a mongrel service" Off \
PACKAGE_ORIGIN "Use port origin as package name" On
PACKAGE_ORIGIN "Use port origin as package name" On \
PACKAGE_ROOT "Use PACKAGEROOT insted of PACKAGESITE" Off
.include <bsd.port.options.mk>
@ -63,6 +64,14 @@ EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_origin
RUN_DEPENDS+= rubygem-bzip2>=0:${PORTSDIR}/archivers/rubygem-bzip2
.endif
.if defined(WITH_PACKAGE_ROOT)
.if !defined(WITH_PACKAGE_ORIGIN)
EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_root
.else
BROKEN= "PACKAGE_ROOT option patch is incompatable with PACKAGE_ORIGIN patch."
.endif
.endif
.include <bsd.port.pre.mk>
post-patch:

View File

@ -0,0 +1,11 @@
--- lib/puppet/provider/package/freebsd.rb-orig 2011-04-21 19:36:17.000000000 -0500
+++ lib/puppet/provider/package/freebsd.rb 2011-04-21 20:09:50.000000000 -0500
@@ -20,7 +20,7 @@
if @resource[:source] =~ /\/$/
if @resource[:source] =~ /^(ftp|https?):/
- Puppet::Util::Execution::withenv :PACKAGESITE => @resource[:source] do
+ Puppet::Util::Execution::withenv :PACKAGEROOT => @resource[:source] do
pkgadd "-r", @resource[:name]
end
else