Fix editors/openoffice-4 build with clang 6.0.0 by compiling with
-std=gnu++98 since that was the default for the compilers historically used for the build. It turns out that -std=c++98 does not work because the vigra headers depend on LLONG_MAX and friends, which are not defined without the GNU extensions. Compensate for a recent poudriere change by overriding $HOME and setting it to /tmp if $HOME is not writeable. Some of the test code run during the build wants to use mkstemp() to create temporary directories under $HOME, which does not work for the "nobody" user which points $HOME at /nonexistent. No PORTREVISION bump since this is a build fix and there is no change to the package. PR: 225129 Reported by: jbeich
This commit is contained in:
parent
e13f41bfd1
commit
1c0aec0a94
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459363
@ -450,6 +450,9 @@ do-build:
|
||||
fi ; \
|
||||
cd ${WRKSRC}/instsetoo_native ; \
|
||||
. ../${FREEBSD_ENV_SET} ; \
|
||||
if [ -n "${HOME}" -a ! -w "${HOME}" ]; then \
|
||||
export HOME=/tmp ; \
|
||||
fi ; \
|
||||
build.pl --all -P$${numproc} -- -P$${dmproc}
|
||||
|
||||
do-install:
|
||||
|
@ -0,0 +1,10 @@
|
||||
--- solenv/gbuild/platform/freebsd.mk.orig 2017-11-27 13:50:25 UTC
|
||||
+++ solenv/gbuild/platform/freebsd.mk
|
||||
@@ -94,6 +94,7 @@ gb_CXXFLAGS := \
|
||||
-fno-use-cxa-atexit \
|
||||
-fvisibility-inlines-hidden \
|
||||
-fvisibility=hidden \
|
||||
+ -std=gnu++98 \
|
||||
-pipe
|
||||
ifeq ($(COM),CLANG)
|
||||
gb_CXXFLAGS += -DHAVE_STL_INCLUDE_PATH
|
11
editors/openoffice-devel/files/patch-solenv_inc_unxfbsd.mk
Normal file
11
editors/openoffice-devel/files/patch-solenv_inc_unxfbsd.mk
Normal file
@ -0,0 +1,11 @@
|
||||
--- solenv/inc/unxfbsd.mk.orig 2017-11-27 13:50:28 UTC
|
||||
+++ solenv/inc/unxfbsd.mk
|
||||
@@ -96,7 +96,7 @@ CFLAGSEXCEPTIONS=-fexceptions -fno-enforce-eh-specs
|
||||
CFLAGS_NO_EXCEPTIONS=-fno-exceptions
|
||||
|
||||
# -fpermissive should be removed as soon as possible
|
||||
-CFLAGSCXX= -pipe $(ARCH_FLAGS)
|
||||
+CFLAGSCXX= -pipe $(ARCH_FLAGS) -std=gnu++98
|
||||
.IF "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
|
||||
CFLAGSCXX += -fvisibility-inlines-hidden
|
||||
.ENDIF # "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
|
Loading…
Reference in New Issue
Block a user