net/freerdp: Fix build failure

PR:		230954
Submitted by:	kevans (maintainer)
Reported by:	rozhuk.im@gmail.com
This commit is contained in:
Steve Wills 2018-08-27 18:12:35 +00:00
parent b89426e44d
commit 1c02d9877b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478243
2 changed files with 3 additions and 16 deletions

View File

@ -13,6 +13,8 @@ COMMENT= Free implementation of Remote Desktop Protocol
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim
USES= alias cmake:outsource compiler:c++11-lib cpe gettext localbase pathfix pkgconfig ssl
USE_LDCONFIG= yes
CPE_VENDOR= freerdp_project
@ -73,8 +75,7 @@ SSE_CMAKE_BOOL= WITH_SSE2
WAYLAND_DESC= Build FreeRDP Wayland client
WAYLAND_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libwayland-client.so:graphics/wayland \
WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libwayland-cursor.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
WAYLAND_CMAKE_BOOL= WITH_WAYLAND

View File

@ -1,14 +0,0 @@
--- CMakeLists.txt.orig 2016-11-24 13:19:47 UTC
+++ CMakeLists.txt
@@ -156,6 +156,11 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "BSD")
endif()
endif()
+if(${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
+ set(BSD TRUE)
+ set(FREEBSD TRUE)
+endif()
+
# Configure MSVC Runtime
if(MSVC)
include(MSVCRuntime)