Make sure to set astrundir to /var/run in the default asterisk.conf, so that
it matches rc.d startup script. Bump PORTREVISION. Reported by: Steve Clement
This commit is contained in:
parent
3ce1c8f7cc
commit
1bddf25906
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199647
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 1.4.11
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
|
||||
http://ftp.digium.com/pub/asterisk/old-releases/
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- Makefile.orig Fri Aug 10 17:08:31 2007
|
||||
+++ Makefile Fri Aug 10 17:18:00 2007
|
||||
--- Makefile.orig Mon Sep 17 11:42:04 2007
|
||||
+++ Makefile Mon Sep 17 11:43:10 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -9,7 +18,7 @@
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -30,7 +39,7 @@
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -106,7 +115,7 @@
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -115,7 +124,7 @@
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -155,7 +164,7 @@
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -585,20 +577,23 @@
|
||||
@@ -597,20 +589,23 @@
|
||||
echo "; Default: strict"; \
|
||||
echo ";"; \
|
||||
echo ";translation_algorithm = strict"; \
|
||||
@ -183,7 +192,7 @@
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -625,10 +620,10 @@
|
||||
@@ -637,10 +632,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -196,7 +205,7 @@
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -639,19 +634,19 @@
|
||||
@@ -651,19 +646,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -1,8 +1,14 @@
|
||||
|
||||
$FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v 1.1 2007-08-10 16:30:40 sobomax Exp $
|
||||
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
--- Makefile.orig Thu Aug 9 16:10:46 2007
|
||||
+++ Makefile Mon Sep 17 11:40:51 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -12,7 +18,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -33,7 +39,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -109,7 +115,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -118,7 +124,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -158,7 +164,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -544,20 +536,23 @@
|
||||
@@ -556,20 +548,23 @@
|
||||
echo ";astctlowner = root" ; \
|
||||
echo ";astctlgroup = apache" ; \
|
||||
echo ";astctl = asterisk.ctl" ; \
|
||||
@ -186,7 +192,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -584,10 +579,10 @@
|
||||
@@ -596,10 +591,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -199,7 +205,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk/files/Attic/nocodecnego-patch-Makefile,v
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -598,19 +593,19 @@
|
||||
@@ -610,19 +605,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 1.4.11
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
|
||||
http://ftp.digium.com/pub/asterisk/old-releases/
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- Makefile.orig Fri Aug 10 17:08:31 2007
|
||||
+++ Makefile Fri Aug 10 17:18:00 2007
|
||||
--- Makefile.orig Mon Sep 17 11:42:04 2007
|
||||
+++ Makefile Mon Sep 17 11:43:10 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -9,7 +18,7 @@
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -30,7 +39,7 @@
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -106,7 +115,7 @@
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -115,7 +124,7 @@
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -155,7 +164,7 @@
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -585,20 +577,23 @@
|
||||
@@ -597,20 +589,23 @@
|
||||
echo "; Default: strict"; \
|
||||
echo ";"; \
|
||||
echo ";translation_algorithm = strict"; \
|
||||
@ -183,7 +192,7 @@
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -625,10 +620,10 @@
|
||||
@@ -637,10 +632,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -196,7 +205,7 @@
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -639,19 +634,19 @@
|
||||
@@ -651,19 +646,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -1,8 +1,14 @@
|
||||
|
||||
$FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,v 1.1 2007-08-10 16:30:40 sobomax Exp $
|
||||
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
--- Makefile.orig Thu Aug 9 16:10:46 2007
|
||||
+++ Makefile Mon Sep 17 11:40:51 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -12,7 +18,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -33,7 +39,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -109,7 +115,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -118,7 +124,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -158,7 +164,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -544,20 +536,23 @@
|
||||
@@ -556,20 +548,23 @@
|
||||
echo ";astctlowner = root" ; \
|
||||
echo ";astctlgroup = apache" ; \
|
||||
echo ";astctl = asterisk.ctl" ; \
|
||||
@ -186,7 +192,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -584,10 +579,10 @@
|
||||
@@ -596,10 +591,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -199,7 +205,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk10/files/Attic/nocodecnego-patch-Makefile,
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -598,19 +593,19 @@
|
||||
@@ -610,19 +605,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 1.4.11
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
|
||||
http://ftp.digium.com/pub/asterisk/old-releases/
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- Makefile.orig Fri Aug 10 17:08:31 2007
|
||||
+++ Makefile Fri Aug 10 17:18:00 2007
|
||||
--- Makefile.orig Mon Sep 17 11:42:04 2007
|
||||
+++ Makefile Mon Sep 17 11:43:10 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -9,7 +18,7 @@
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -30,7 +39,7 @@
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -106,7 +115,7 @@
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -115,7 +124,7 @@
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -155,7 +164,7 @@
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -585,20 +577,23 @@
|
||||
@@ -597,20 +589,23 @@
|
||||
echo "; Default: strict"; \
|
||||
echo ";"; \
|
||||
echo ";translation_algorithm = strict"; \
|
||||
@ -183,7 +192,7 @@
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -625,10 +620,10 @@
|
||||
@@ -637,10 +632,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -196,7 +205,7 @@
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -639,19 +634,19 @@
|
||||
@@ -651,19 +646,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -1,8 +1,14 @@
|
||||
|
||||
$FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1 2007-08-10 16:30:40 sobomax Exp $
|
||||
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
--- Makefile.orig Thu Aug 9 16:10:46 2007
|
||||
+++ Makefile Mon Sep 17 11:40:51 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -12,7 +18,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -33,7 +39,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -109,7 +115,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -118,7 +124,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -158,7 +164,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -544,20 +536,23 @@
|
||||
@@ -556,20 +548,23 @@
|
||||
echo ";astctlowner = root" ; \
|
||||
echo ";astctlgroup = apache" ; \
|
||||
echo ";astctl = asterisk.ctl" ; \
|
||||
@ -186,7 +192,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -584,10 +579,10 @@
|
||||
@@ -596,10 +591,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -199,7 +205,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk14/files/nocodecnego-patch-Makefile,v 1.1
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -598,19 +593,19 @@
|
||||
@@ -610,19 +605,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= asterisk
|
||||
PORTVERSION= 1.4.11
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
|
||||
http://ftp.digium.com/pub/asterisk/old-releases/
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- Makefile.orig Fri Aug 10 17:08:31 2007
|
||||
+++ Makefile Fri Aug 10 17:18:00 2007
|
||||
--- Makefile.orig Mon Sep 17 11:42:04 2007
|
||||
+++ Makefile Mon Sep 17 11:43:10 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -9,7 +18,7 @@
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -30,7 +39,7 @@
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -106,7 +115,7 @@
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -115,7 +124,7 @@
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -155,7 +164,7 @@
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -585,20 +577,23 @@
|
||||
@@ -597,20 +589,23 @@
|
||||
echo "; Default: strict"; \
|
||||
echo ";"; \
|
||||
echo ";translation_algorithm = strict"; \
|
||||
@ -183,7 +192,7 @@
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -625,10 +620,10 @@
|
||||
@@ -637,10 +632,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -196,7 +205,7 @@
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -639,19 +634,19 @@
|
||||
@@ -651,19 +646,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
@ -1,8 +1,14 @@
|
||||
|
||||
$FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,v 1.1 2007-08-10 16:30:40 sobomax Exp $
|
||||
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
--- Makefile.orig Thu Aug 9 16:10:46 2007
|
||||
+++ Makefile Mon Sep 17 11:40:51 2007
|
||||
@@ -119,7 +119,7 @@
|
||||
ASTMANDIR=$(mandir)
|
||||
ifneq ($(findstring BSD,$(OSARCH)),)
|
||||
ASTVARLIBDIR=$(prefix)/share/asterisk
|
||||
- ASTVARRUNDIR=$(localstatedir)/run/asterisk
|
||||
+ ASTVARRUNDIR=$(localstatedir)/run
|
||||
else
|
||||
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
|
||||
endif
|
||||
@@ -210,7 +210,7 @@
|
||||
|
||||
ifeq ($(OSARCH),FreeBSD)
|
||||
@ -12,7 +18,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
|
||||
AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
|
||||
endif
|
||||
@@ -375,15 +375,15 @@
|
||||
@@ -379,15 +379,15 @@
|
||||
# Should static HTTP be installed during make samples or even with its own target ala
|
||||
# webvoicemail? There are portions here that *could* be customized but might also be
|
||||
# improved a lot. I'll put it here for now.
|
||||
@ -33,7 +39,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
$(MAKE) -C sounds install
|
||||
|
||||
update:
|
||||
@@ -404,45 +404,45 @@
|
||||
@@ -408,45 +408,45 @@
|
||||
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
|
||||
|
||||
bininstall: _all
|
||||
@ -109,7 +115,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
fi
|
||||
|
||||
$(SUBDIRS_INSTALL):
|
||||
@@ -469,7 +469,7 @@
|
||||
@@ -473,7 +473,7 @@
|
||||
echo " WARNING WARNING WARNING" ;\
|
||||
fi
|
||||
|
||||
@ -118,7 +124,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
@if [ -x /usr/sbin/asterisk-post-install ]; then \
|
||||
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
|
||||
fi
|
||||
@@ -499,31 +499,23 @@
|
||||
@@ -511,31 +511,23 @@
|
||||
upgrade: bininstall
|
||||
|
||||
adsi:
|
||||
@ -158,7 +164,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
( \
|
||||
echo "[directories]" ; \
|
||||
echo "astetcdir => $(ASTETCDIR)" ; \
|
||||
@@ -544,20 +536,23 @@
|
||||
@@ -556,20 +548,23 @@
|
||||
echo ";astctlowner = root" ; \
|
||||
echo ";astctlgroup = apache" ; \
|
||||
echo ";astctl = asterisk.ctl" ; \
|
||||
@ -186,7 +192,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
done
|
||||
@echo " +--------- Asterisk Web Voicemail ----------+"
|
||||
@echo " + +"
|
||||
@@ -584,10 +579,10 @@
|
||||
@@ -596,10 +591,10 @@
|
||||
|
||||
__rpm: include/asterisk/version.h include/asterisk/buildopts.h spec
|
||||
rm -rf /tmp/asterisk ; \
|
||||
@ -199,7 +205,7 @@ $FreeBSD: /tmp/pcvs/ports/net/asterisk16/files/Attic/nocodecnego-patch-Makefile,
|
||||
cp -f contrib/init.d/rc.redhat.asterisk /tmp/asterisk/etc/rc.d/init.d/asterisk ; \
|
||||
rpmbuild --rcfile /usr/lib/rpm/rpmrc:redhat/rpmrc -bb asterisk.spec
|
||||
|
||||
@@ -598,19 +593,19 @@
|
||||
@@ -610,19 +605,19 @@
|
||||
config:
|
||||
@if [ "${OSARCH}" = "linux-gnu" ]; then \
|
||||
if [ -f /etc/redhat-release -o -f /etc/fedora-release ]; then \
|
||||
|
Loading…
Reference in New Issue
Block a user