Update to 0.3 and make this module really work. Try the newly added

examples and enjoy.
This commit is contained in:
Akinori MUSHA 2002-02-13 04:49:07 +00:00
parent 546a2d6187
commit 1bd1769c7a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54645
4 changed files with 37 additions and 3 deletions

View File

@ -6,12 +6,11 @@
#
PORTNAME= ncurses
PORTVERSION= 0.1
PORTVERSION= 0.3
CATEGORIES= devel ruby
MASTER_SITES= http://download.berlios.de/ncurses-ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
EXTRACT_SUFX= .tar.bz
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@ -21,6 +20,7 @@ USE_BZIP2= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
DOCS= README TODO
@ -35,6 +35,8 @@ post-install:
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
.endfor
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (ruby/ncurses-ruby-0.1.tar.bz) = 26af561aee73eba42c59abd31d1d7d48
MD5 (ruby/ncurses-ruby-0.3.tar.bz2) = eb4bb76463a929f72ee607c66fde8a43

View File

@ -0,0 +1,27 @@
--- extconf.rb.orig Tue Feb 12 18:37:54 2002
+++ extconf.rb Wed Feb 13 13:46:12 2002
@@ -7,2 +7,4 @@
+have_library("stdc++", "cerr")
+
have_header("unistd.h")
@@ -38,19 +40 @@
create_makefile('ncurses')
-
-makefile = IO.readlines("Makefile").collect{|line|
- line.chomp!
- line.gsub("gcc", "g++")
-}
-
-line_no = makefile.index(makefile.grep(/^install:/)[0])
-
-makefile[line_no] += " $(rubylibdir)$(target_prefix)/ncurses.rb\n" +
- "$(rubylibdir)$(target_prefix)/ncurses.rb: ncurses.rb \n" +
- "\tif test -e $(sitelibdir)$(target_prefix)/ncurses.rb; then echo This file is probably a leftover from ncurses-ruby-0.1; rm -i $(sitelibdir)$(target_prefix)/ncurses.rb; fi\n" +
- "\t@$(RUBY) -r ftools -e 'File::install(ARGV[0], ARGV[1], 0644, true)' " +
- " ncurses.rb $(rubylibdir)$(target_prefix)/ncurses.rb"
-
-
-File.open("Makefile", "w") {|f|
- f.puts(makefile)
-}

View File

@ -3,3 +3,8 @@
%%PORTDOCS%%%%RUBY_DOCDIR%%/ncurses/README
%%PORTDOCS%%%%RUBY_DOCDIR%%/ncurses/TODO
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/ncurses
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/ncurses/LICENSES_for_examples
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/ncurses/example.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/ncurses/hello_ncurses.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/ncurses/rain.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/ncurses