Mk/Uses/mpi.mk: revert c9a111c1f2 by marking MPICH libraries as private

Mark the libraries brought by MPICH dependencies as private, in order to
avoid to register them.

Patch provided by tijl@.
This commit is contained in:
Thierry Thomas 2022-12-28 17:51:02 +01:00
parent 0d238969f0
commit 1bcedd2d66
3 changed files with 14 additions and 6 deletions

View File

@ -28,12 +28,7 @@ USES+= pkgconfig
. endif
. if ${mpi_ARGS} == mpich
LIB_DEPENDS+= libmpich.so:net/mpich \
libhwloc.so:devel/hwloc2 \
libjson-c.so:devel/json-c \
libfabric.so:net/libfabric \
libze_loader.so:devel/level-zero\
libepoll-shim.so:devel/libepoll-shim
LIB_DEPENDS+= libmpich.so:net/mpich
MPI_HOME= ${LOCALBASE}
MPI_LIBS+= `pkgconf --libs mpich`
. if ${USES:Mfortran}

View File

@ -1,5 +1,6 @@
PORTNAME= mpich
PORTVERSION= 3.4.3
PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= https://www.mpich.org/static/downloads/${DISTVERSION}/

View File

@ -0,0 +1,12 @@
--- src/packaging/pkgconfig/mpich.pc.in.orig 2021-12-16 16:59:29 UTC
+++ src/packaging/pkgconfig/mpich.pc.in
@@ -9,7 +9,8 @@ Requires:
Version: @MPICH_VERSION@
URL: http://www.mcs.anl.gov/research/projects/mpich
Requires:
-Libs: @WRAPPER_C_DYNAMIC_LOADING_FLAGS@ @WRAPPER_LDFLAGS@ -L${libdir} -l@MPILIBNAME@ @LPMPILIBNAME@ @WRAPPER_LIBS@
+Libs: @WRAPPER_C_DYNAMIC_LOADING_FLAGS@ @WRAPPER_LDFLAGS@ -L${libdir} -l@MPILIBNAME@ @LPMPILIBNAME@
+Libs.private: @WRAPPER_LIBS@
Cflags: @WRAPPER_CPPFLAGS@ @WRAPPER_CFLAGS@ -I${includedir}
# pkg-config does not understand Cxxflags, etc. So we allow users to