new port: net/p5-ResourcePool-Resource-SOAP-Lite

A ResourcePool wrapper for SOAP::Lite

PR:		ports/48773
Submitted by:	Erwin Lansing <erwin@lansing.dk>
This commit is contained in:
Edwin Groothuis 2003-04-02 11:46:57 +00:00
parent 076253c921
commit 1bb1302c20
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77967
6 changed files with 65 additions and 0 deletions

View File

@ -448,6 +448,7 @@
SUBDIR += p5-PlRPC
SUBDIR += p5-RPC-XML
SUBDIR += p5-ResourcePool-Resource-Net-LDAP
SUBDIR += p5-ResourcePool-Resource-SOAP-Lite
SUBDIR += p5-SNMP
SUBDIR += p5-SNMP-MIB-Compiler
SUBDIR += p5-SNMP-Util

View File

@ -0,0 +1,29 @@
# New ports collection makefile for: p5-ResourcePool-Resourse-SOAP-Lite
# Date created: February 28th, 2003
# Whom: Erwin Lansing <erwin@lansing.dk>
#
# $FreeBSD$
#
PORTNAME= ResourcePool-Resource-SOAP-Lite
PORTVERSION= 1.0100
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://www.fatalmind.com/projects/ResourcePool/
MASTER_SITE_SUBDIR= ../by-authors/id/M/MW/MWS
PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= A ResourcePool wrapper for SOAP::Lite
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/ResourcePool.pm:${PORTSDIR}/devel/p5-ResourcePool \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= ResourcePool::Factory::SOAP::Lite.3 \
ResourcePool::Command::SOAP::Lite::Call.3
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (ResourcePool-Resource-SOAP-Lite-1.0100.tar.gz) = 2a1376b42bd8692c433d61ad3b5b0eca

View File

@ -0,0 +1,14 @@
--- Makefile.PL.orig Sat Feb 22 21:33:53 2003
+++ Makefile.PL Fri Feb 28 12:43:54 2003
@@ -21,11 +21,4 @@
$opts{AUTHOR} = 'Markus Winand <mws@fatalmind.com>';
}
-my $onlinetests = ExtUtils::MakeMaker::prompt('
-During "make test" phase we may run tests against a SOAP server located
-at the authors website.
-
-Do you want to perform these tests in addition to core tests?', 'yes') =~ /^\s*(y)/i;
-
-$opts{test} = {TESTS => join(' ', glob($onlinetests ? 't/*.t' : 't/[0-3]*.t'))};
WriteMakefile(%opts);

View File

@ -0,0 +1,5 @@
This factory can be used by ResourcePool to create
SOAP::Lite objects which use the specified proxy
for SOAP RPC invocations.
WWW: http://www.fatalmind.com/projects/ResourcePool/

View File

@ -0,0 +1,15 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool/Resource/SOAP/Lite/.packlist
lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Command/SOAP/Lite/Call.pod
lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Command/SOAP/Lite/Call.pm
lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource/SOAP/Lite.pm
lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/SOAP/Lite.pm
lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/SOAP/Lite.pod
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool/Resource/SOAP/Lite
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool/Resource/SOAP
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/ResourcePool/Resource 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Command/SOAP/Lite
@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Command/SOAP
@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource/SOAP
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Resource 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory/SOAP
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/ResourcePool/Factory 2>/dev/null || true