- Update to 0.7.2

PR:		ports/91087
Submitted by:	Phil Oleson <oz@nixil.net> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-12-30 21:26:14 +00:00
parent eada140a47
commit 1b6c4db618
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=152450
3 changed files with 27 additions and 7 deletions

View File

@ -6,11 +6,10 @@
#
PORTNAME= dvd-slideshow
PORTVERSION= 0.7.1
PORTVERSION= 0.7.2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= oz@nixil.net
COMMENT= Script that creates a slideshow-style DVD with some simple menus
@ -46,9 +45,9 @@ MAN1= dvd-slideshow.1 \
DOC_FILES= README.html changelog.html gallery2slideshow.html \
dir2slideshow.html jigl2slideshow.html \
dvd-menu.html dvd-slideshow.html
PLIST_FILES+= ${DOC_FILES:S,^,%%DOCSDIR%%/,}
PLIST_FILES+= ${DOC_FILES:S,^,%%DOCSDIR%%/,}
PLIST_FILES+= %%DOCSDIR%%/dvd-slideshowrc
PLIST_DIRS+= %%DOCSDIR%%
PLIST_DIRS+= %%DOCSDIR%%
.endif
.include <bsd.port.pre.mk>
@ -73,7 +72,7 @@ RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
pre-patch:
post-patch:
.for FILE in dvd-slideshow dvd-menu dir2slideshow gallery2slideshow jigl2slideshow
@${REINPLACE_CMD} -e 's|!/bin/bash|!${PREFIX}/bin/bash|g' ${WRKSRC}/${FILE}
.endfor

View File

@ -1,2 +1,3 @@
MD5 (dvd-slideshow_0.7.1.tar.gz) = 34c3455cc8b75f5ea3c199d447a34a9b
SIZE (dvd-slideshow_0.7.1.tar.gz) = 72132
MD5 (dvd-slideshow-0.7.2.tar.gz) = bc3b5a691b81ccc94ce0e96b805ef71b
SHA256 (dvd-slideshow-0.7.2.tar.gz) = e49d2fd3c8e663449948668915cd717855528958a07d4f79ca3cd6d0f2ea62ff
SIZE (dvd-slideshow-0.7.2.tar.gz) = 85603

View File

@ -0,0 +1,20 @@
--- dvd-slideshow.orig Fri Dec 30 04:21:02 2005
+++ dvd-slideshow Fri Dec 30 04:25:22 2005
@@ -2051,7 +2051,7 @@
audio_inside_txtfile=0
imagefiles=0 ; moviefiles=0 ; audiofiles=0
## let's parse the txtfile:
-total_lines=`wc -l ${input_txtfile} | awk '{print $1}'`
+total_lines=`wc -l "${input_txtfile}" | awk '{print $1}'`
total_lines=$(( $total_lines + 1 ))
let line=1
@@ -3813,7 +3813,7 @@
audio_1[0]='silence' # no duration needed
myecho "[dvd-slideshow] No audio files passed. Using $end_hms silence."
audio1_start=0
- audio1_end="$end_time"
+ audio1_end="5"
fi
## let's split this audio processing into two loops: one just prepares the