Initial import of Adobe AcrobatViewer(r) - a new Adobe's free PDF viewer written

entirely in Java

PR:		16606
Submitted by:	sobomax
This commit is contained in:
Maxim Sobolev 2000-05-29 08:34:03 +00:00
parent 1fdcbff778
commit 1b69e27a4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28921
8 changed files with 161 additions and 0 deletions

View File

@ -0,0 +1,74 @@
# New ports collection makefile for: Adobe Acrobar Viewer Version 1.1
# Date created: 4 Febrary 2000
# Whom: Maxim Sobolev
#
# $FreeBSD$
#
PORTNAME= acrobatviewer
PORTVERSION= 1.1
CATEGORIES= print java
MASTER_SITES= ftp://ftp.adobe.com/pub/adobe/magic/acrobatviewer/unix/1.x/
DISTNAME= viewer.bin
EXTRACT_SUFX=
MAINTAINER= sobomax@FreeBSD.org
RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/jdk
USE_ZIP= yes
USE_XLIB= yes
NO_BUILD= yes
JDK_VERSION= 1.1.8
JAVAVM= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java
.if defined(WITH_JIT)
RUN_DEPENDS+= ${LOCALBASE}/jdk${JDK_VERSION}/lib/${ARCH}/green_threads/libshujit.so:${PORTSDIR}/java/shujit
JAVAJIT= shujit
.else
JAVAJIT=
.endif
INSTSBDR= ${PREFIX}/share/java/AdobeAcrobatViewer
# For the end-users this "InstallAnywhere" whizard probably is a great step
# toward Windowze-like software installations comparing with traditional
# "make install" enviropment, but for *nix administrator it is a pain to deal
# with. Fortunately, Zero G (author of the InstallAnywhere) does not use
# propiertary format for archiving files, so it was possible for me to make
# following dirty hack. If they will provide better way to centralise
# installations in the next versions of InstallAnywhere than I'll be glad to
# remove all following crap.
BLOCKSIZE= 32768
ARCHSTART= 1
ARCHSIZE= 2749762
ARCHBLOCKS= 84
do-extract:
@${MKDIR} ${WRKSRC} && \
cd ${WRKSRC} && \
dd if=${DISTDIR}/${DISTNAME} of=archive.zip bs=${BLOCKSIZE} skip=${ARCHSTART} count=${ARCHBLOCKS} 2>/dev/null && \
${LOCALBASE}/bin/unzip -o -a -j -qq archive.zip && \
${PERL} -pi -e "s.\x0D.." ${WRKSRC}/AcrobatViewer.lax
do-configure:
@${PERL} -pi -e "s|%INSTDIR%|${INSTSBDR}|g" ${WRKSRC}/AcrobatViewer.lax && \
${PERL} -pi -e "s|%JAVAVM%|${JAVAVM}|g" ${WRKSRC}/AcrobatViewer.lax && \
${PERL} -pi -e "s|%JAVAJIT%|${JAVAJIT}|g" ${WRKSRC}/AcrobatViewer.lax
do-install:
${MKDIR} ${INSTSBDR}
${INSTALL_SCRIPT} ${WRKSRC}/launixgc.sh ${INSTSBDR}/AcrobatViewer
${INSTALL_DATA} ${WRKSRC}/License.pdf ${INSTSBDR}/
${INSTALL_DATA} ${WRKSRC}/help.pdf ${INSTSBDR}/
${INSTALL_DATA} ${WRKSRC}/lax.jar ${INSTSBDR}/
${INSTALL_DATA} ${WRKSRC}/acrobat.jar ${INSTSBDR}/
${INSTALL_DATA} ${WRKSRC}/AcrobatViewer.lax ${INSTSBDR}/
${LN} -sf ${INSTSBDR}/AcrobatViewer ${PREFIX}/bin/AcrobatViewer
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (viewer.bin) = 7cc85a3d8856de3bb1dc20eed8bfd466

View File

@ -0,0 +1,48 @@
--- AcrobatViewer.lax.orig Fri Feb 11 18:02:57 2000
+++ AcrobatViewer.lax Fri Feb 11 18:04:07 2000
@@ -4,7 +4,7 @@
# --------------------
# name given the launcher in console windows
-lax.application.name=AcrobatViewer.exe
+lax.application.name=AcrobatViewer
# LAX.CLASS.PATH
@@ -12,7 +12,7 @@
# the Java classpath necessary to run this application
# Can be separated by colons or semicolons
-lax.class.path=acrobat.jar;lax.jar
+lax.class.path=acrobat.jar:lax.jar
# LAX.COMMAND.LINE.ARGS
@@ -26,7 +26,7 @@
# -------
# path to directory holding LaunchAnywhere's native launcher
-lax.dir=C:\\Program Files\\AdobeAcrobatViewer\\
+lax.dir=%INSTDIR%/
# LAX.MAIN.CLASS
@@ -47,7 +47,8 @@
# -----------------
# the VM to use for the next launch
-lax.nl.current.vm=C:\\Java\\jdk1.1.8\\bin\\jre.exe
+lax.nl.current.vm=%JAVAVM%
+lax.nl.java.compiler=%JAVAJIT%
# LAX.NL.JAVA.LAUNCHER.MAIN.CLASS
@@ -104,7 +105,7 @@
# --------------------
# path to the installdir magic folder
-lax.root.install.dir=C:\\Program Files\\AdobeAcrobatViewer
+lax.root.install.dir=%INSTDIR%
# LAX.STDERR.REDIRECT

View File

@ -0,0 +1,11 @@
--- launixgc.sh.orig Thu Dec 2 09:30:38 1999
+++ launixgc.sh Fri Feb 11 18:00:40 2000
@@ -421,6 +421,8 @@
if [ ${jittype:-""} = "off" ]
then
jitinvoc="-Djava.compiler="
+ else
+ jitinvoc="-Djava.compiler=$jittype"
fi
fi

View File

@ -0,0 +1 @@
Viewer for the PDF files written in Java(TM)

View File

@ -0,0 +1,13 @@
Adobe(R) Acrobat(R) Viewer lets you view Adobe Portable Document Format (PDF)
files on all platforms that have a Java(TM) Virtual Machine (JVM) installed.
If you already have Adobe Acrobat Reader, you won't need Acrobat Viewer. But if
there is no available version of Acrobat Reader for your system, and you have a
Java Virtual Machine installed, then Acrobat Viewer is for you. Written
entirely in Java, Acrobat Viewer can be used as an application or a JavaBean.
Acrobat Viewer can be licensed for free to be bundled with Java-related
products, or integrated into custom Java solutions through the JavaBean
interface. Please read the End User License Agreement for details.
WWW: http://www.adobe.com/products/acrviewer/main.html

View File

@ -0,0 +1,5 @@
Please advise all your users intended to use Acrobat Viewer to create
"~/AdobeFonts" directory, which is neccessary for Acrobat Viewer to normally
save its configuration data.

View File

@ -0,0 +1,8 @@
bin/AcrobatViewer
share/java/AdobeAcrobatViewer/AcrobatViewer
share/java/AdobeAcrobatViewer/AcrobatViewer.lax
share/java/AdobeAcrobatViewer/License.pdf
share/java/AdobeAcrobatViewer/acrobat.jar
share/java/AdobeAcrobatViewer/help.pdf
share/java/AdobeAcrobatViewer/lax.jar
@dirrm share/java/AdobeAcrobatViewer