Update to 0.14
This commit is contained in:
parent
8a9cbf0da0
commit
1b5b0693d9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=132546
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= HTTP-Proxy
|
||||
PORTVERSION= 0.13
|
||||
PORTVERSION= 0.14
|
||||
CATEGORIES= www perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= HTTP
|
||||
@ -18,14 +18,16 @@ COMMENT= A pure Perl HTTP proxy
|
||||
BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
PERL_MODBUILD= yes
|
||||
|
||||
MAN3= \
|
||||
HTTP::Proxy.3 \
|
||||
HTTP::Proxy::BodyFilter.3 \
|
||||
HTTP::Proxy::BodyFilter::complete.3 \
|
||||
HTTP::Proxy::BodyFilter::htmlparser.3 \
|
||||
HTTP::Proxy::BodyFilter::htmltext.3 \
|
||||
HTTP::Proxy::BodyFilter::lines.3 \
|
||||
HTTP::Proxy::BodyFilter::save.3 \
|
||||
HTTP::Proxy::BodyFilter::simple.3 \
|
||||
HTTP::Proxy::BodyFilter::tags.3 \
|
||||
HTTP::Proxy::HeaderFilter.3 \
|
||||
@ -36,10 +38,9 @@ MAN3= \
|
||||
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
|
||||
EXTRA_PATCHES= ${PATCHDIR}/5.005-Makefile.PL ${PATCHDIR}/5.005-lib::HTTP::Proxy.pm ${PATCHDIR}/5.005-lib::HTTP::Proxy::BodyFilter::htmltext.pm
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name '*.orig' -delete
|
||||
@${PERL} -i -pe '$$_ = "" if /use warnings/' ${WRKSRC}/Build.PL
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (HTTP-Proxy-0.13.tar.gz) = 377756e947cee91d93c12927a78d88c8
|
||||
SIZE (HTTP-Proxy-0.13.tar.gz) = 38958
|
||||
MD5 (HTTP-Proxy-0.14.tar.gz) = d6fcfb1137a5edff172414c54afbe9a7
|
||||
SIZE (HTTP-Proxy-0.14.tar.gz) = 48915
|
||||
|
@ -1,24 +0,0 @@
|
||||
--- Makefile.PL~ Tue Mar 23 17:31:09 2004
|
||||
+++ Makefile.PL Tue Mar 23 17:31:28 2004
|
||||
@@ -1,5 +1,21 @@
|
||||
use ExtUtils::MakeMaker;
|
||||
|
||||
+if ($] < 5.006) {
|
||||
+ for my $f (<lib/HTTP/Proxy/*/*.pm>) {
|
||||
+ open F,$f;
|
||||
+ my @f = <F>;
|
||||
+ close F;
|
||||
+ for (@f) {
|
||||
+ if (/^use base qw\( (.*) \);/o) {
|
||||
+ $_ = "use $1;\nuse vars '\@ISA';\n\@ISA = qw( $1 );\n";
|
||||
+ }
|
||||
+ }
|
||||
+ open F, ">$f";
|
||||
+ print F @f;
|
||||
+ close F;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
WriteMakefile(
|
||||
NAME => 'HTTP::Proxy',
|
||||
VERSION_FROM => 'lib/HTTP/Proxy.pm',
|
@ -1,11 +0,0 @@
|
||||
--- lib/HTTP/Proxy.pm~ Wed Mar 3 01:15:02 2004
|
||||
+++ lib/HTTP/Proxy.pm Tue Mar 23 17:54:31 2004
|
||||
@@ -760,7 +760,7 @@
|
||||
# proxy the data
|
||||
$self->log( CONNECT, "($$) CONNECT:",
|
||||
"$read bytes received from $from" );
|
||||
- $peer->syswrite($data);
|
||||
+ $peer->syswrite($data, length($data));
|
||||
}
|
||||
}
|
||||
$self->log( CONNECT, "($$) CONNECT:", "End of CONNECT proxyfication");
|
@ -1,11 +0,0 @@
|
||||
--- lib/HTTP/Proxy/BodyFilter/htmltext.pm~ Tue Mar 23 17:51:08 2004
|
||||
+++ lib/HTTP/Proxy/BodyFilter/htmltext.pm Tue Mar 23 17:53:30 2004
|
||||
@@ -66,7 +66,7 @@
|
||||
redo SCAN if $self->{js}; # ignore protected
|
||||
{
|
||||
local $_ = $1;
|
||||
- $self->{_filter}();
|
||||
+ $self->{_filter}->();
|
||||
substr( $$dataref, $pos, length($1), $_ );
|
||||
pos($$dataref) = $pos + length($_);
|
||||
}
|
@ -1,8 +1,10 @@
|
||||
%%SITE_PERL%%/HTTP/Proxy.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/complete.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/htmlparser.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/htmltext.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/lines.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/save.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/simple.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/BodyFilter/tags.pm
|
||||
%%SITE_PERL%%/HTTP/Proxy/HeaderFilter.pm
|
||||
|
Loading…
Reference in New Issue
Block a user