Add a script to start urxvtc and urxvtd if it isn't running already.

This script is described in urxvtc(1).
Debian also uses this and the Manpage is from Debian.

PR:		ports/150976
Submitted by:	Simon Olofsson <simon (at) olofsson.de>
This commit is contained in:
Thierry Thomas 2010-09-27 20:04:08 +00:00
parent 638427c01a
commit 1b436676c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=261971
6 changed files with 67 additions and 2 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= rxvt-unicode
PORTVERSION= 9.07
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
@ -47,7 +47,7 @@ OPTIONS= \
.include <bsd.port.pre.mk>
MAN1= urxvt.1 urxvtc.1 urxvtd.1
MAN1= urxvt.1 urxvtc.1 urxvtcd.1 urxvtd.1
MAN7= urxvt.7
PORTDOCS1= Changes README.FAQ README.configure

View File

@ -0,0 +1,10 @@
--- doc/Makefile.in.orig 2010-09-26 22:34:30.000000000 +0200
+++ doc/Makefile.in 2010-09-26 22:33:53.000000000 +0200
@@ -94,6 +94,7 @@
$(INSTALL) -d $(DESTDIR)$(man7dir)
$(INSTALL_DATA) rxvt.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME).$(man1ext)
$(INSTALL_DATA) rxvtc.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME)c.$(man1ext)
+ $(INSTALL_DATA) urxvtcd.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME)cd.$(man1ext)
$(INSTALL_DATA) rxvtd.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME)d.$(man1ext)
$(INSTALL_DATA) rxvt.7.man $(DESTDIR)$(man7dir)/$(RXVTNAME).$(man7ext)
@IF_PERL@ $(INSTALL) -d $(DESTDIR)$(man3dir)

View File

@ -0,0 +1,26 @@
--- doc/urxvtcd.1.man.orig 2010-09-26 22:16:01.000000000 +0200
+++ doc/urxvtcd.1.man 2010-09-26 22:16:01.000000000 +0200
@@ -0,0 +1,23 @@
+.TH rxvt-unicode 1 "2006-04-27"
+.SH NAME
+urxvtcd \- start a urxvtc and/or urxvtd
+.SH SYNOPSIS
+.B urxvtcd
+.RI [ options ]
+.SH DESCRIPTION
+The
+.B urxvtcd
+script automatically starts
+.BR urxvtd (1)
+if it is not running, and then runs
+.BR urxvtc (1)
+with the specified arguments.
+.SH OPTIONS
+All options are passed to
+.BR urxvtc (1)
+as-is.
+.SH AUTHOR
+rxvt\-unicode was written by Marc Alexander Lehmann <rxvt\-unicode@schmorp.de>.
+.PP
+This manual page was written by Decklin Foster <decklin@red\-bean.com>,
+for the Debian project (but may be used by others).

View File

@ -0,0 +1,18 @@
--- src/Makefile.in.orig 2010-09-26 22:32:22.000000000 +0200
+++ src/Makefile.in 2010-09-26 22:33:37.000000000 +0200
@@ -42,6 +42,7 @@
RXVT_BASENAME=`echo $(RXVTNAME)|sed 's/$(EXEEXT)$$//'|sed '$(transform)'`
RXVT_BINNAME=$(DESTDIR)$(bindir)/$(RXVT_BASENAME)$(EXEEXT)
RXVTC_BINNAME=$(DESTDIR)$(bindir)/$(RXVT_BASENAME)c$(EXEEXT)
+RXVTCD_BINNAME=$(DESTDIR)$(bindir)/$(RXVT_BASENAME)cd$(EXEEXT)
RXVTD_BINNAME=$(DESTDIR)$(bindir)/$(RXVT_BASENAME)d$(EXEEXT)
#
@@ -105,6 +106,7 @@
$(INSTALL) -d $(DESTDIR)$(bindir)
$(INSTALL_PROGRAM) rxvt $(RXVT_BINNAME)
$(INSTALL_PROGRAM) rxvtc $(RXVTC_BINNAME)
+ $(INSTALL_PROGRAM) urxvtcd $(RXVTCD_BINNAME)
$(INSTALL_PROGRAM) rxvtd $(RXVTD_BINNAME)
install: install-bin install-perl

View File

@ -0,0 +1,10 @@
--- src/urxvtcd.orig 2010-09-26 22:16:01.000000000 +0200
+++ src/urxvtcd 2010-09-26 22:16:01.000000000 +0200
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+urxvtc "$@"
+if [ $? -eq 2 ]; then
+ urxvtd -q -f
+ exec urxvtc "$@"
+fi

View File

@ -1,5 +1,6 @@
bin/urxvt
bin/urxvtc
bin/urxvtcd
bin/urxvtd
%%PERL%%lib/urxvt/perl/block-graphics-to-ascii
%%PERL%%lib/urxvt/perl/digital-clock