Use the latest patch from maintainer to make this work on -CURRENT.
Submitted by: Anders Nordby <anders@fix.no> (maintainer)
This commit is contained in:
parent
a78211b02c
commit
1b3ebaa7b2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42454
@ -22,13 +22,12 @@ MAN3= dracauth.3
|
||||
MAN1= rpc.dracd.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${OSVERSION} >= 500018
|
||||
MAKE_ARGS+= -DWITH_TI_RPC
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/rpc.dracd.1m
|
||||
.if ${OSVERSION} >= 500018
|
||||
@${PERL} -pi -e "s|^RPCGENFLAGS.*|RPCGENFLAGS = -C -b|g" \
|
||||
${WRKSRC}/Makefile
|
||||
.endif
|
||||
@${ECHO} "================================================================================"
|
||||
@${ECHO} "Use make -DWITH_POSTFIX or -DWITH_EXIM with this port for databases compatible"
|
||||
@${ECHO} "with those MTAs."
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.old Mon Nov 20 16:35:16 2000
|
||||
+++ Makefile Sun Jan 14 20:06:47 2001
|
||||
--- Makefile.orig Mon Nov 20 16:35:16 2000
|
||||
+++ Makefile Sun Apr 29 20:38:47 2001
|
||||
@@ -5,9 +5,10 @@
|
||||
|
||||
# Paths
|
||||
@ -14,17 +14,23 @@
|
||||
|
||||
# OS-Dependant settings
|
||||
|
||||
@@ -33,20 +34,26 @@
|
||||
@@ -33,20 +34,32 @@
|
||||
# -DCIDR_KEY # keys in CIDR format
|
||||
# -DTERM_KD # keys and data nul-terminated
|
||||
|
||||
-DEFS = -DTI_RPC -DFCNTL_LOCK -DSYSINFO
|
||||
+.if defined(WITH_POSTFIX)
|
||||
+DEFS= -DSOCK_RPC -DFLOCK_LOCK -DGETHOST -DDASH_C -DTERM_KD
|
||||
+.elif defined(WITH_EXIM)
|
||||
+DEFS= -DSOCK_RPC -DFLOCK_LOCK -DGETHOST -DDASH_C -DTERM_KD -DREQ_HASH -DCIDR_KEY
|
||||
+.if defined(WITH_TI_RPC)
|
||||
+RPCFLAGS= -DTI_RPC
|
||||
+.else
|
||||
+DEFS= -DSOCK_RPC -DFLOCK_LOCK -DGETHOST -DDASH_C
|
||||
+RPCFLAGS= -DSOCK_RPC
|
||||
+.endif
|
||||
+
|
||||
+.if defined(WITH_POSTFIX)
|
||||
+DEFS= $(RPCFLAGS) -DFLOCK_LOCK -DGETHOST -DDASH_C -DTERM_KD
|
||||
+.elif defined(WITH_EXIM)
|
||||
+DEFS= $(RPCFLAGS) -DFLOCK_LOCK -DGETHOST -DDASH_C -DTERM_KD -DREQ_HASH -DCIDR_KEY
|
||||
+.else
|
||||
+DEFS= $(RPCFLAGS) -DFLOCK_LOCK -DGETHOST -DDASH_C
|
||||
+.endif
|
||||
|
||||
# Compiler flags
|
||||
|
@ -1,12 +1,20 @@
|
||||
--- rpc.dracd.c.old Sun Jan 14 20:53:02 2001
|
||||
+++ rpc.dracd.c Sun Jan 14 20:53:10 2001
|
||||
@@ -36,9 +36,6 @@
|
||||
--- rpc.dracd.c.orig Tue Nov 21 05:22:05 2000
|
||||
+++ rpc.dracd.c Sun Apr 29 20:41:31 2001
|
||||
@@ -8,7 +8,6 @@
|
||||
#include <errno.h>
|
||||
#include <syslog.h>
|
||||
#ifdef TI_RPC
|
||||
-#include <netdir.h>
|
||||
#include <netconfig.h>
|
||||
#endif
|
||||
#include <stdlib.h>
|
||||
@@ -35,9 +34,6 @@
|
||||
#define DB_VERSION_MAJOR 1
|
||||
#endif
|
||||
#include "drac.h"
|
||||
|
||||
-
|
||||
-#define DBFILE "/etc/mail/dracd.db"
|
||||
-#define ALFILE "/etc/mail/dracd.allow"
|
||||
-
|
||||
|
||||
struct net_def {
|
||||
struct net_def *nd_next;
|
||||
struct in_addr nd_mask;
|
||||
|
Loading…
Reference in New Issue
Block a user