misc/libsolv: Update 0.7.4 -> 0.7.15

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2020-09-25 23:47:40 +00:00
parent 26d24c88a5
commit 1b1e343ed2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550093
5 changed files with 55 additions and 30 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libsolv
DISTVERSION= 0.7.4
PORTREVISION= 1
DISTVERSION= 0.7.15
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
@ -11,14 +10,33 @@ COMMENT= Package dependency solver using a satisfiability algorithm
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.BSD
USES= cmake
USES= cmake localbase:ldflags
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= rpm-software-management
GH_ACCOUNT= openSUSE
OPTIONS_DEFINE= RPMDB RPMMD RPMPKG
OPTIONS_DEFAULT= RPMDB RPMMD RPMPKG
OPTIONS_GROUP= COMPRESSION
OPTIONS_GROUP_COMPRESSION= BZIP2 LZMA ZCHUNK ZSTD
OPTIONS_SUB= yes
# general options
RPMDB_DESC= Build with rpm database support
RPMDB_CMAKE_BOOL= ENABLE_RPMDB
RPMDB_LIB_DEPENDS= librpmio.so:archivers/rpm4
RPMMD_DESC= Build with rpmmd repository support
RPMMD_CMAKE_BOOL= ENABLE_RPMMD
RPMMD_LIB_DEPENDS= libexpat.so:textproc/expat2
RPMPKG_DESC= Build with rpm package support
RPMPKG_CMAKE_BOOL= ENABLE_RPMPKG
# comnpression options
COMPRESSION_DESC= Enable compression:
BZIP2_DESC= BZip2 support

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1600576582
SHA256 (rpm-software-management-libsolv-0.7.4_GH0.tar.gz) = 725b598075c5c44a90cbda5594fd29417144ff8acb9762996162e7b68f94c8c4
SIZE (rpm-software-management-libsolv-0.7.4_GH0.tar.gz) = 662383
TIMESTAMP = 1601076252
SHA256 (openSUSE-libsolv-0.7.15_GH0.tar.gz) = 2a1d6ae1719288ecb368b33893bc2f4d047dbf4426cafa1dc6af4288388e6269
SIZE (openSUSE-libsolv-0.7.15_GH0.tar.gz) = 717327

View File

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2020-09-20 04:37:26 UTC
+++ CMakeLists.txt
@@ -44,7 +44,7 @@ IF (DEFINED LIB)
SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${LIB}")
ELSE (DEFINED LIB)
IF (CMAKE_SIZEOF_VOID_P MATCHES "8")
- SET (LIB_SUFFIX "64")
+ SET (LIB_SUFFIX "")
ENDIF (CMAKE_SIZEOF_VOID_P MATCHES "8")
SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
ENDIF (DEFINED LIB)

View File

@ -12,4 +12,4 @@ decision tree to provide introspection, and also allows to provide the user with
suggestions on how to deal with unsolvable problems. It also takes advantage of
the repository storage to minimize memory usage.
WWW: https://github.com/rpm-software-management/libsolv
WWW: https://github.com/openSUSE/libsolv

View File

@ -1,8 +1,14 @@
%%RPMMD%%bin/deltainfoxml2solv
bin/dumpsolv
bin/installcheck
bin/mergesolv
bin/repo2solv
%%RPMMD%%bin/repomdxml2solv
%%RPMMD%%bin/rpmmd2solv
%%RPMDB%%bin/rpmdb2solv
%%RPMDB%%bin/rpms2solv
bin/testsolv
%%RPMMD%%bin/updateinfoxml2solv
include/solv/bitmap.h
include/solv/chksum.h
include/solv/dataiterator.h
@ -12,6 +18,7 @@ include/solv/hash.h
include/solv/knownid.h
include/solv/policy.h
include/solv/pool.h
%%RPMDB%%include/solv/pool_fileconflicts.h
include/solv/poolarch.h
include/solv/poolid.h
include/solv/pooltypes.h
@ -19,7 +26,12 @@ include/solv/poolvendor.h
include/solv/problems.h
include/solv/queue.h
include/solv/repo.h
%%RPMMD%%include/solv/repo_deltainfoxml.h
%%RPMMD%%include/solv/repo_repomdxml.h
%%RPMDB%%include/solv/repo_rpmdb.h
%%RPMMD%%include/solv/repo_rpmmd.h
include/solv/repo_solv.h
%%RPMMD%%include/solv/repo_updateinfoxml.h
include/solv/repo_write.h
include/solv/repodata.h
include/solv/rules.h
@ -40,15 +52,21 @@ lib/libsolvext.so
lib/libsolvext.so.1
libdata/pkgconfig/libsolv.pc
libdata/pkgconfig/libsolvext.pc
%%RPMMD%%man/man1/deltainfoxml2solv.1.gz
man/man1/dumpsolv.1.gz
man/man1/installcheck.1.gz
man/man1/mergesolv.1.gz
man/man1/repo2solv.1.gz
%%RPMMD%%man/man1/repomdxml2solv.1.gz
%%RPMDB%%man/man1/rpmdb2solv.1.gz
%%RPMMD%%man/man1/rpmmd2solv.1.gz
%%RPMDB%%man/man1/rpms2solv.1.gz
man/man1/solv.1.gz
man/man1/testsolv.1.gz
%%RPMMD%%man/man1/updateinfoxml2solv.1.gz
man/man3/libsolv-bindings.3.gz
man/man3/libsolv-constantids.3.gz
man/man3/libsolv-history.3.gz
man/man3/libsolv-pool.3.gz
man/man3/libsolv.3.gz
share/cmake/Modules/FindLibSolv.cmake
share/man/man1/dumpsolv.1.gz
share/man/man1/installcheck.1.gz
share/man/man1/mergesolv.1.gz
share/man/man1/repo2solv.1.gz
share/man/man1/solv.1.gz
share/man/man1/testsolv.1.gz
share/man/man3/libsolv-bindings.3.gz
share/man/man3/libsolv-constantids.3.gz
share/man/man3/libsolv-history.3.gz
share/man/man3/libsolv-pool.3.gz
share/man/man3/libsolv.3.gz