Update to 1.10.2.

This commit is contained in:
Maxim Sobolev 2002-10-18 16:36:22 +00:00
parent 8e07872e6a
commit 1b11d98cb8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68268
24 changed files with 225 additions and 155 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= asc
PORTVERSION= 1.9.5.4
PORTVERSION= 1.10.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= asc-hq
@ -14,13 +14,12 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
BROKEN= Does not configure
LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
SDLmm.8:${PORTSDIR}/devel/sdlmm \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
paragui.3:${PORTSDIR}/x11-toolkits/paragui
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif

View File

@ -1 +1 @@
MD5 (asc-source-1.9.5.4.tar.gz) = ca60d279765f1c2d64b2141a222642cc
MD5 (asc-source-1.10.2.tar.gz) = 61aca2f50c851c440c7d76b356d3d28b

View File

@ -1,9 +1,9 @@
$FreeBSD$
--- configure.orig Tue Dec 11 12:50:51 2001
+++ configure Tue Dec 11 12:52:36 2001
@@ -1709,7 +1709,7 @@
--- configure.orig Tue Oct 1 15:16:15 2002
+++ configure Tue Oct 1 15:16:21 2002
@@ -2992,7 +2992,7 @@
@ -12,24 +12,3 @@ $FreeBSD$
game_datadir=`(
test "x$prefix" = xNONE && prefix="$ac_default_prefix"
test "x$exec_prefix" = xNONE && exec_prefix="${prefix}"
@@ -1729,16 +1729,16 @@
fi
-ac_safe=`echo "SDL/SDL.h" | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for SDL/SDL.h""... $ac_c" 1>&6
-echo "configure:1735: checking for SDL/SDL.h" >&5
+ac_safe=`echo "SDL.h" | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for SDL.h""... $ac_c" 1>&6
+echo "configure:1735: checking for SDL.h" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
#line 1740 "configure"
#include "confdefs.h"
-#include <SDL/SDL.h>
+#include <SDL.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
{ (eval echo configure:1745: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }

View File

@ -1,11 +1,19 @@
$FreeBSD$
--- data/Makefile.in 2001/05/22 19:52:06 1.1
+++ data/Makefile.in 2001/05/22 19:52:26
@@ -76,7 +76,7 @@
--- data/Makefile.in.orig Sat Apr 27 23:06:17 2002
+++ data/Makefile.in Fri Oct 18 17:03:10 2002
@@ -89,14 +89,14 @@
VERSION = @VERSION@
asc_version = @asc_version@
pkgdata_DATA = main.con
-SUBDIRS = dialog @MUSICDIR@
+SUBDIRS = dialog
MAINTAINERCLEANFILES = Makefile.in
# main.con buildings.con mk1.con trrobj.con trrobj2.con
pkgdata_DATA = main.con buildings.con mk1.con trrobj.con trrobj2.con
-pkgdatadir = $(datadir)/games/@PACKAGE@
+pkgdatadir = $(datadir)/@PACKAGE@

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- data/dialog/Makefile.in 2002/10/01 12:21:59 1.1
+++ data/dialog/Makefile.in 2002/10/01 12:23:35
@@ -89,7 +89,7 @@
VERSION = @VERSION@
asc_version = @asc_version@
-pkgdatadir = $(datadir)/games/@PACKAGE@
+pkgdatadir = $(datadir)/@PACKAGE@
pkgdata_DATA = asc_dlg.zip
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- data/moredata/Makefile.in 2001/10/22 10:49:12 1.1
+++ data/moredata/Makefile.in 2001/10/22 10:49:23
@@ -76,7 +76,7 @@
pkgdata_DATA = buildings.con mk1.con trrobj.con
-pkgdatadir = $(datadir)/games/@PACKAGE@
+pkgdatadir = $(datadir)/@PACKAGE@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h
CONFIG_CLEAN_FILES =

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- data/music/Makefile.in 2002/10/01 12:21:59 1.1
+++ data/music/Makefile.in 2002/10/01 12:22:47
@@ -89,7 +89,7 @@
VERSION = @VERSION@
asc_version = @asc_version@
-pkgdatadir = $(datadir)/games/@PACKAGE@/music
+pkgdatadir = $(datadir)/@PACKAGE@/music
pkgdata_DATA = frontiers.mp3 time_to_strike.mp3
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs

View File

@ -0,0 +1,23 @@
$FreeBSD$
--- source/ai/misc.cpp 2002/10/18 11:37:58 1.1
+++ source/ai/misc.cpp 2002/10/18 11:41:35
@@ -86,7 +86,7 @@
float value = veh->aiparam[getPlayerNum()]->getValue();
if ( veh->typ->movement[j] )
- value *= log( veh->typ->movement[j] );
+ value *= log( (double)veh->typ->movement[j] );
float threat = sec.avgFieldThreat.threat[ veh->aiparam[getPlayerNum()]->valueType ];
if ( minAvgFieldThreat > 0 ) {
@@ -834,7 +834,7 @@
danger = enemyThreat.threat[ typ->aiparam[getPlayerNum()]->valueType] / typ->aiparam[getPlayerNum()]->getValue();
}
- rating /= 1 + log ( danger );
+ rating /= 1 + log ( (double)danger );
int cost = 0;
for ( int j = 0; j < resourceTypeNum; j++ )

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/ai/tactics.cpp 2002/10/18 11:52:01 1.1
+++ source/ai/tactics.cpp 2002/10/18 11:52:50
@@ -330,7 +330,7 @@
int _dist = beeline ( x, y, veh->xpos, veh->ypos);
// make fields far away a bit unattractive; we don't want to move the whole distance back again next turn
- int t = int( ait.threat[ veh->aiparam[ getPlayerNum()]->valueType ] * log ( _dist )/log(10) );
+ int t = int( ait.threat[ veh->aiparam[ getPlayerNum()]->valueType ] * log ( (double)_dist )/log((double)10) );
if ( t < threat || ( t == threat && _dist < dist )) {
threat = t;

View File

@ -0,0 +1,23 @@
$FreeBSD$
--- source/ai/valuation.cpp 2002/10/18 11:44:39 1.1
+++ source/ai/valuation.cpp 2002/10/18 11:46:45
@@ -78,7 +78,7 @@
for ( int e = (fzt->weapons.weapon[i].mindistance + maxmalq - 1)/ maxmalq; e <= fzt->weapons.weapon[i].maxdistance / maxmalq; e++ ) { // the distance between two fields is maxmalq
d++;
int n = int( weapDist.getWeapStrength( &fzt->weapons.weapon[i], e*maxmalq ) * fzt->weapons.weapon[i].maxstrength * af.strength_damage(getdamage()) * ( 1 + af.strength_experience(getexpirience())) );
- m += int( n / log10(10*d));
+ m += int( n / log10((double)10*d));
}
if (getammunition(i) == 0)
m /= 2;
@@ -694,7 +694,7 @@
int dist = beeline ( veh->xpos, veh->ypos, sec.centerx, sec.centery ) + 3 * veh->maxMovement();
if ( dist )
- f /= log(dist);
+ f /= log((double)dist);
if ( f > d ) {
int ac = 0;

View File

@ -1,18 +1,18 @@
$FreeBSD$
--- source/basestrm.cpp 2001/02/17 15:08:39 1.1
+++ source/basestrm.cpp 2001/02/17 15:08:54
@@ -895,7 +892,7 @@
while (actpos2 < size) {
if (datasize == 0)
--- source/basestrm.cpp.orig Tue Oct 1 16:11:44 2002
+++ source/basestrm.cpp Fri Oct 18 15:04:21 2002
@@ -1008,7 +1011,7 @@
while (actpos2 < size) {
if (datasize == 0)
if ( excpt ) {
- throw treadafterend ( getDeviceName() );
+ goto except1;
}
else
return actpos2;
@@ -915,6 +912,9 @@
@@ -1028,6 +1031,9 @@
}
return actpos2;
@ -22,7 +22,7 @@ $FreeBSD$
}
@@ -945,10 +945,14 @@
@@ -1058,10 +1064,14 @@
}
else
if (actmempos > memsize)

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/basestrm.h 2002/10/18 12:10:03 1.1
+++ source/basestrm.h 2002/10/18 12:10:30
@@ -516,7 +516,7 @@
-class tanycompression : public t_compressor_stream_interface, protected tlzwstreamcompression {
+class tanycompression : public t_compressor_stream_interface, public tlzwstreamcompression {
typedef deque<char> CDQ;
queue<char, CDQ> _queue;

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/building.cpp 2002/10/18 13:03:04 1.1
+++ source/building.cpp 2002/10/18 13:03:22
@@ -1022,7 +1022,7 @@
int getstepwidth ( int max )
{
- double ep = log10 ( max );
+ double ep = log10 ( (double)max );
if ( ep > 2.0 )
ep -= 2.0;
else

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/gamedlg.cpp 2002/10/18 12:57:12 1.2
+++ source/gamedlg.cpp 2002/10/18 12:57:38
@@ -3794,7 +3794,7 @@
int step = ( target->service[displayed[mp]].maxAmount - target->service[displayed[mp]].minAmount ) / 100;
if ( step == 0 )
step = 1;
- step = int( pow ( 10, int ( log10 ( (double)step ))));
+ step = int( pow ( (double)10, int ( log10 ( (double)step ))));
oldpos[mp] = newpos[mp];

View File

@ -1,20 +1,20 @@
$FreeBSD$
--- source/gameoptions.cpp.orig Tue May 22 22:28:53 2001
+++ source/gameoptions.cpp Tue May 22 22:30:29 2001
@@ -103,7 +103,7 @@
--- source/gameoptions.cpp.orig Tue Oct 1 15:26:40 2002
+++ source/gameoptions.cpp Tue Oct 1 15:29:07 2002
@@ -112,7 +112,7 @@
defaultSuperVisorPassword.setName ( "" );
- #if USE_HOME_DIRECTORY == 0
+ #if _UNIX_ == 0
-#if USE_HOME_DIRECTORY == 0
+#if _UNIX_ == 0
searchPath[0].setName ( ".\\" );
for ( int i = 1; i < getSearchPathNum(); i++ )
searchPath[i].setName ( NULL );
@@ -111,7 +111,7 @@
for ( int i = 0; i < getSearchPathNum(); i++ )
searchPath[i].setName ( NULL );
@@ -120,7 +120,7 @@
for ( int i = 0; i < getSearchPathNum(); i++ )
searchPath[i].setName ( NULL );
searchPath[0].setName ( "~/.asc/" );
- searchPath[1].setName ( "/var/local/games/asc/" );
+ searchPath[1].setName ( PREFIX "/share/asc/" );

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/mapalgorithms.cpp 2002/10/18 12:38:06 1.1
+++ source/mapalgorithms.cpp 2002/10/18 12:38:23
@@ -117,7 +117,7 @@
int dx = xp2-xp1;
int dy = yp2-yp1;
- double at = atan2 ( dy, dx );
+ double at = atan2 ( (double)dy, (double)dx );
// printf("%d / %d / %f \n", dx, dy, at);
at -= offset;
while ( at < 0 )

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- source/sdl/events.cpp 2001/02/16 21:38:57 1.1
+++ source/sdl/events.cpp 2001/02/16 21:39:12
@@ -150,7 +150,7 @@
#ifdef _WIN32_
#include "SDL_thread.h"
#else
-#include "SDL/SDL_thread.h"
+#include "SDL_thread.h"
#endif

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- source/sdl/testSound.cpp 2001/02/16 21:38:57 1.1
+++ source/sdl/testSound.cpp 2001/02/16 21:39:20
@@ -14,7 +14,7 @@
* *
***************************************************************************/
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL.h>
#include <unistd.h>
#include <sound.h>

View File

@ -1,34 +1,18 @@
$FreeBSD$
--- source/tools/linux/Makefile.in.orig Fri Oct 12 03:37:29 2001
+++ source/tools/linux/Makefile.in Mon Oct 22 11:57:55 2001
@@ -91,15 +91,15 @@
asc_bin2text_SOURCES = bin2text.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp strtmesg.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp itemrepository.cpp
asc_weaponguide_SOURCES = weaponguide.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp strtmesg.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp itemrepository.cpp
--- source/tools/linux/Makefile.in.orig Sat Apr 27 23:06:16 2002
+++ source/tools/linux/Makefile.in Tue Oct 1 15:36:31 2002
@@ -111,7 +111,7 @@
asc_weaponguide_SOURCES = weaponguide.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp strtmesg.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp stringtokenizer.cpp itemrepository.cpp
asc_raw2pcx_SOURCES = raw2pcx.cpp basestrm.cpp misc.cpp ascstring.cpp loadpcxc.cpp palette.cpp sgstream.cpp newfont.cpp basegfx.cpp graphicset.cpp gameoptions.cpp CLoadable.cpp Named.cpp Property.cpp PropertyGroup.cpp stack.cpp buildingtype.cpp typen.cpp vehicletype.cpp password.cpp strtmesg.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp stringtokenizer.cpp
-asc_mount_LDADD = -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_demount_LDADD = -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-#asc_gfx2pcx_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_makegfx_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_mntgraph_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_viewid_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_tank2pcx_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_bin2text_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
-asc_weaponguide_LDADD = ../../sdl/libsdl.a -lSDL -lSDLmm -lpthread @LDADDLIBBZ2@
+asc_mount_LDADD = -lSDLmm @LDADDLIBBZ2@
+asc_demount_LDADD = -lSDLmm @LDADDLIBBZ2@
+#asc_gfx2pcx_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_makegfx_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_mntgraph_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_viewid_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_tank2pcx_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_bin2text_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
+asc_weaponguide_LDADD = ../../sdl/libsdl.a -lSDLmm @LDADDLIBBZ2@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =
@@ -107,7 +107,7 @@
-asc_mount_LDADD = @SDL_LIBS@ @SDLMM_LIBS@ -lpthread @LDADDLIBBZ2@ $(top_builddir)/source/tools/lib/libasc_cmd.la
+asc_mount_LDADD = @SDL_LIBS@ @SDLMM_LIBS@ @LDADDLIBBZ2@ $(top_builddir)/source/tools/lib/libasc_cmd.la
asc_demount_LDADD = @SDL_LIBS@ @SDLMM_LIBS@ @LDADDLIBBZ2@ $(top_builddir)/source/tools/lib/libasc_cmd.la
asc_makegfx_LDADD = $(top_builddir)/source/sdl/libsdl.la @LDADDLIBBZ2@ $(top_builddir)/source/tools/lib/libasc_cmd.la
asc_viewid_LDADD = $(top_builddir)/source/sdl/libsdl.la @LDADDLIBBZ2@ $(top_builddir)/source/tools/lib/libasc_cmd.la
@@ -125,7 +125,7 @@
DEFS = @DEFS@ -I. -I$(srcdir) -I../../..

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- source/typen.h 2002/10/18 11:15:33 1.1
+++ source/typen.h 2002/10/18 11:16:11
@@ -247,8 +247,6 @@
#include <limits.h>
#endif
-#include <values.h>
-
#include "pointers.h"
#include "tpascal.inc"
#include "misc.h"

View File

@ -1,20 +1,14 @@
$FreeBSD$
--- source/unix/Makefile.in.orig Tue Aug 28 16:26:40 2001
+++ source/unix/Makefile.in Mon Sep 3 17:31:54 2001
@@ -78,12 +78,12 @@
asc_SOURCES = unitctrl.cpp soundList.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp sg.cpp pd.cpp palette.cpp newfont.cpp network.cpp missions.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp gui.cpp gamedlg.cpp dlg_box.cpp dialog.cpp controls.cpp building.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp astar2.cpp vehicletype.cpp buildingtype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp replay.cpp research.cpp mapdisplay.cpp resourcenet.cpp dashboard.cpp ascstring.cpp graphicset.cpp vehicle.cpp buildings.cpp networkdata.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp itemrepository.cpp
-asc_LDADD = ../ai/libai.a ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL -lpthread -lSDL_image -lSDL_mixer -lSDLmm @LDADDLIBBZ2@
+asc_LDADD = ../ai/libai.a ../sdl/libsdl.a ../libs/triangul/libtriangul.a -lSDL_image -lSDL_mixer -lSDLmm @LDADDLIBBZ2@
--- source/unix/Makefile.in.orig Sat Apr 27 23:06:16 2002
+++ source/unix/Makefile.in Tue Oct 1 15:39:29 2002
@@ -98,7 +98,7 @@
SUBDIRS = mapeditor
-CXXFLAGS = @CXXFLAGS@ -I./ -Dsgmain -DFREEMAPZOOM -DNEWKEYB
+CXXFLAGS = @CXXFLAGS@ -I./ -Dsgmain -DFREEMAPZOOM -DNEWKEYB -DPREFIX=\"$(prefix)\"
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h
CONFIG_CLEAN_FILES =
-CXXFLAGS = @CXXFLAGS@ @SDL_CFLAGS@ @SDLMM_CXXFLAGS@ -Dsgmain -DFREEMAPZOOM -DNEWKEYB @PARAGUI_CFLAGS@
+CXXFLAGS = @CXXFLAGS@ @SDL_CFLAGS@ @SDLMM_CXXFLAGS@ -Dsgmain -DFREEMAPZOOM -DNEWKEYB @PARAGUI_CFLAGS@ -DPREFIX=\"$(prefix)\"
bin_PROGRAMS = asc

View File

@ -1,9 +1,9 @@
$FreeBSD$
--- source/unix/global_os.h.orig Mon Sep 3 17:26:45 2001
+++ source/unix/global_os.h Mon Sep 3 17:32:50 2001
@@ -53,8 +53,8 @@
--- source/unix/global_os.h 2002/10/01 12:34:15 1.1
+++ source/unix/global_os.h 2002/10/01 12:34:29
@@ -60,8 +60,8 @@
#define global_os_h_included
#ifndef minimalIO
@ -14,7 +14,7 @@ $FreeBSD$
#include sdlheader
#endif
@@ -77,7 +77,7 @@
@@ -84,7 +84,7 @@
#endif
#define CASE_SENSITIVE_FILE_NAMES 1

View File

@ -1,24 +1,14 @@
$FreeBSD$
--- source/unix/mapeditor/Makefile.in.orig Tue Aug 28 16:26:40 2001
+++ source/unix/mapeditor/Makefile.in Mon Sep 3 17:34:12 2001
@@ -76,15 +76,15 @@
SGML2MAN = @SGML2MAN@
VERSION = @VERSION@
--- source/unix/mapeditor/Makefile.in.orig Sat Apr 27 23:06:16 2002
+++ source/unix/mapeditor/Makefile.in Tue Oct 1 15:41:13 2002
@@ -98,7 +98,7 @@
INCLUDES = -I$(top_builddir) -I$(top_src_dir) -I$(top_builddir)/source -I$(top_src_dir)/source
-CXXFLAGS = @CXXFLAGS@ @SDL_CFLAGS@ @SDLMM_CXXFLAGS@ -Dkarteneditor -DFREEMAPZOOM -DNEWKEYB @PARAGUI_CFLAGS@
+CXXFLAGS = @CXXFLAGS@ @SDL_CFLAGS@ @SDLMM_CXXFLAGS@ -Dkarteneditor -DFREEMAPZOOM -DNEWKEYB @PARAGUI_CFLAGS@ -DPREFIX=\"$(prefix)\"
-CXXFLAGS = @CXXFLAGS@ -Dkarteneditor -I./ -DFREEMAPZOOM -DNEWKEYB
+CXXFLAGS = @CXXFLAGS@ -Dkarteneditor -I./ -DFREEMAPZOOM -DNEWKEYB -DPREFIX=\"$(prefix)\"
bin_PROGRAMS = asc_mapedit asc_map2pcx
asc_mapedit_SOURCES = edevents.cpp edgen.cpp edglobal.cpp edmain.cpp edselfnt.cpp edmisc.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp vehicle.cpp buildings.cpp networkdata.cpp resourcenet.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp itemrepository.cpp
-asc_mapedit_LDADD = ../../sdl/libsdl.a ../../libs/triangul/libtriangul.a -lSDL -lpthread -lSDL_image -lSDLmm @LDADDLIBBZ2@
+asc_mapedit_LDADD = ../../sdl/libsdl.a ../../libs/triangul/libtriangul.a -lSDL_image -lSDLmm @LDADDLIBBZ2@
asc_map2pcx_SOURCES = map2pcx.cpp weather.cpp typen.cpp strtmesg.cpp stack.cpp spfst.cpp sgstream.cpp pd.cpp palette.cpp newfont.cpp misc.cpp loadpcxc.cpp loaders.cpp loadbi3.cpp dlg_box.cpp dialog.cpp basestrm.cpp basegfx.cpp attack.cpp CLoadable.cpp Property.cpp PropertyGroup.cpp gameoptions.cpp Named.cpp buildingtype.cpp vehicletype.cpp containerbase.cpp mapalgorithms.cpp viewcalculation.cpp gamemap.cpp password.cpp password_dialog.cpp research.cpp mapdisplay.cpp ascstring.cpp graphicset.cpp vehicle.cpp buildings.cpp networkdata.cpp resourcenet.cpp textfileparser.cpp terraintype.cpp objecttype.cpp textfiletags.cpp itemrepository.cpp
-asc_map2pcx_LDADD = ../../sdl/libsdl.a ../../libs/triangul/libtriangul.a -lSDL -lpthread -lSDL_image -lSDLmm @LDADDLIBBZ2@
+asc_map2pcx_LDADD = ../../sdl/libsdl.a ../../libs/triangul/libtriangul.a -lSDL_image -lSDLmm @LDADDLIBBZ2@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../../config.h
CONFIG_CLEAN_FILES =

View File

@ -4,11 +4,11 @@ bin/asc_demount
bin/asc_makegfx
bin/asc_map2pcx
bin/asc_mapedit
bin/asc_mntgraph
bin/asc_mount
bin/asc_tank2pcx
bin/asc_raw2pcx
bin/asc_viewid
bin/asc_weaponguide
share/asc/asc_dlg.zip
share/asc/buildings.con
share/asc/main.con
share/asc/mk1.con