Fix build-issue when ffmpeg is installed.
PR: ports/59615 Submitted by: ume Approved by: maintainer silence
This commit is contained in:
parent
4664863229
commit
1af872aa6b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110036
@ -1,6 +1,8 @@
|
||||
*** configure.in.orig Thu May 22 13:25:00 2003
|
||||
--- configure.in Sat Aug 23 07:52:44 2003
|
||||
*************** fi
|
||||
Index: configure.in
|
||||
diff -c configure.in.orig configure.in
|
||||
*** configure.in.orig Thu May 22 21:25:00 2003
|
||||
--- configure.in Sun Nov 23 22:51:33 2003
|
||||
***************
|
||||
*** 73,85 ****
|
||||
|
||||
dnl ########################################################################
|
||||
@ -29,3 +31,20 @@
|
||||
PWLIBDIR="/usr/local/share/pwlib/"
|
||||
fi
|
||||
echo "PWLib prefix set to.... $PWLIBDIR"
|
||||
***************
|
||||
*** 96,102 ****
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
--- 96,102 ----
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
|
13
net/opal/files/patch-src::h263codec.cxx
Normal file
13
net/opal/files/patch-src::h263codec.cxx
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/h263codec.cxx
|
||||
diff -u src/h263codec.cxx.orig src/h263codec.cxx
|
||||
--- src/h263codec.cxx.orig Fri Jun 6 15:32:08 2003
|
||||
+++ src/h263codec.cxx Sat Nov 22 23:17:45 2003
|
||||
@@ -109,7 +109,7 @@
|
||||
#include "rtp.h"
|
||||
|
||||
extern "C" {
|
||||
-#include <avcodec.h>
|
||||
+#include <ffmpeg/avcodec.h>
|
||||
};
|
||||
|
||||
|
@ -1,6 +1,8 @@
|
||||
*** configure.in.orig Thu May 22 13:25:00 2003
|
||||
--- configure.in Sat Aug 23 07:52:44 2003
|
||||
*************** fi
|
||||
Index: configure.in
|
||||
diff -c configure.in.orig configure.in
|
||||
*** configure.in.orig Thu May 22 21:25:00 2003
|
||||
--- configure.in Sun Nov 23 22:51:33 2003
|
||||
***************
|
||||
*** 73,85 ****
|
||||
|
||||
dnl ########################################################################
|
||||
@ -29,3 +31,20 @@
|
||||
PWLIBDIR="/usr/local/share/pwlib/"
|
||||
fi
|
||||
echo "PWLib prefix set to.... $PWLIBDIR"
|
||||
***************
|
||||
*** 96,102 ****
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
--- 96,102 ----
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
|
13
net/opal3/files/patch-src::h263codec.cxx
Normal file
13
net/opal3/files/patch-src::h263codec.cxx
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/h263codec.cxx
|
||||
diff -u src/h263codec.cxx.orig src/h263codec.cxx
|
||||
--- src/h263codec.cxx.orig Fri Jun 6 15:32:08 2003
|
||||
+++ src/h263codec.cxx Sat Nov 22 23:17:45 2003
|
||||
@@ -109,7 +109,7 @@
|
||||
#include "rtp.h"
|
||||
|
||||
extern "C" {
|
||||
-#include <avcodec.h>
|
||||
+#include <ffmpeg/avcodec.h>
|
||||
};
|
||||
|
||||
|
@ -1,6 +1,8 @@
|
||||
*** configure.in.orig Thu May 22 13:25:00 2003
|
||||
--- configure.in Sat Aug 23 07:52:44 2003
|
||||
*************** fi
|
||||
Index: configure.in
|
||||
diff -c configure.in.orig configure.in
|
||||
*** configure.in.orig Thu May 22 21:25:00 2003
|
||||
--- configure.in Sun Nov 23 22:51:33 2003
|
||||
***************
|
||||
*** 73,85 ****
|
||||
|
||||
dnl ########################################################################
|
||||
@ -29,3 +31,20 @@
|
||||
PWLIBDIR="/usr/local/share/pwlib/"
|
||||
fi
|
||||
echo "PWLib prefix set to.... $PWLIBDIR"
|
||||
***************
|
||||
*** 96,102 ****
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
--- 96,102 ----
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
|
13
net/openh323-112/files/patch-src::h263codec.cxx
Normal file
13
net/openh323-112/files/patch-src::h263codec.cxx
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/h263codec.cxx
|
||||
diff -u src/h263codec.cxx.orig src/h263codec.cxx
|
||||
--- src/h263codec.cxx.orig Fri Jun 6 15:32:08 2003
|
||||
+++ src/h263codec.cxx Sat Nov 22 23:17:45 2003
|
||||
@@ -109,7 +109,7 @@
|
||||
#include "rtp.h"
|
||||
|
||||
extern "C" {
|
||||
-#include <avcodec.h>
|
||||
+#include <ffmpeg/avcodec.h>
|
||||
};
|
||||
|
||||
|
@ -1,6 +1,8 @@
|
||||
*** configure.in.orig Thu May 22 13:25:00 2003
|
||||
--- configure.in Sat Aug 23 07:52:44 2003
|
||||
*************** fi
|
||||
Index: configure.in
|
||||
diff -c configure.in.orig configure.in
|
||||
*** configure.in.orig Thu May 22 21:25:00 2003
|
||||
--- configure.in Sun Nov 23 22:51:33 2003
|
||||
***************
|
||||
*** 73,85 ****
|
||||
|
||||
dnl ########################################################################
|
||||
@ -29,3 +31,20 @@
|
||||
PWLIBDIR="/usr/local/share/pwlib/"
|
||||
fi
|
||||
echo "PWLib prefix set to.... $PWLIBDIR"
|
||||
***************
|
||||
*** 96,102 ****
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include/ffmpeg
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
--- 96,102 ----
|
||||
else
|
||||
AC_CHECK_FILE(/usr/local/include/ffmpeg/avcodec.h, H323_AVCODEC=1)
|
||||
if test "${H323_AVCODEC:-unset}" != "unset" ; then
|
||||
! AVCODECINCLUDEDIR=/usr/local/include
|
||||
AVCODECLIBDIR=/usr/local/lib
|
||||
fi
|
||||
fi
|
||||
|
13
net/openh323/files/patch-src::h263codec.cxx
Normal file
13
net/openh323/files/patch-src::h263codec.cxx
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/h263codec.cxx
|
||||
diff -u src/h263codec.cxx.orig src/h263codec.cxx
|
||||
--- src/h263codec.cxx.orig Fri Jun 6 15:32:08 2003
|
||||
+++ src/h263codec.cxx Sat Nov 22 23:17:45 2003
|
||||
@@ -109,7 +109,7 @@
|
||||
#include "rtp.h"
|
||||
|
||||
extern "C" {
|
||||
-#include <avcodec.h>
|
||||
+#include <ffmpeg/avcodec.h>
|
||||
};
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user