audio/libcanberra: include the gtk header in both gtk2 and gtk3 cases

Avoid collision by puting them in a different path which is anyway provided
by pkgconf

Reported by:	jbeich
This commit is contained in:
Baptiste Daroussin 2022-05-19 18:12:41 +02:00
parent 274d6cb1a5
commit 1ac2359a88
6 changed files with 40 additions and 4 deletions

View File

@ -4,4 +4,8 @@
MASTERDIR= ${.CURDIR:H}/libcanberra
SLAVEPORT= gtk2
post-install:
@${MKDIR} ${STAGEDIR}/${PREFIX}/include/canberra-gtk2
@${MV} ${STAGEDIR}/${PREFIX}/include/canberra-gtk.h ${STAGEDIR}/${PREFIX}/include/canberra-gtk2
.include "${MASTERDIR}/Makefile"

View File

@ -4,4 +4,8 @@
MASTERDIR= ${.CURDIR:H}/libcanberra
SLAVEPORT= gtk3
post-install:
@${MKDIR} ${STAGEDIR}/${PREFIX}/include/canberra-gtk3
@${MV} ${STAGEDIR}/${PREFIX}/include/canberra-gtk.h ${STAGEDIR}/${PREFIX}/include/canberra-gtk3
.include "${MASTERDIR}/Makefile"

View File

@ -3,7 +3,7 @@
PORTNAME= libcanberra
PORTVERSION= 0.30
PORTREVISION= 6
PORTREVISION= 7
CATEGORIES= audio devel
MASTER_SITES= http://0pointer.de/lennart/projects/libcanberra/ \
http://pkgs.fedoraproject.org/repo/pkgs/libcanberra/libcanberra-0.30.tar.xz/34cb7e4430afaf6f447c4ebdb9b42072/
@ -35,13 +35,17 @@ PKGNAMESUFFIX= -${SLAVEPORT}
USE_GNOME+= gtk30
LIB_DEPENDS+= libcanberra.so:audio/libcanberra
CONFIGURE_ARGS+= --enable-gtk3 \
--disable-gtk
--disable-gtk \
--disable-gstreamer \
--disable-pulse
PLIST_SUB+= BASE="@comment " GTK3="" GTK2="@comment "
.elif ${SLAVEPORT:U} == gtk2
USE_GNOME+= gnomeprefix gtk20
LIB_DEPENDS+= libcanberra.so:audio/libcanberra
CONFIGURE_ARGS+= --enable-gtk \
--disable-gtk3
--disable-gtk3 \
--disable-gstreamer \
--disable-pulse
PLIST_SUB+= BASE="@comment " GTK3="@comment " GTK2=""
.else
CONFIGURE_ARGS+= --disable-gtk \
@ -61,4 +65,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- libcanberra-gtk.pc.in.orig 2022-05-19 16:04:44 UTC
+++ libcanberra-gtk.pc.in
@@ -1,7 +1,7 @@ libdir=@libdir@
prefix=@prefix@
exec_prefix=${prefix}
libdir=@libdir@
-includedir=@includedir@
+includedir=@includedir@/canberra-gtk2
Name: libcanberra-gtk
Description: Gtk Event Sound API

View File

@ -0,0 +1,11 @@
--- libcanberra-gtk3.pc.in.orig 2022-05-19 16:04:19 UTC
+++ libcanberra-gtk3.pc.in
@@ -1,7 +1,7 @@ libdir=@libdir@
prefix=@prefix@
exec_prefix=${prefix}
libdir=@libdir@
-includedir=@includedir@
+includedir=@includedir@/canberra-gtk3
Name: libcanberra-gtk3
Description: Gtk3 Event Sound API

View File

@ -1,5 +1,6 @@
%%GTK2%%bin/canberra-gtk-play
%%GTK2%%include/canberra-gtk.h
%%GTK2%%include/canberra-gtk2/canberra-gtk.h
%%GTK3%%include/canberra-gtk3/canberra-gtk.h
%%BASE%%include/canberra.h
%%GTK2%%lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
%%GTK2%%lib/gtk-2.0/modules/libcanberra-gtk-module.so