Rename to mftrace.

PR:		50578
Submitted by:	Keith White of SITE, University of Ottawa

Also fix master site, update to 1.0.19, generate packing list upon
installation, support getopt_long on -CURRENT, and assume maintainership.
This commit is contained in:
Trevor Johnson 2003-10-13 23:22:02 +00:00
parent d00dc3632d
commit 1aa50ba883
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91113
12 changed files with 68 additions and 34 deletions

View File

@ -1,18 +1,17 @@
# ex:ts=8
# Ports collection makefile for: pktrace
# Ports collection makefile for: mftrace (formerly pktrace)
# Date created: Jun w, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= pktrace
PORTVERSION= 1.0.4
PORTREVISION= 1
PORTNAME= mftrace
PORTVERSION= 1.0.19
CATEGORIES= print
MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
MASTER_SITES= http://www.xs4all.nl/~hanwen/mftrace/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= trevor@FreeBSD.org
COMMENT= Scalable PostScript (Type1) Fonts for MetaFont
RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
@ -25,13 +24,30 @@ USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
PLIST= ${WRKDIR}/pkg-plist
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= pktrace.1
MAN1= mftrace.1
pre-everything::
@${CAT} ${PKGMESSAGE}
@{ECHO_CMD} Pausing ten seconds--press control-C to cancel build.
@sleep 10
pre-install:
${RM} -f ${PLIST}
.for ii in gf2pbm mftrace
${ECHO_CMD} bin/${ii} >> ${PLIST}
.endfor
.for ii in afm tfm
${ECHO_CMD} lib/%%PYTHON_VERSION%%/site-packages/${ii}.py >> ${PLIST}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/mftrace ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mftrace.1 ${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/afm.py ${PYTHON_SITELIBDIR}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pktrace-1.0.4.tar.gz) = e78cd41f09abf9558133263397498f7b
MD5 (mftrace-1.0.19.tar.gz) = f121f62bcbd4681df816d2956ed9b607

View File

@ -1,11 +1,13 @@
$FreeBSD$
--- GNUmakefile.in.orig Sun Jun 2 23:51:33 2002
+++ GNUmakefile.in Sun Jun 2 23:52:07 2002
@@ -23,7 +23,7 @@
compile: pktrace gf2pbm
compile: mftrace gf2pbm
gf2pbm: gf2pbm.c
- gcc -O2 -Wall -o $@ $<
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib -lgnugetopt
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib ${LDFLAGS}
README.txt: README.texi
makeinfo --no-split --no-headers --output $@ $<

View File

@ -1,8 +1,8 @@
pktrace is a small Python program that lets you trace a TeX bitmap font into
mftrace is a small Python program that lets you trace a TeX bitmap font into
a PFA or PFB font (A PostScript Type1 Scalable Font).
Type1 fonts offer many advantages over bitmaps, as they allow PostScript
files to render correctly on printers with many resolutions. Moreover,
Ghostscript can generate much better PDF, if given scalable fonts.
WWW: http://www.cs.uu.nl/~hanwen/pktrace/
WWW: http://www.cs.uu.nl/~hanwen/mftrace/

View File

@ -0,0 +1,2 @@
*** WARNING:
*** The source code of mftrace has not been reviewed by the maintainer!

View File

@ -1,3 +0,0 @@
bin/gf2pbm
bin/pktrace
lib/%%PYTHON_VERSION%%/site-packages/tfm.py

View File

@ -1,18 +1,17 @@
# ex:ts=8
# Ports collection makefile for: pktrace
# Ports collection makefile for: mftrace (formerly pktrace)
# Date created: Jun w, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= pktrace
PORTVERSION= 1.0.4
PORTREVISION= 1
PORTNAME= mftrace
PORTVERSION= 1.0.19
CATEGORIES= print
MASTER_SITES= http://www.cs.uu.nl/~hanwen/pktrace/
MASTER_SITES= http://www.xs4all.nl/~hanwen/mftrace/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= trevor@FreeBSD.org
COMMENT= Scalable PostScript (Type1) Fonts for MetaFont
RUN_DEPENDS= mktextfm:${PORTSDIR}/print/teTeX \
@ -25,13 +24,30 @@ USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
PLIST= ${WRKDIR}/pkg-plist
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= pktrace.1
MAN1= mftrace.1
pre-everything::
@${CAT} ${PKGMESSAGE}
@{ECHO_CMD} Pausing ten seconds--press control-C to cancel build.
@sleep 10
pre-install:
${RM} -f ${PLIST}
.for ii in gf2pbm mftrace
${ECHO_CMD} bin/${ii} >> ${PLIST}
.endfor
.for ii in afm tfm
${ECHO_CMD} lib/%%PYTHON_VERSION%%/site-packages/${ii}.py >> ${PLIST}
.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gf2pbm ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/pktrace ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/pktrace.1 ${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/mftrace ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/mftrace.1 ${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/tfm.py ${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/afm.py ${PYTHON_SITELIBDIR}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (pktrace-1.0.4.tar.gz) = e78cd41f09abf9558133263397498f7b
MD5 (mftrace-1.0.19.tar.gz) = f121f62bcbd4681df816d2956ed9b607

View File

@ -1,11 +1,13 @@
$FreeBSD$
--- GNUmakefile.in.orig Sun Jun 2 23:51:33 2002
+++ GNUmakefile.in Sun Jun 2 23:52:07 2002
@@ -23,7 +23,7 @@
compile: pktrace gf2pbm
compile: mftrace gf2pbm
gf2pbm: gf2pbm.c
- gcc -O2 -Wall -o $@ $<
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib -lgnugetopt
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o $@ $< -L${LOCALBASE}/lib ${LDFLAGS}
README.txt: README.texi
makeinfo --no-split --no-headers --output $@ $<

View File

@ -1,8 +1,8 @@
pktrace is a small Python program that lets you trace a TeX bitmap font into
mftrace is a small Python program that lets you trace a TeX bitmap font into
a PFA or PFB font (A PostScript Type1 Scalable Font).
Type1 fonts offer many advantages over bitmaps, as they allow PostScript
files to render correctly on printers with many resolutions. Moreover,
Ghostscript can generate much better PDF, if given scalable fonts.
WWW: http://www.cs.uu.nl/~hanwen/pktrace/
WWW: http://www.cs.uu.nl/~hanwen/mftrace/

View File

@ -0,0 +1,2 @@
*** WARNING:
*** The source code of mftrace has not been reviewed by the maintainer!

View File

@ -1,3 +0,0 @@
bin/gf2pbm
bin/pktrace
lib/%%PYTHON_VERSION%%/site-packages/tfm.py