The latest version is 0.8.12. The *.tcl scripts are no longer

provided. The documentation layout is changed, the master-site
changed.
This commit is contained in:
Mikhail Teterin 2001-02-13 17:52:54 +00:00
parent 42b9d9405c
commit 1a995d596c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38313
7 changed files with 27 additions and 66 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= mod_dtcl
PORTVERSION= 0.8.1.1
PORTVERSION= 0.8.12
CATEGORIES= www tcl83
MASTER_SITES= http://master.debian.org/~davidw/mod_dtcl/
DISTNAME= libapache-mod-dtcl_0.8.1-1
MASTER_SITES= http://tcl.apache.org/mod_dtcl/download/
MAINTAINER= mi@aldan.algebra.com
@ -20,30 +19,16 @@ WRKSRC= ${WRKDIR}/mod_dtcl
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAN1= testdtcl.1
MANCOMPRESSED= no
do-install:
${INSTALL_DATA} ${WRKSRC}/libmod_dtcl.so.1* \
${PREFIX}/libexec/apache/mod_dtcl.so
${PREFIX}/sbin/apxs -e -A -n dtcl ${PREFIX}/libexec/apache/mod_dtcl.so
${INSTALL_PROGRAM} ${WRKSRC}/testdtcl ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/testdtcl.1 ${PREFIX}/man/man1/
${MKDIR} ${PREFIX}/share/mod_dtcl
${INSTALL_DATA} ${WRKSRC}/*.tcl ${PREFIX}/share/mod_dtcl
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/mod_dtcl
${INSTALL_DATA} ${WRKSRC}/*.?tml ${WRKSRC}/*.gif \
${INSTALL_DATA} ${WRKSRC}/docs/*.?tml ${WRKSRC}/docs/*.gif \
${PREFIX}/share/doc/mod_dtcl
${CAT} ${PKGMESSAGE}
.else
# Not installing the documentation. Consult the
# file:/${WRKSRC}/INSTALL.html
# for information on how to proceed to enable mod_dtcl.
# Note, that the dtcl.tcl mentioned there is installed as
# ${PREFIX}/share/mod_dtcl/dtcl.tcl
# but the comment in it suggests it should not be used
# in a "production environment"...
${SED} 's,/usr/local,${LOCALBASE},g' ${PKGMESSAGE}
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (libapache-mod-dtcl_0.8.1-1.tar.gz) = 66513a09a1cc0d3a4478276a308d4328
MD5 (mod_dtcl-0.8.12.tar.gz) = ee71c3a6e2b60554fb22b988ab2a5cc1

View File

@ -1,4 +1,3 @@
# If you link against Tcl like so "-ltcl", leave this blank.
TCL_VERSION?=8.3
TCL_NDVER?=${TCL_VERSION:S/.//} # same, but without the dot
@ -6,10 +5,13 @@ PREFIX?= /usr/local
INCLUDES=-I${PREFIX}/include/apache -I${PREFIX}/include/tcl${TCL_VERSION}
DTCL_VERSION!= cat ${.CURDIR}/VERSION
CC!= ${PREFIX}/sbin/apxs -q CC
CFLAGS!= ${PREFIX}/sbin/apxs -q CFLAGS CFLAGS_SHLIB
CFLAGS+= -Wall -DSTATUS -DNO_DBM_REWRITEMAP ${INCLUDES}
CFLAGS+= -DDEBUG_SCRIPT_DIR="\"${PREFIX}/share/mod_dtcl/\""
CFLAGS+= -DDTCL_VERSION="\"${DTCL_VERSION}\""
LIB= mod_dtcl
SHLIB_MAJOR=1
@ -24,6 +26,6 @@ INTERNALLIB= True # to avoid building a static version
SRCS= mod_dtcl.c
NOMAN= True # don't bother with the man-page here, let the port handle it
all: ${SHLIB_NAME} testdtcl
all: ${SHLIB_NAME}
.include <bsd.lib.mk>

View File

@ -1,20 +0,0 @@
--- testdtcl.c.orig Mon Dec 6 00:26:28 1999
+++ testdtcl.c Thu Feb 17 15:01:52 2000
@@ -14,4 +14,5 @@
#include <tcl.h>
#include <unistd.h>
+#include <stdlib.h> /* In older FreeBSD, this is where getopt(3) lives */
#ifndef DEBUG_SCRIPT_DIR
@@ -51,5 +52,4 @@
"Testdtcl is out of date, you should only "
"really be using it if you wish to improve it\n");
- exit(0);
interp = Tcl_CreateInterp();
@@ -233,4 +233,5 @@
}
}
+ return 0;
}

View File

@ -0,0 +1,7 @@
There is not index.ttml provided with this package. Make the
link point to the official site. -mi
--- docs/examples.ttml Wed Nov 8 11:46:00 2000
+++ docs/examples.ttml Tue Feb 13 12:13:41 2001
@@ -238 +238 @@
-<a href="index.ttml">Return to the mod_dtcl homepage</a>
+<a href="http://tcl.apache.org/mod_dtcl/">Return to the mod_dtcl homepage</a>

View File

@ -1,14 +1,12 @@
-
Please, follow the instructions in
file:/usr/local/share/doc/mod_dtcl/INSTALL.html
file:/usr/local/share/doc/mod_dtcl/documentation.html
(where /usr/local may be replaced by your machine's
setting for PREFIX) to enable the mod_dtcl's usage.
Note, that the dtcl.tcl mentioned in the instructions is
installed as /usr/local/share/mod_dtcl/dtcl.tcl .
(where /usr/local may be replaced by a machine's
setting for LOCALBASE) to enable the mod_dtcl's usage.
The mentioning of mod_dtcl is already in the Apache's config
file, but it is commented out -- you have to uncomment it
manually.
manually and add the line:
AddType application/x-httpd-tcl .ttml
-

View File

@ -1,21 +1,10 @@
bin/testdtcl
libexec/apache/mod_dtcl.so
@exec %D/sbin/apxs -e -A -n dtcl %D/%F
@unexec %D/sbin/apxs -e -A -n dtcl %D/%F
share/mod_dtcl/dtcl.tcl
share/mod_dtcl/globalscript.tcl
share/mod_dtcl/infodebug.tcl
share/mod_dtcl/testdtcl.tcl
@dirrm share/mod_dtcl
share/doc/mod_dtcl/INSTALL.html
share/doc/mod_dtcl/TODO.html
share/doc/mod_dtcl/benchmark.html
share/doc/mod_dtcl/browse-source.html
share/doc/mod_dtcl/dtcl-tcl.html
share/doc/mod_dtcl/examples.ttml
share/doc/mod_dtcl/readme.hpux.html
share/doc/mod_dtcl/readme.html
share/doc/mod_dtcl/table.html
share/doc/mod_dtcl/use.html
share/doc/mod_dtcl/dtcl.gif
@dirrm share/doc/mod_dtcl
%%PORTDOCS%%share/doc/mod_dtcl/asf_logo.gif
%%PORTDOCS%%share/doc/mod_dtcl/documentation.html
%%PORTDOCS%%share/doc/mod_dtcl/dtcl.gif
%%PORTDOCS%%share/doc/mod_dtcl/examples.ttml
%%PORTDOCS%%share/doc/mod_dtcl/logoLarge.gif
%%PORTDOCS%%@dirrm share/doc/mod_dtcl