Unbreak on 64bit platforms

This commit is contained in:
Tilman Keskinoz 2009-03-13 18:15:57 +00:00
parent 6d9278eb9c
commit 1a90878336
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230008
3 changed files with 22 additions and 4 deletions

View File

@ -27,10 +27,6 @@ PORTEXAMPLES= *
.include <bsd.port.pre.mk>
.if ( ${ARCH} == "amd64" || ${ARCH} == "sparc64" ) && ${OSVERSION} >= 700043
BROKEN= does not compile
.endif
post-patch:
# Allow to build with modern GCC
@${REINPLACE_CMD} -e 's,friend,& class,' ${WRKSRC}/XMill/*.?pp \

View File

@ -0,0 +1,11 @@
--- XMill/CompressMan.cpp.orig 2009-03-13 19:11:05.000000000 +0100
+++ XMill/CompressMan.cpp 2009-03-13 19:11:08.000000000 +0100
@@ -423,7 +423,7 @@
UserCompressorFactory *compressor=compressorlist;
while(compressor!=NULL)
{
- printf("%lu =>",(unsigned int)compressor);
+ printf("%lu =>",(unsigned intptr_t)compressor);
printf("%s\n",compressor->GetName());
compressor=compressor->next;
}

View File

@ -0,0 +1,11 @@
--- XMill/PPMDI.cpp.orig 2009-03-13 19:12:05.000000000 +0100
+++ XMill/PPMDI.cpp 2009-03-13 19:12:29.000000000 +0100
@@ -245,7 +245,7 @@
cleanup:
*outused = j;
- *inused = inlen - (int)endptr + (int)src;
+ *inused = inlen - (intptr_t)endptr + (intptr_t)src;
return ret;
}