net-im/fractal: create port

Fractal is a Gtk+ Matrix messaging client written in Rust.
Its interface is optimized for collaboration in large groups
such as free software projects.

WWW: https://wiki.gnome.org/Apps/Fractal

PR:		226683
Submitted by:	Greg V <greg@unrelenting.technology>
This commit is contained in:
Steve Wills 2018-10-09 18:06:15 +00:00
parent c68a39284e
commit 1a80bb1732
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481644
5 changed files with 79 additions and 0 deletions

39
net-im/fractal/Makefile Normal file
View File

@ -0,0 +1,39 @@
# $FreeBSD$
PORTNAME= fractal
DISTVERSION= 3.30.0
CATEGORIES= net-im
MASTER_SITES= https://gitlab.gnome.org/World/fractal/uploads/${GL_HASH}/
MAINTAINER= greg@unrelenting.technology
COMMENT= GTK+ Matrix IM client
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
# gmake for the backtrace-sys crate
BUILD_DEPENDS= cargo:lang/rust \
gmake:devel/gmake
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libgmp.so:math/gmp \
libgspell-1.so:textproc/gspell
USES= gettext gnome meson pkgconfig python:3.5+,build ssl tar:xz
USE_GNOME= cairo gtk30 gtksourceview3
USE_GSTREAMER1= bad
GL_HASH= cc46d6b9702ce5d0b1f3073f516a58c3
BINARY_ALIAS= python3=${PYTHON_CMD}
GLIB_SCHEMAS= org.gnome.Fractal.gschema.xml
INSTALLS_ICONS= yes
WITHOUT_FBSD10_FIX= yes # changes libbacktrace conf script's checksum
# for the gettext-sys crate
MAKE_ENV+= GETTEXT_BIN_DIR=${LOCALBASE}/bin \
GETTEXT_LIB_DIR=${LOCALBASE}/lib \
GETTEXT_INCLUDE_DIR=${LOCALBASE}/include
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fractal
.include <bsd.port.mk>

3
net-im/fractal/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1536754711
SHA256 (fractal-3.30.0.tar.xz) = 4782a0ab59c5da2470a380700374d5c3d736085a66cf0de1fca9b2921c1f8363
SIZE (fractal-3.30.0.tar.xz) = 11603220

View File

@ -0,0 +1,11 @@
--- scripts/cargo.sh.orig 2018-09-12 12:22:27 UTC
+++ scripts/cargo.sh
@@ -7,7 +7,7 @@ export FRACTAL_NAME_SUFFIX="$5"
export FRACTAL_VERSION="$6"
export FRACTAL_PROFILE="$7"
-if [[ "$FRACTAL_PROFILE" == "Devel" ]]
+if [ "$FRACTAL_PROFILE" = "Devel" ]
then
echo "DEBUG MODE"
cargo build --manifest-path $1/Cargo.toml -p fractal-gtk && cp $1/target/debug/fractal-gtk $2

5
net-im/fractal/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Fractal is a Gtk+ Matrix messaging client written in Rust.
Its interface is optimized for collaboration in large groups
such as free software projects.
WWW: https://wiki.gnome.org/Apps/Fractal

21
net-im/fractal/pkg-plist Normal file
View File

@ -0,0 +1,21 @@
bin/fractal
share/applications/org.gnome.Fractal.desktop
share/icons/hicolor/16x16/apps/org.gnome.Fractal.png
share/icons/hicolor/22x22/apps/org.gnome.Fractal.png
share/icons/hicolor/24x24/apps/org.gnome.Fractal.png
share/icons/hicolor/32x32/apps/org.gnome.Fractal.png
share/icons/hicolor/48x48/apps/org.gnome.Fractal.png
share/icons/hicolor/512x512/apps/org.gnome.Fractal.png
share/icons/hicolor/scalable/apps/org.gnome.Fractal-symbolic.svg
share/locale/ca/LC_MESSAGES/fractal.mo
share/locale/cs/LC_MESSAGES/fractal.mo
share/locale/de/LC_MESSAGES/fractal.mo
share/locale/es/LC_MESSAGES/fractal.mo
share/locale/fi/LC_MESSAGES/fractal.mo
share/locale/fr/LC_MESSAGES/fractal.mo
share/locale/fur/LC_MESSAGES/fractal.mo
share/locale/pl/LC_MESSAGES/fractal.mo
share/locale/pt_BR/LC_MESSAGES/fractal.mo
share/locale/sk/LC_MESSAGES/fractal.mo
share/locale/sv/LC_MESSAGES/fractal.mo
share/metainfo/org.gnome.Fractal.appdata.xml