New port: security/py-ssh-audit: SSH server auditing

PR:		223810
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D13207
This commit is contained in:
Yuri Victorovich 2017-11-24 21:32:05 +00:00
parent 3aa1fec25f
commit 1a7525ba58
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454849
5 changed files with 69 additions and 0 deletions

View File

@ -969,6 +969,7 @@
SUBDIR += py-slowaes
SUBDIR += py-spake2
SUBDIR += py-ssh
SUBDIR += py-ssh-audit
SUBDIR += py-sslstrip
SUBDIR += py-stem
SUBDIR += py-stix

View File

@ -0,0 +1,27 @@
# $FreeBSD$
PORTNAME= ssh-audit
DISTVERSIONPREFIX= v
DISTVERSION= 1.7.0
CATEGORIES= security
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= pkubaj@anongoth.pl
COMMENT= SSH server auditing
LICENSE= MIT
USES= python shebangfix
USE_GITHUB= yes
GH_ACCOUNT= arthepsy
USE_PYTHON= concurrent
NO_BUILD= yes
NO_ARCH= yes
SHEBANG_FILES= ssh-audit.py
PLIST_FILES= bin/ssh-audit
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ssh-audit.py ${STAGEDIR}${PREFIX}/bin/ssh-audit
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1511379690
SHA256 (arthepsy-ssh-audit-v1.7.0_GH0.tar.gz) = cba29cc19ec2932e4f43c720b2c49a7d179219e23482476aeb472f7463713b68
SIZE (arthepsy-ssh-audit-v1.7.0_GH0.tar.gz) = 30222

View File

@ -0,0 +1,20 @@
--- ssh-audit.py.orig 2017-11-23 08:27:24 UTC
+++ ssh-audit.py
@@ -43,11 +43,12 @@ try: # pragma: nocover
from typing import Callable, Optional, Union, Any
except ImportError: # pragma: nocover
pass
-try: # pragma: nocover
- from colorama import init as colorama_init
- colorama_init() # pragma: nocover
-except ImportError: # pragma: nocover
- pass
+# colorama is only for Windows, posix systems support colors without it
+#try: # pragma: nocover
+# from colorama import init as colorama_init
+# colorama_init() # pragma: nocover
+#except ImportError: # pragma: nocover
+# pass
def usage(err=None):

View File

@ -0,0 +1,18 @@
ssh-audit is a tool for ssh server auditing.
Features:
* SSH1 and SSH2 protocol server support;
* grab banner, recognize device or software and operating system,
detect compression;
* gather key-exchange, host-key, encryption and
message authentication code algorithms;
* output algorithm information
(available since, removed/disabled, unsafe/weak/legacy, etc);
* output algorithm recommendations
(append or remove based on recognized software version);
* output security information (related issues, assigned CVE list, etc);
* analyze SSH version compatibility based on algorithm information;
* historical information from OpenSSH, Dropbear SSH and libssh;
* no dependencies, compatible with Python 2.6+, Python 3.x and PyPy.
WWW: https://github.com/arthepsy/ssh-audit