Update to 1.1.12.
This commit is contained in:
parent
0c247abf30
commit
1a5f63a5b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50211
@ -6,22 +6,26 @@
|
||||
#
|
||||
|
||||
PORTNAME= glimmer
|
||||
PORTVERSION= 1.0.8
|
||||
PORTVERSION= 1.1.12
|
||||
CATEGORIES= editors gnome python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_PYTHON= yes
|
||||
USE_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-regex
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D_REGEX_H_ -D_REGEX_H" \
|
||||
LIBS="-L${LOCALBASE}/lib -lgnuregex"
|
||||
.if exists(/usr/lib/libcrypto.a)
|
||||
PYTHON_LIBS= -lssl -lcrypto
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (glimmer-1.0.8.tar.gz) = 4504d63f5ca196c5de19ae13804ebacd
|
||||
MD5 (glimmer-1.1.12-1.tar.gz) = dd240d137dea849524db387d8ab12a5a
|
||||
|
@ -1,12 +1,12 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure 2001/07/02 06:14:02 1.1
|
||||
+++ configure 2001/07/02 06:14:16
|
||||
@@ -4731,7 +4731,7 @@
|
||||
if test "$python" = yes; then
|
||||
echo Python version.....$PY_VERSION
|
||||
--- configure.orig Fri Nov 16 16:02:10 2001
|
||||
+++ configure Fri Nov 16 16:02:49 2001
|
||||
@@ -8320,7 +8320,7 @@
|
||||
fi
|
||||
echo System regex.......$use_system_regex
|
||||
|
||||
-echo GTK+ version.......`gtk-config --version`
|
||||
+echo GTK+ version.......`$GTK_CONFIG --version`
|
||||
echo GNOME version......`gnome-config --version`
|
||||
|
28
editors/glimmer/files/patch-ltmain.sh
Normal file
28
editors/glimmer/files/patch-ltmain.sh
Normal file
@ -0,0 +1,28 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/08/27 09:51:26 1.1
|
||||
+++ ltmain.sh 2001/08/27 09:51:42
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test "$build_libtool_need_lc" = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -1,188 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/Makefile.in 2001/10/05 13:54:30 1.1
|
||||
+++ src/Makefile.in 2001/10/05 13:56:32
|
||||
@@ -117,7 +117,7 @@
|
||||
l = @l@
|
||||
pythonpath = @pythonpath@
|
||||
|
||||
-SUBDIRS = regex gtkextext widgets libprint
|
||||
+SUBDIRS = gtkextext widgets libprint
|
||||
|
||||
EXTRA_DIST = xpm/folder_closed.xpm xpm/folder_open.xpm xpm/new.xpm xpm/selection.xpm xpm/select_all.xpm xpm/debug.xpm xpm/window.xpm xpm/bookmark.xpm xpm/glimmer.xpm bindings-python.c colors.h
|
||||
|
||||
@@ -130,7 +130,7 @@
|
||||
glimmer_SOURCES = about.c about.h bindings.c bindings.h build.c build.h color-settings.c color-settings.h commandbar.c commandbar.h declarations.h dialogs.c dialogs.h dragndrop.c dragndrop.h edit.c edit.h file-io.c file-io.h findbar.c findbar.h getprefs.c getprefs.h highlightbar.c highlightbar.h insert.c insert.h linebar.c linebar.h macro-language.c macro-language.h main.c main.h mdi-routines.c mdi-routines.h menus.c menus.h misc.c misc.h properties.c properties.h searches.c searches.h session.c session.h session-management.c session-management.h settings.c settings.h signals.c signals.h splash.c splash.h syntax-highlight.c syntax-highlight.h toolbar.c toolbar.h view.c view.h windows.c windows.h
|
||||
|
||||
|
||||
-glimmer_LDADD = widgets/libwidgets.a regex/libregex.a gtkextext/libgtkextext.a libprint/libglimmerprint.a $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(EXTRA_GNOME_LIBS) $(PY_LIBS)
|
||||
+glimmer_LDADD = widgets/libwidgets.a -lgnuregex gtkextext/libgtkextext.a libprint/libglimmerprint.a $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(EXTRA_GNOME_LIBS) $(PY_LIBS)
|
||||
|
||||
|
||||
glimmerout_SOURCES = glimmerout.c
|
||||
@@ -152,7 +152,7 @@
|
||||
mdi-routines.o menus.o misc.o properties.o searches.o session.o \
|
||||
session-management.o settings.o signals.o splash.o syntax-highlight.o \
|
||||
toolbar.o view.o windows.o
|
||||
-glimmer_DEPENDENCIES = widgets/libwidgets.a regex/libregex.a \
|
||||
+glimmer_DEPENDENCIES = widgets/libwidgets.a \
|
||||
gtkextext/libgtkextext.a libprint/libglimmerprint.a
|
||||
glimmer_LDFLAGS =
|
||||
glimmerout_OBJECTS = glimmerout.o
|
||||
@@ -372,67 +372,67 @@
|
||||
about.o: about.c declarations.h ../config.h about.h
|
||||
bindings.o: bindings.c declarations.h ../config.h bindings.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h build.h edit.h file-io.h widgets/gnomefilelist.h \
|
||||
+ build.h edit.h file-io.h widgets/gnomefilelist.h \
|
||||
main.h misc.h searches.h widgets/gnomesearchdialog.h \
|
||||
widgets/gnomegotoline.h widgets/gdsmanpage.h settings.h \
|
||||
syntax-highlight.h macro-language.h commandbar.h windows.h
|
||||
build.o: build.c declarations.h ../config.h build.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
dialogs.h main.h menus.h misc.h toolbar.h signals.h
|
||||
color-settings.o: color-settings.c declarations.h ../config.h \
|
||||
color-settings.h syntax-highlight.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
getprefs.h main.h settings.h
|
||||
commandbar.o: commandbar.c declarations.h ../config.h commandbar.h \
|
||||
macro-language.h bindings.h main.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h misc.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h misc.h \
|
||||
settings.h
|
||||
dialogs.o: dialogs.c declarations.h ../config.h dialogs.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h file-io.h widgets/gnomefilelist.h misc.h main.h
|
||||
+ file-io.h widgets/gnomefilelist.h misc.h main.h
|
||||
dragndrop.o: dragndrop.c declarations.h ../config.h dragndrop.h main.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h dialogs.h file-io.h widgets/gnomefilelist.h \
|
||||
+ dialogs.h file-io.h widgets/gnomefilelist.h \
|
||||
syntax-highlight.h
|
||||
edit.o: edit.c declarations.h ../config.h edit.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
commandbar.h macro-language.h bindings.h main.h \
|
||||
syntax-highlight.h
|
||||
file-io.o: file-io.c declarations.h ../config.h file-io.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h widgets/gnomefilelist.h dialogs.h main.h misc.h \
|
||||
+ widgets/gnomefilelist.h dialogs.h main.h misc.h \
|
||||
macro-language.h bindings.h mdi-routines.h menus.h properties.h \
|
||||
settings.h session.h signals.h syntax-highlight.h \
|
||||
widgets/gdstearaway.h
|
||||
findbar.o: findbar.c declarations.h ../config.h findbar.h main.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h misc.h searches.h widgets/gnomesearchdialog.h \
|
||||
+ misc.h searches.h widgets/gnomesearchdialog.h \
|
||||
widgets/gnomegotoline.h widgets/gdsmanpage.h settings.h
|
||||
getprefs.o: getprefs.c declarations.h ../config.h getprefs.h colors.h \
|
||||
color-settings.h syntax-highlight.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h main.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h main.h \
|
||||
searches.h widgets/gnomesearchdialog.h widgets/gnomegotoline.h \
|
||||
widgets/gdsmanpage.h settings.h session.h \
|
||||
widgets/gnomefilelist.h
|
||||
glimmerout.o: glimmerout.c
|
||||
highlightbar.o: highlightbar.c declarations.h ../config.h highlightbar.h \
|
||||
main.h widgets/gdsfile.h widgets/gdseditor.h \
|
||||
- gtkextext/gtkextext.h regex/regex.h edit.h
|
||||
+ gtkextext/gtkextext.h edit.h
|
||||
insert.o: insert.c declarations.h ../config.h insert.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
widgets/gnomefilelist.h widgets/gnomeasciilist.h \
|
||||
widgets/gnomeruncmd.h dialogs.h file-io.h main.h misc.h \
|
||||
settings.h
|
||||
linebar.o: linebar.c declarations.h ../config.h linebar.h main.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h misc.h settings.h
|
||||
+ misc.h settings.h
|
||||
macro-language.o: macro-language.c declarations.h ../config.h \
|
||||
macro-language.h bindings.h main.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h menus.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h menus.h \
|
||||
misc.h syntax-highlight.h bindings-python.c settings.h \
|
||||
signals.h toolbar.h
|
||||
main.o: main.c declarations.h ../config.h main.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h build.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h build.h \
|
||||
commandbar.h macro-language.h bindings.h dialogs.h dragndrop.h \
|
||||
file-io.h widgets/gnomefilelist.h findbar.h getprefs.h \
|
||||
highlightbar.h linebar.h menus.h mdi-routines.h misc.h \
|
||||
@@ -442,11 +442,11 @@
|
||||
widgets/gdstearaway.h xpm/bookmark.xpm
|
||||
mdi-routines.o: mdi-routines.c declarations.h ../config.h mdi-routines.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h main.h menus.h misc.h settings.h signals.h \
|
||||
+ main.h menus.h misc.h settings.h signals.h \
|
||||
toolbar.h widgets/gdstearaway.h
|
||||
menus.o: menus.c declarations.h ../config.h menus.h about.h build.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h color-settings.h syntax-highlight.h dialogs.h \
|
||||
+ color-settings.h syntax-highlight.h dialogs.h \
|
||||
edit.h file-io.h widgets/gnomefilelist.h insert.h \
|
||||
widgets/gnomeasciilist.h widgets/gnomeruncmd.h main.h \
|
||||
macro-language.h bindings.h misc.h properties.h searches.h \
|
||||
@@ -455,48 +455,47 @@
|
||||
libprint/print.h widgets/gdsfile.h xpm/selection.xpm \
|
||||
xpm/select_all.xpm xpm/debug.xpm xpm/window.xpm
|
||||
misc.o: misc.c declarations.h ../config.h misc.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h main.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h main.h \
|
||||
settings.h widgets/gdstearaway.h
|
||||
properties.o: properties.c declarations.h ../config.h properties.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h main.h settings.h widgets/gnomedirentry.h
|
||||
+ main.h settings.h widgets/gnomedirentry.h
|
||||
searches.o: searches.c declarations.h ../config.h searches.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h widgets/gnomesearchdialog.h \
|
||||
+ widgets/gnomesearchdialog.h \
|
||||
widgets/gnomegotoline.h widgets/gdsmanpage.h dialogs.h \
|
||||
findbar.h linebar.h main.h misc.h settings.h windows.h
|
||||
session-management.o: session-management.c declarations.h ../config.h \
|
||||
session-management.h session.h widgets/gnomefilelist.h
|
||||
session.o: session.c declarations.h ../config.h session.h \
|
||||
widgets/gnomefilelist.h dialogs.h widgets/gdsfile.h \
|
||||
- widgets/gdseditor.h gtkextext/gtkextext.h regex/regex.h \
|
||||
+ widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
file-io.h main.h misc.h settings.h
|
||||
settings.o: settings.c declarations.h ../config.h settings.h file-io.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h widgets/gnomefilelist.h getprefs.h main.h menus.h \
|
||||
+ widgets/gnomefilelist.h getprefs.h main.h menus.h \
|
||||
misc.h syntax-highlight.h widgets/gnomedirentry.h \
|
||||
widgets/gnome-settings.h xpm/folder_closed.xpm xpm/window.xpm
|
||||
signals.o: signals.c declarations.h ../config.h signals.h \
|
||||
- widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h
|
||||
+ widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h
|
||||
splash.o: splash.c splash.h xpm/glimmer.xpm
|
||||
syntax-highlight.o: syntax-highlight.c declarations.h ../config.h \
|
||||
syntax-highlight.h widgets/gdsfile.h widgets/gdseditor.h \
|
||||
- gtkextext/gtkextext.h regex/regex.h colors.h insert.h \
|
||||
+ gtkextext/gtkextext.h colors.h insert.h \
|
||||
widgets/gnomefilelist.h widgets/gnomeasciilist.h \
|
||||
widgets/gnomeruncmd.h macro-language.h bindings.h main.h misc.h \
|
||||
settings.h signals.h
|
||||
toolbar.o: toolbar.c declarations.h ../config.h toolbar.h build.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h edit.h file-io.h widgets/gnomefilelist.h main.h \
|
||||
+ edit.h file-io.h widgets/gnomefilelist.h main.h \
|
||||
properties.h xpm/debug.xpm
|
||||
view.o: view.c declarations.h ../config.h view.h commandbar.h \
|
||||
macro-language.h bindings.h findbar.h highlightbar.h main.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h linebar.h menus.h toolbar.h
|
||||
+ linebar.h menus.h toolbar.h
|
||||
windows.o: windows.c declarations.h ../config.h windows.h main.h \
|
||||
widgets/gdsfile.h widgets/gdseditor.h gtkextext/gtkextext.h \
|
||||
- regex/regex.h misc.h signals.h
|
||||
+ misc.h signals.h
|
||||
|
||||
info-am:
|
||||
info: info-recursive
|
@ -1,14 +1,17 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/gtkextext/gtkextext.h 2001/10/05 13:57:54 1.1
|
||||
+++ src/gtkextext/gtkextext.h 2001/10/05 13:58:07
|
||||
@@ -29,7 +29,7 @@
|
||||
#include <gtk/gtkadjustment.h>
|
||||
--- src/gtkextext/gtkextext.h.orig Fri Oct 26 23:57:02 2001
|
||||
+++ src/gtkextext/gtkextext.h Mon Nov 19 13:16:44 2001
|
||||
@@ -30,8 +30,10 @@
|
||||
|
||||
#include <sys/types.h>
|
||||
-#include "../regex/regex.h"
|
||||
+#include <gnuregex.h>
|
||||
|
||||
#define GTK_TYPE_EXTEXT (gtk_extext_get_type ())
|
||||
#define GTK_EXTEXT(obj) (GTK_CHECK_CAST ((obj), GTK_TYPE_EXTEXT, GtkExText))
|
||||
+#include "config.h"
|
||||
+
|
||||
#ifdef WITH_SYSTEM_REGEX
|
||||
-#include <regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#else
|
||||
#include "regex.h"
|
||||
#endif
|
||||
|
@ -1,13 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/syntax-highlight.c 2001/10/05 14:02:22 1.1
|
||||
+++ src/syntax-highlight.c 2001/10/05 14:05:45
|
||||
@@ -14,6 +14,7 @@
|
||||
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
+#define _REGEX_H_
|
||||
#include <libgnomevfs/gnome-vfs-mime.h>
|
||||
|
||||
#include "declarations.h"
|
@ -38,6 +38,7 @@ share/gnome/glimmer/languages/z80.lang
|
||||
share/gnome/glimmer/scripts/Delete_To_End.py
|
||||
share/gnome/glimmer/scripts/Delete_To_Start.py
|
||||
share/gnome/glimmer/scripts/FileSelector.py
|
||||
share/gnome/glimmer/scripts/Global.py
|
||||
share/gnome/glimmer/scripts/ISO2HTML.py
|
||||
share/gnome/glimmer/scripts/Replace_Spaces.py
|
||||
share/gnome/glimmer/scripts/Replace_Tabs.py
|
||||
@ -60,6 +61,7 @@ share/gnome/pixmaps/glimmer-title.png
|
||||
share/locale/es/LC_MESSAGES/glimmer.mo
|
||||
share/locale/ja/LC_MESSAGES/glimmer.mo
|
||||
share/locale/sv/LC_MESSAGES/glimmer.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/glimmer.mo
|
||||
@dirrm share/gnome/help/glimmer/C
|
||||
@dirrm share/gnome/help/glimmer
|
||||
@dirrm share/gnome/glimmer/scripts
|
||||
|
Loading…
Reference in New Issue
Block a user