Update to 0.9.7
This commit is contained in:
parent
951063bbab
commit
1987d4855f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=283467
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= smbldap-tools
|
||||
PORTVERSION= 0.9.6
|
||||
PORTVERSION= 0.9.7
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://download.gna.org/smbldap-tools/sources/${PORTVERSION}/
|
||||
|
||||
@ -25,27 +25,19 @@ LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USE_PERL5= yes
|
||||
NO_BUILD= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
ALL_TARGET= build
|
||||
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
|
||||
OPTIONS= MIGRATION_SCRIPTS "Install migration scripts" off \
|
||||
PDF_DOC "Install PDF documentation" off
|
||||
|
||||
SMBLDAP_TOOLS= smbldap-groupadd \
|
||||
smbldap-groupdel \
|
||||
smbldap-grouplist \
|
||||
smbldap-groupmod \
|
||||
smbldap-groupshow \
|
||||
smbldap-useradd \
|
||||
smbldap-userdel \
|
||||
smbldap-userinfo \
|
||||
smbldap-userlist \
|
||||
smbldap-usermod \
|
||||
smbldap-usershow \
|
||||
smbldap-passwd \
|
||||
smbldap-populate
|
||||
CONFIGURE_ARGS+= --with-samba-sysconfdir=${LOCALBASE}/etc \
|
||||
--with-samba-bindir=${LOCALBASE}/bin \
|
||||
--with-perl=${PERL} \
|
||||
--with-perl-libdir=sitelib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
@ -57,51 +49,27 @@ PLIST_SUB+= MIGRATION_SCRIPTS="@comment "
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||
-e "s|/etc/samba|${PREFIX}/etc|g" \
|
||||
-e "s|/etc/smb/|${PREFIX}/etc/smb/|g" \
|
||||
${WRKSRC}/configure.pl \
|
||||
${WRKSRC}/doc/smb.conf \
|
||||
${WRKSRC}/smbldap_tools.pm
|
||||
.for i in smbldap_tools.pm ${SMBLDAP_TOOLS} \
|
||||
doc/migration_scripts/smbldap-migrate-pwdump-groups \
|
||||
doc/migration_scripts/smbldap-migrate-unix-accounts \
|
||||
doc/migration_scripts/smbldap-migrate-unix-groups \
|
||||
doc/migration_scripts/smbldap-migrate-pwdump-accounts
|
||||
@${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|g" \
|
||||
-e "s|/usr/sbin|${LOCALBASE}/sbin|g" \
|
||||
-e "s|/etc/opt/IDEALX|${PREFIX}/etc|g" \
|
||||
${WRKSRC}/$i
|
||||
.endfor
|
||||
${WRKSRC}/smbldap-config.pl
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/etc/smbldap-tools
|
||||
post-install:
|
||||
@${MKDIR} ${PREFIX}/etc/smbldap-tools
|
||||
.for i in smbldap.conf smbldap_bind.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/smbldap-tools/$i.sample
|
||||
@[ -f ${PREFIX}/etc/smbldap-tools/$i ] || ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/smbldap-tools/$i
|
||||
.endfor
|
||||
.for i in ${SMBLDAP_TOOLS}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/sbin
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/smbldap_tools.pm ${SITE_PERL}/
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/smb.conf ${EXAMPLESDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/slapd.conf ${EXAMPLESDIR}/
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/configure.pl ${EXAMPLESDIR}/
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MIGRATION_SCRIPTS)
|
||||
${MKDIR} ${DOCSDIR}/migration_scripts
|
||||
.for i in smbldap-migrate-pwdump-accounts smbldap-migrate-pwdump-groups \
|
||||
. for i in smbldap-migrate-pwdump-accounts smbldap-migrate-pwdump-groups \
|
||||
smbldap-migrate-unix-accounts smbldap-migrate-unix-groups
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/doc/migration_scripts/$i ${PREFIX}/sbin
|
||||
.endfor
|
||||
@${SED} -e 's|/usr/bin/perl|${PERL}|g' \
|
||||
${WRKSRC}/doc/migration_scripts/$i > ${PREFIX}/sbin/$i
|
||||
. endfor
|
||||
.endif
|
||||
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/smbldap-config.cmd ${DOCSDIR}/smbldap-config
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/smbldap-upgrade-0.9.6.cmd ${DOCSDIR}/smbldap-upgrade-0.9.6
|
||||
.for file in CONTRIBUTORS COPYING ChangeLog FILES INFRA INSTALL README TODO
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/
|
||||
.endfor
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (smbldap-tools-0.9.6.tar.gz) = e3bd27a5237c0f3f38c178b40cda982e0e4e9740c82949b40653f84d29becfe5
|
||||
SIZE (smbldap-tools-0.9.6.tar.gz) = 304912
|
||||
SHA256 (smbldap-tools-0.9.7.tar.gz) = f2401bf8ee2301e37dd351319f7ebc2aaf50d35d4d9941b737c677898b143378
|
||||
SIZE (smbldap-tools-0.9.7.tar.gz) = 334488
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.pl.orig 2010-11-15 15:45:49.000000000 +0100
|
||||
+++ configure.pl 2010-11-15 16:02:51.745592626 +0100
|
||||
--- smbldap-config.pl.orig 2011-10-13 11:26:12.939953317 +0200
|
||||
+++ smbldap-config.pl 2011-10-13 11:27:09.173960781 +0200
|
||||
@@ -48,7 +48,7 @@
|
||||
print "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-\n";
|
||||
|
||||
@ -7,9 +7,9 @@
|
||||
-my $test_smb=`pidof smbd`;
|
||||
+my $test_smb=`pgrep -x smbd`;
|
||||
chomp($test_smb);
|
||||
die "\nSamba need to be started first !\n" if ($test_smb eq "" || not defined $test_smb);
|
||||
die "\nSamba needs to be started first !\n" if ($test_smb eq "" || not defined $test_smb);
|
||||
|
||||
@@ -303,7 +303,7 @@
|
||||
@@ -290,7 +290,7 @@
|
||||
|
||||
my $default_computer_gidnumber=read_entry(". default computer gidNumber","","515",0);
|
||||
|
||||
@ -18,14 +18,23 @@
|
||||
|
||||
my $skeletonDir=read_entry(". default skeleton directory","","/etc/skel",0);
|
||||
|
||||
@@ -527,12 +527,12 @@
|
||||
# Allows not to use smbpasswd (if with_smbpasswd="0" in smbldap.conf) but
|
||||
@@ -441,7 +441,7 @@
|
||||
|
||||
# Login defs
|
||||
# Default Login Shell
|
||||
-# Ex: userLoginShell=\"/bin/bash\"
|
||||
+# Ex: userLoginShell=\"/bin/sh\"
|
||||
userLoginShell=\"$userLoginShell\"
|
||||
|
||||
# Home directory
|
||||
@@ -511,12 +511,12 @@
|
||||
# Allows not to use smbpasswd (if with_smbpasswd=\"0\" in smbldap.conf) but
|
||||
# prefer Crypt::SmbHash library
|
||||
with_smbpasswd=\"0\"
|
||||
-smbpasswd=\"/usr/bin/smbpasswd\"
|
||||
+smbpasswd=\"%%LOCALBASE%%/bin/smbpasswd\"
|
||||
|
||||
# Allows not to use slappasswd (if with_slappasswd="0" in smbldap.conf)
|
||||
# Allows not to use slappasswd (if with_slappasswd=\"0\" in smbldap.conf)
|
||||
# but prefer Crypt:: libraries
|
||||
with_slappasswd=\"0\"
|
||||
-slappasswd=\"/usr/sbin/slappasswd\"
|
Loading…
Reference in New Issue
Block a user