Fix build with gcc 4.2

Approved by:	portmgr (pav), MAINTAINER
This commit is contained in:
Max Khon 2007-11-06 17:08:12 +00:00
parent 8c91ed6fff
commit 197bc56956
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202545
2 changed files with 12 additions and 7 deletions

View File

@ -63,10 +63,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/eng/* ${DOCSDIR}
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- hpp/pktbase.hpp.orig 2007-11-05 16:01:21.000000000 +0600
+++ hpp/pktbase.hpp 2007-11-05 16:01:27.000000000 +0600
@@ -30,7 +30,7 @@
int CopyTail(FILE *tf);
int CopyMessages(FILE *tf);
int CopyOneMessage(FILE *tf);
- int PKTBASE::ReadHeader(FILE *tf, char *Buff);
+ int ReadHeader(FILE *tf, char *Buff);
public:
int WriteOneMsg(unsigned int Num, cMSG &m);
PKTBASE();