- Update to 0.99.2

- Remove DOCS option
- Adjust dependencies
This commit is contained in:
Olivier Duchateau 2017-01-24 21:42:48 +00:00
parent e5319d682e
commit 18d1c7c4b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432393
9 changed files with 43 additions and 220 deletions

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= lxde-common
PORTVERSION= 0.5.5
PORTREVISION= 6
PORTVERSION= 0.99.2
CATEGORIES= misc
MASTER_SITES= SF/lxde/${PORTNAME}%20%28default%20config%29/LXDE%20Common%20${PORTVERSION}/
MASTER_SITES= SF/lxde/${PORTNAME}%20%28default%20config%29/${PORTNAME}%20${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= LXDE Common files
@ -13,22 +12,20 @@ COMMENT= LXDE Common files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake iconv
USE_GNOME= gtk20
RUN_DEPENDS= lxde-icon-theme>=0:x11-themes/lxde-icon-theme \
gnome-themes-standard>=3.18:x11-themes/gnome-themes-standard \
xscreensaver:x11/xscreensaver
USES= gettext-tools gmake localbase tar:xz
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
GMSGFMT="${LOCALBASE}/bin/msgfmt" \
--with-xsession-path=${PREFIX}/share/xsessions \
--with-xdg-path=${PREFIX}/share/applications
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc \
--with-xsession-path=${PREFIX}/share/xsessions
NO_ARCH= yes
DATADIR= ${PREFIX}/share/lxde
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS
post-install:
${INSTALL_DATA} ${WRKSRC}/desktop.conf \
@ -36,8 +33,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf \
${STAGEDIR}${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (lxde-common-0.5.5.tar.gz) = ee18a09b64a442b33c1b54f0269649a1b4d9490460c400a07ed785d41bf6dde6
SIZE (lxde-common-0.5.5.tar.gz) = 899075
TIMESTAMP = 1485104743
SHA256 (lxde-common-0.99.2.tar.xz) = 1cd9bc900960c995d48ffbbdc86ecffda7c806168c67aaa50c53113794234856
SIZE (lxde-common-0.99.2.tar.xz) = 889948

View File

@ -1,12 +0,0 @@
--- Makefile.am.orig 2011-07-29 16:04:03.000000000 +0200
+++ Makefile.am 2013-06-21 19:58:35.000000000 +0200
@@ -6,6 +6,9 @@
xsessiondir=$(xsesspath)
xsession_DATA = LXDE.desktop
+xdgdir=$(xdgpath)
+xdg_DATA = lxde-logout.desktop
+
defaultsdir=$(sysconfdir)/xdg/lxsession/LXDE
defaults_DATA = autostart desktop.conf

View File

@ -1,121 +0,0 @@
--- Makefile.in.orig 2011-07-29 16:12:19.000000000 +0200
+++ Makefile.in 2013-06-21 21:33:42.000000000 +0200
@@ -79,7 +79,7 @@
"$(DESTDIR)$(imagesdir)" "$(DESTDIR)$(lxpaneldir)" \
"$(DESTDIR)$(lxpanel_paneldir)" "$(DESTDIR)$(openboxdir)" \
"$(DESTDIR)$(pcmanfmdir)" "$(DESTDIR)$(wallpapersdir)" \
- "$(DESTDIR)$(xsessiondir)"
+ "$(DESTDIR)$(xsessiondir)" "$(DESTDIR)$(xdgdir)"
SCRIPTS = $(bin_SCRIPTS)
SOURCES =
DIST_SOURCES =
@@ -92,7 +92,7 @@
ps-recursive uninstall-recursive
DATA = $(defaults_DATA) $(images_DATA) $(lxpanel_DATA) \
$(lxpanel_panel_DATA) $(openbox_DATA) $(pcmanfm_DATA) \
- $(wallpapers_DATA) $(xsession_DATA)
+ $(wallpapers_DATA) $(xsession_DATA) $(xdg_DATA)
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
distclean-recursive maintainer-clean-recursive
AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
@@ -214,14 +214,17 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
xsesspath = @xsesspath@
+xdgpath = @xdgpath@
SUBDIRS = man
bin_SCRIPTS = startlxde lxde-logout openbox-lxde
# Currently these paths are hardcoded.
xsessiondir = $(xsesspath)
xsession_DATA = LXDE.desktop
+xdgdir = $(xdgpath)
+xdg_DATA = lxde-logout.desktop
defaultsdir = $(sysconfdir)/xdg/lxsession/LXDE
-defaults_DATA = autostart desktop.conf
+defaults_DATA = autostart
wallpapersdir = $(datadir)/lxde/wallpapers
wallpapers_DATA = \
wallpapers/lxde_blue.jpg \
@@ -243,8 +246,7 @@
openbox/menu.xml
pcmanfmdir = $(sysconfdir)/xdg/pcmanfm/LXDE
-pcmanfm_DATA = \
- pcmanfm/pcmanfm.conf
+pcmanfm_DATA =
EXTRA_DIST = \
autostart \
@@ -508,6 +510,26 @@
test -n "$$files" || exit 0; \
echo " ( cd '$(DESTDIR)$(xsessiondir)' && rm -f" $$files ")"; \
cd "$(DESTDIR)$(xsessiondir)" && rm -f $$files
+install-xdgDATA: $(xdg_DATA)
+ @$(NORMAL_INSTALL)
+ test -z "$(xdgdir)" || $(MKDIR_P) "$(DESTDIR)$(xdgdir)"
+ @list='$(xdg_DATA)'; test -n "$(xdgdir)" || list=; \
+ for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ echo "$$d$$p"; \
+ done | $(am__base_list) | \
+ while read files; do \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(xdgdir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(xdgdir)" || exit $$?; \
+ done
+
+uninstall-xdgDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(xdg_DATA)'; test -n "$(xdgdir)" || list=; \
+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
+ test -n "$$files" || exit 0; \
+ echo " ( cd '$(DESTDIR)$(xdgdir)' && rm -f" $$files ")"; \
+ cd "$(DESTDIR)$(xdgdir)" && rm -f $$files
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
@@ -824,7 +846,7 @@
all-am: Makefile $(SCRIPTS) $(DATA)
installdirs: installdirs-recursive
installdirs-am:
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(defaultsdir)" "$(DESTDIR)$(imagesdir)" "$(DESTDIR)$(lxpaneldir)" "$(DESTDIR)$(lxpanel_paneldir)" "$(DESTDIR)$(openboxdir)" "$(DESTDIR)$(pcmanfmdir)" "$(DESTDIR)$(wallpapersdir)" "$(DESTDIR)$(xsessiondir)"; do \
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(defaultsdir)" "$(DESTDIR)$(imagesdir)" "$(DESTDIR)$(lxpaneldir)" "$(DESTDIR)$(lxpanel_paneldir)" "$(DESTDIR)$(openboxdir)" "$(DESTDIR)$(pcmanfmdir)" "$(DESTDIR)$(wallpapersdir)" "$(DESTDIR)$(xsessiondir)" "$(DESTDIR)$(xdgdir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-recursive
@@ -877,7 +899,7 @@
install-data-am: install-defaultsDATA install-imagesDATA \
install-lxpanelDATA install-lxpanel_panelDATA \
install-openboxDATA install-pcmanfmDATA install-wallpapersDATA \
- install-xsessionDATA
+ install-xsessionDATA install-xdgDATA
install-dvi: install-dvi-recursive
@@ -927,7 +949,7 @@
uninstall-imagesDATA uninstall-lxpanelDATA \
uninstall-lxpanel_panelDATA uninstall-openboxDATA \
uninstall-pcmanfmDATA uninstall-wallpapersDATA \
- uninstall-xsessionDATA
+ uninstall-xsessionDATA uninstall-xdgDATA
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) ctags-recursive \
install-am install-strip tags-recursive
@@ -945,7 +967,7 @@
install-info-am install-lxpanelDATA install-lxpanel_panelDATA \
install-man install-openboxDATA install-pcmanfmDATA \
install-pdf install-pdf-am install-ps install-ps-am \
- install-strip install-wallpapersDATA install-xsessionDATA \
+ install-strip install-wallpapersDATA install-xsessionDATA install-xdgDATA \
installcheck installcheck-am installdirs installdirs-am \
maintainer-clean maintainer-clean-generic mostlyclean \
mostlyclean-generic pdf pdf-am ps ps-am tags tags-recursive \
@@ -953,7 +975,7 @@
uninstall-defaultsDATA uninstall-imagesDATA \
uninstall-lxpanelDATA uninstall-lxpanel_panelDATA \
uninstall-openboxDATA uninstall-pcmanfmDATA \
- uninstall-wallpapersDATA uninstall-xsessionDATA
+ uninstall-wallpapersDATA uninstall-xsessionDATA uninstall-xdgDATA
# Tell versions [3.59,3.63) of GNU make to not export all variables.

View File

@ -1,41 +0,0 @@
--- configure.orig 2011-07-29 16:12:19.000000000 +0200
+++ configure 2013-06-21 20:48:19.000000000 +0200
@@ -568,6 +568,7 @@
XMLCATALOG
XML_CATALOG_FILE
XSLTPROC
+xdgpath
xsesspath
LN_S
am__untar
@@ -636,6 +637,7 @@
enable_option_checking
enable_man
with_xsession_path
+with_xdg_path
with_xml_catalog
'
ac_precious_vars='build_alias
@@ -1265,6 +1267,9 @@
--with-xsession-path=PATH
set the install path of xsession data
[[DATAROOTDIR/xsessions]]
+ --with-xdg-path=PATH
+ set the install path of xdg data
+ [[DATAROOTDIR/applications]]
--with-xml-catalog=CATALOG
path to xml catalog to use
@@ -2235,6 +2240,12 @@
xsesspath="\${datarootdir}/xsessions"
fi
+# Check whether --with-xdg-path was given.
+if test "${with_xdg_path+set}" = set; then :
+ withval=$with_xdg_path; test x$withval != x && xdgpath="$withval"
+else
+ xdgpath="\${datarootdir}/applications"
+fi

View File

@ -1,18 +0,0 @@
--- configure.ac.orig 2011-07-29 16:04:03.000000000 +0200
+++ configure.ac 2013-06-21 21:11:18.000000000 +0200
@@ -23,6 +23,15 @@
[xsesspath="\${datarootdir}/xsessions"])
AC_SUBST(xsesspath)
+# xdg data of path
+AC_ARG_WITH([xdg-path],
+ AS_HELP_STRING(
+ [--with-xdg-path=PATH],
+ [set the install path of xdg data [[DATAROOTDIR/applications]]]),
+ [test x$withval != x && xdgpath="$withval"],
+ [xdgpath="\${datarootdir}/applications"])
+AC_SUBST(xdgpath)
+
if test x"$enable_man" = x"yes"; then
AC_PATH_PROG([XSLTPROC], [xsltproc])

View File

@ -0,0 +1,11 @@
--- desktop.conf.orig 2014-09-01 14:17:11 UTC
+++ desktop.conf
@@ -2,7 +2,7 @@
window_manager=openbox-lxde
[GTK]
-sNet/ThemeName=Clearlooks
+sNet/ThemeName=Adwaita
sNet/IconThemeName=nuoveXT2
sGtk/FontName=Sans 10
iGtk/ToolbarStyle=3

View File

@ -0,0 +1,9 @@
--- pcmanfm/pcmanfm.conf.in.orig 2016-11-21 22:47:05 UTC
+++ pcmanfm/pcmanfm.conf.in
@@ -1,6 +1,5 @@
[config]
bm_open_method=0
-su_cmd=xdg-su -c '%s'
[desktop]
wallpaper_mode=crop

View File

@ -1,20 +1,21 @@
bin/lxde-logout
bin/openbox-lxde
bin/startlxde
etc/xdg/lxpanel/LXDE/config
etc/xdg/lxpanel/LXDE/panels/panel
etc/xdg/lxsession/LXDE/autostart
@sample etc/xdg/lxsession/LXDE/desktop.conf.sample
etc/xdg/openbox/LXDE/menu.xml
etc/xdg/openbox/LXDE/rc.xml
@sample etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
man/man1/lxde-logout.1.gz
man/man1/openbox-lxde.1.gz
man/man1/startlxde.1.gz
share/applications/lxde-logout.desktop
share/lxde/images/logout-banner.png
share/lxde/images/lxde-icon.png
share/lxde/openbox/menu.xml
share/lxde/openbox/rc.xml
share/lxde/wallpapers/lxde_blue.jpg
share/lxde/wallpapers/lxde_green.jpg
share/lxde/wallpapers/lxde_red.jpg
share/lxpanel/profile/LXDE/config
share/lxpanel/profile/LXDE/panels/panel
share/applications/lxde-screenlock.desktop
%%DATADIR%%/images/logout-banner.png
%%DATADIR%%/images/lxde-icon.png
%%DATADIR%%/wallpapers/lxde_blue.jpg
%%DATADIR%%/wallpapers/lxde_green.jpg
%%DATADIR%%/wallpapers/lxde_red.jpg
share/xsessions/LXDE.desktop