MFH: r500847 comms/hylafax: Update to 6.0.7

- Remove upstreamed [1] patch-libhylafax_FaxRecvInfo.c++
  - Pet portlint: section order, deprecated @exec

[1] http://git.hylafax.org/HylaFAX?a=commit;h=dfc8a6ffe5a6031c6df716186681f92dac0d07cb

Security:	3df5a920-6edc-11e9-a44b-0050562a4d7b

Approved by:	ports-secteam (joneum)
This commit is contained in:
Kubilay Kocak 2019-05-24 10:16:54 +00:00
parent e66addbe22
commit 18c8549c0c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q2/; revision=502447
4 changed files with 17 additions and 26 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hylafax
PORTVERSION= 6.0.6
PORTREVISION= 8
PORTVERSION= 6.0.7
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
@ -17,10 +16,13 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:print/afm
LIB_DEPENDS= libtiff.so:graphics/tiff \
libjbig.so:graphics/jbigkit
MAKE_JOBS_UNSAFE= yes
HAS_CONFIGURE= yes
USES= fakeroot ghostscript jpeg
USE_RC_SUBR= hylafax
MAKE_JOBS_UNSAFE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-INSTALL="" \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
--with-ZLIB=no --with-LIBZ=-lz \
@ -36,20 +38,24 @@ MAKE_ARGS+= OPTIMIZER="" -DOPTIMIZER
PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
SUB_FILES= pkg-message
USE_RC_SUBR= hylafax
OPTIONS_DEFINE= PAM NLS GAWK DOCS
OPTIONS_DEFAULT=PAM
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
NO_OPTIONS_SORT=yes
GAWK_DESC= Use gawk for scripts
PAM_CONFIGURE_OFF= --disable-pam
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
GAWK_BUILD_DEPENDS= gawk:lang/gawk
GAWK_RUN_DEPENDS= gawk:lang/gawk
GAWK_CONFIGURE_ON= --with-AWK="${LOCALBASE}/bin/gawk"
DOCS_CONFIGURE_ON= --with-HTML=yes
.include <bsd.port.options.mk>

View File

@ -1,2 +1,3 @@
SHA256 (hylafax-6.0.6.tar.gz) = 28926915b23ce7f5b4896de8ac5f58389c2c6e6bb73b4eee5bbd5129603bf7c0
SIZE (hylafax-6.0.6.tar.gz) = 1297412
TIMESTAMP = 1556939625
SHA256 (hylafax-6.0.7.tar.gz) = a3dcb1a7fd8794bd33cea9a9414c32da100119dd2131bd08ab3ab3749fc30315
SIZE (hylafax-6.0.7.tar.gz) = 1309111

View File

@ -1,16 +0,0 @@
PR: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=225372
Upstream: http://bugs.hylafax.org/show_bug.cgi?id=971
Obtained from: https://sourceforge.net/p/hylafax/HylaFAX+/2417/
See Also: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853448
--- libhylafax/FaxRecvInfo.c++.orig 2018-10-07 07:40:23 UTC
+++ libhylafax/FaxRecvInfo.c++
@@ -112,7 +112,7 @@ FaxRecvInfo::decode(const char* cp)
if (cp == NULL || cp[1] != ',' || cp[2] != '"')
return (false);
u_int i = 0;
- while (cp+2 != '\0') {
+ while (*(cp+2) != '\0') {
callid[i] = cp+3; // +1 for "/+1 for ,/+1 for "
if (*cp == '\"') break;
callid[i].resize(callid[i].next(0,'"'));

View File

@ -130,8 +130,8 @@ sbin/hylafax
%%NLS%%share/locale/vi/LC_MESSAGES/hylafax-server.mo
%%NLS%%share/locale/vi/LC_MESSAGES/libhylafax.mo
%%HYLAFAX_SPOOL%%/COPYRIGHT
@exec mkfifo -m 0600 %%HYLAFAX_SPOOL%%/FIFO
@exec chown uucp:dialer %%HYLAFAX_SPOOL%%/FIFO
@postexec mkfifo -m 0600 %%HYLAFAX_SPOOL%%/FIFO
@postexec chown uucp:dialer %%HYLAFAX_SPOOL%%/FIFO
@rmtry %%HYLAFAX_SPOOL%%/FIFO
%%HYLAFAX_SPOOL%%/bin/ps2fax.gs
%%HYLAFAX_SPOOL%%/bin/ps2fax.dps